1 2 3 Previous Next 34 Replies Latest reply on Feb 11, 2016 9:20 PM by User254377 Branched from an earlier discussion.

    Re: R12.2 Install

    user8565543

      Hi Hussein,

       

      I am also getting the same errors while installing EBS R12.2.0 fresh installation on RHEL 7- 64 bit OS, using startCD version 12.2.0.50 at Step 4 of 8 after 46% .

       

      Please help me in resolving this issue.

       

      Below is the log for your reference.

       

      Using /data/appshared122/evkvis/fs2/inst/apps/evkvis_evkvision122/temp/xmldocs/instToolPatches.xml

       

      Executing command: /data/R1220stage/startCD/Disk1/rapidwiz/jre/Linux_x64/1.6.0/bin/java -cp /data/appshared122/evkvis/fs2/inst/apps/evkvis_evkvision122/temp/ASInstallHome/fnd/../j11067592_fnd.zip:/data/appshared122/evkvis/fs2/inst/apps/evkvis_evkvision122/temp/ASInstallHome/fnd/java/3rdparty/stdalone/xmlparserv2.zip -Doracle.apps.fnd.txk.env_home=/data/appshared122/evkvis/fs2/EBSapps/appl/admin/evkvis_evkvision122/ -Doracle.apps.fnd.txk.runtime.config=/data/appshared122/evkvis/fs2/inst/apps/evkvis_evkvision122/temp/xmldocs/instToolPatches.xml oracle.apps.fnd.txk.config.InstallService

       

      Fatal Error: TXK Install Service

       

      oracle.apps.fnd.txk.config.ProcessStateException: OPatch process failed : Exit=100 See log for details. CMD= perl /data/appshared122/evkvis/fs2/EBSapps/10.1.2/OPatch/opatch.pl apply -verbose -silent   -ocmrf /data/appshared122/evkvis/fs2/inst/apps/evkvis_evkvision122/temp/ASInstallHome/fnd/admin/template/txkForms_ocm.rsp /data/appshared122/evkvis/fs2/inst/apps/evkvis_evkvision122/temp/patches/16271876/16271876

       

          at oracle.apps.fnd.txk.config.OPatchActionNode.processState(OPatchActionNode.java:312)

          at oracle.apps.fnd.txk.config.PatchActionNode.processState(PatchActionNode.java:187)

          at oracle.apps.fnd.txk.config.PatchNode.processState(PatchNode.java:338)

          at oracle.apps.fnd.txk.config.PatchesNode.processState(PatchesNode.java:79)

          at oracle.apps.fnd.txk.config.InstallNode.processState(InstallNode.java:68)

          at oracle.apps.fnd.txk.config.TXKTopology.traverse(TXKTopology.java:594)

          at oracle.apps.fnd.txk.config.InstallService.doInvoke(InstallService.java:224)

          at oracle.apps.fnd.txk.config.InstallService.invoke(InstallService.java:237)

          at oracle.apps.fnd.txk.config.InstallService.main(InstallService.java:291)

       

      Cannot patch 10.1.2 Tools.

       

      RW-50010: Error: - script has returned an error:   1

      RW-50004: Error code received when running external process.  Check log file for details.

      Running APPL_TOP Install Driver for evkvis instance

       

      ##################

       

      Log from ohclone.log

       

      copying /data/appshared122/evkvis/fs2/EBSapps/10.1.2/jlib/ojmisc.jar into jdk/jre/lib

      copying /data/appshared122/evkvis/fs2/EBSapps/10.1.2/jlib/ojmisc.jar into jdk/jre/lib

      checking - /data/appshared122/evkvis/fs2/EBSapps/10.1.2/oraInst.loc

      Validating oraInst.loc - /data/appshared122/evkvis/fs2/EBSapps/10.1.2/oraInst.loc

      checking - /etc/oraInst.loc

      Validating oraInst.loc - /etc/oraInst.loc

      Found oraInst.loc at - /etc/oraInst.loc

      Checking for 11g oracle home

      Running OUI CLI home cloning from within OracleHomeCloner:

        /data/appshared122/evkvis/fs2/EBSapps/10.1.2/oui/bin/runInstaller -debug -clone -silent -force -nolink -waitForCompletion -invPtrLoc /etc/oraInst.loc session:ORACLE_HOME=/data/appshared122/evkvis/fs2/EBSapps/10.1.2 oracle.as.j2ee.top:s_asInstanceName=evkvis_TOOLS__data_appshared122_evkvis_fs2_EBSapps_10_1_2 oracle.as.j2ee.top:s_adminName=ias_admin oracle.as.j2ee.top:s_adminPassword=welcome ORACLE_HOME_NAME=evkvis_TOOLS__data_appshared122_evkvis_fs2_EBSapps_10_1_2 -J-Doracle.installer.noLink=true

      ******************************

      Executing command sh -c "/data/appshared122/evkvis/fs2/EBSapps/10.1.2/oui/bin/runInstaller -debug -clone -silent -force -nolink -waitForCompletion -invPtrLoc /etc/oraInst.loc session:ORACLE_HOME=/data/appshared122/evkvis/fs2/EBSapps/10.1.2 oracle.as.j2ee.top:s_asInstanceName=evkvis_TOOLS__data_appshared122_evkvis_fs2_EBSapps_10_1_2 oracle.as.j2ee.top:s_adminName=ias_admin oracle.as.j2ee.top:s_adminPassword=welcome ORACLE_HOME_NAME=evkvis_TOOLS__data_appshared122_evkvis_fs2_EBSapps_10_1_2 -J-Doracle.installer.noLink=true ; echo ERRORCODE = $? ERRORCODE_END" Mon Jan 04 22:30:25 IST 2016

      Command returned

      Starting Oracle Universal Installer...

      No pre-requisite checks found in oraparam.ini, no system pre-requisite checks will be executed.

      Preparing to launch Oracle Universal Installer from /tmp/OraInstall2016-01-04_10-30-25PM. Please wait ...

      LD_LIBRARY_PATH environment variable :

      ERRORCODE = 255 ERRORCODE_END

      .end std out.

      The Java RunTime Environment was not found at /tmp/OraInstall2016-01-04_10-30-25PM/jre/bin/java. Hence, the Oracle Universal Installer cannot be run.

      Please visit http://www.javasoft.com and install JRE version 1.3.1 or higher and try again.

      : No such file or directory

       

      .end err out.

       

       

      Thanks in advance,

      Santhosh.

        • 1. Re: R12.2 Install
          Hussein Sawwan-Oracle

          Please collect ALL logs as per (Troubleshooting Rapid Install for E-Business Suite Release 12.2 (Doc ID 1378579.1)) in one zip/tar file and upload it here for us to review.

           

          Thanks,

          Hussein

          • 2. Re: R12.2 Install
            User254377

            Hi Santhosh,

             

            I'm having the same issue here. Would you please post resolution if you find any?

             

            Thanks,

            • 3. Re: R12.2 Install
              user8565543

              Hi Hussien,

               

              First of all thanks for your reply and sorry for delay response.

              Installing EBS R12.2.0 vision on RHEL 7 - 64 bit OS , using startCD version 12.2.0.50 facing error at Step 4 of 8 after 46%.

               

              I am not aware about how to upload a file , i am new to this, after few googling i am inserting a link here for  " EBS_R122_VISION_INSTLTION_ERROR.zip " which consists of below logs


              https://community.oracle.com/servlet/JiveServlet/downloadBody/991729-102-1-117910/EBS_R122_VISION_INSTLTION_ERROR.zip


              1. $INST_TOP/logs - 01071913.log

              2. $INST_TOP/admin/log - ohclone.log

              3. $INST_TOP/admin/log - ApplyAppsTechStack_01072107.log

              4. $INST_TOP/logs/ora/10.1.2/install - make_01072107.log

              5. /data/appshared122/evkvis/fs2/EBSapps/appl/admin/evkvis_evkvision122/logs - oracle.apps.fnd.txk.install0.log


              I have found the errors in all of the above logs but i was not able to find the exact reason for issue. Please help me out.


              Below are the inventory location details.


              [root@evkvision122 ~]#cat /data/appshared122/evkvis/fs2/EBSapps/10.1.2/oraInst.loc

              #Oracle Installer Location File Location

              #Fri Oct 26 10:39:26 PDT 2007

              inst_group=dba

              #inventory_loc=/mnt/orainventory

              inventory_loc=/d1/oraInventory

              [root@evkvision122 ~]#

              [root@evkvision122 ~]# cat /etc/oraInst.loc  ### Previously i have kept the central inventory at $RDBMS_ORACLE_BASE : /data/orasoft122/app/oracle

              inventory_loc=/oracle122/app/evkvis/oraInventory   ### now changed to this location but still same issue.

              [root@evkvision122 ~]#

               

              Thanks,

              Santhosh

              • 4. Re: R12.2 Install
                user8565543

                Hi Hussien,

                 

                Please help me regarding this issue , i am really unable to move forward from this.

                 

                User254377  Did you find any solution, if u have any please help me.


                Thanks

                Santhosh

                • 5. Re: R12.2 Install
                  User254377

                  Hi Santhosh,

                   

                  What hardware are you using? (We're on HP Proliant)

                  What's the filesystem format, ext3, ext4, xfs, etc? (We'er on xfs)

                  What's the directory that you'are trying to install on, root or a directory from the mounted point? (We have two filesystem, one for OS and the other one for Apps/DB)

                   

                  Thanks

                  • 6. Re: R12.2 Install
                    Hussein Sawwan-Oracle

                    Santhosh,

                     

                    Sorry for delay. I reviewed logs but couldn't find main log file which can be found at $TMP/<MMDDHHMM>/<MMDDHHMM>.log

                     

                    Have you logged a SR yet? Oracle support can track the issue via a SR better than the forum.

                     

                    Thanks,

                    Hussein

                    • 7. Re: R12.2 Install
                      user8565543

                      Hi User254377 ,

                       

                      Below are the Hardware details. It is Intel.

                       

                      Architecture:          x86_64

                      CPU op-mode(s):        32-bit, 64-bit

                      Byte Order:            Little Endian

                      CPU(s):                8

                      On-line CPU(s) list:   0-7

                      Vendor ID:             GenuineIntel

                      CPU family:            6

                      Model:                 63

                      Model name:            Intel(R) Xeon(R) CPU E5-2620 v3 @ 2.40GHz

                      Stepping:              2

                      CPU MHz:               2399.998

                      BogoMIPS:              4799.99

                      Hypervisor vendor:     VMware

                      Virtualization type:   full

                       

                      I am using the directory from the mounted point not in root. Format of file system on which i am installing is " xfs ". other mount points like / and /tmp is " ext4 "

                       

                      Filesystem                  Size  Used Avail Use% Mounted on

                      /dev/mapper/rhel-root        81G   59G   19G  77% /

                      devtmpfs                     32G     0   32G   0% /dev

                      tmpfs                        32G  8.1M   32G   1% /dev/shm

                      tmpfs                        32G   65M   32G   1% /run

                      tmpfs                        32G     0   32G   0% /sys/fs/cgroup

                      /dev/sda1                   190M   93M   83M  53% /boot

                      /dev/mapper/rhel-tmp        4.9G   47M  4.6G   1% /tmp

                      /dev/mapper/vg_xfs-lv_data  2.0T  483G  1.6T  24% /data    -->  I am installing in it.

                       

                      Installing as a dual user and using below directory structure for installation.

                       

                      /data/orasoft122/  -- >     RDBMS Home  (Having group permissions oracle122:dba with 775)

                      /data/oradata122/  -- >    RDBMS datafiles (Having group permissions oracle122:dba with 775)

                      /data/appshared122/ -->  APPS (Having group permissions applmgr122:dba with 775)

                       

                      Thanks,

                      Santhosh

                      • 8. Re: R12.2 Install
                        user8565543

                        Hi Hussein,


                        Thanks for your reply. I was not able to find the respective log in $TMP/<MMDDHHMM>/ folder, there is only one file in the folder that is "evkvision122_evkvis_apps2.xml" , Don't know whether it might be deleted accidental or with any other reason. Meanwhile if i will re- try the installation, i will check and share you that log again.


                        I didn't logged an SR yet and I just want to know whether this issue having resolution or it is a new one on which oracle team need to work on it, since i have seen few threads regarding the same issue in community, not answered any of those. Also i am unable to come to the conclusion whether it is a software (12.2.5 media) bug on RHEL 7 or it is an issue with rpms/hardware like mount point problem. If I built a stage with startCD49 will it work fine. Could you please suggest me.

                         

                        Thanks,

                        Santhosh

                        • 9. Re: R12.2 Install
                          User254377

                          Hi Santhosh,

                          I've got stuck on this issue for almost a month now. Have you tried installing on a directory on the root partition? I was able to install it successfully. That's not the place where I want to install but at least I narrowed down some of the issues.I'll post as soon as I make any progress.

                          Thanks,

                          • 10. Re: R12.2 Install
                            2617503

                            How much is /tmp space?-- I noticed your update..  "/tmp/OraInstall2016-01-04_10-30-25PM/jre/bin/java"

                             

                            Can you empty /dev/mapper/rhel-tmp        4.9G   47M  4.6G   1% /tmp folder and restart the installation. Minimum /tmp is 2GB required. I could see there is only 47M left from 4.6G.

                             

                            Regards,

                            Sunil.

                            • 11. Re: R12.2 Install
                              user8565543

                              Hi Sunil,

                               

                              Thanks for your reply, 47M  is used space not the available space. Alloted /tmp size 5G and available free /tmp size is 4.6 G. Below are the details, mentioned the same above. Please check. I have cleared /tmp , orainventory , RDBMS/APPS folders and tried re-installation,but the installation failed at same error again.

                               

                              The Filesystem                Size   Used   Avail   Use%   Mounted on

                              /dev/mapper/rhel-tmp        4.9G   47M   4.6G    1%       /tmp


                              @User254377 : Same with me as well, i am also struck with this issue for almost 20 days. I didn't tried installation on root mount point since i don't have space in it, allotted space for root mount point is : 82G


                              Thanks,

                              Santhosh

                              • 12. Re: R12.2 Install
                                user8565543

                                Hi,

                                 

                                I have run the RDA downloaded from (Doc 314422.1) . Below are the RDA results. Please check if these results are helpful for debugging.

                                 

                                Test "Oracle E-Business Suite Release 12 (12.2.0) Preinstall (Linux x86_64)" executed at 13-Jan-2016 18:33:35

                                 

                                Test Results

                                ~~~~~~~~~~~

                                ID     NAME                 RESULT  VALUE

                                ====== ==================== ======= ==========================================

                                A00100 OS Type              RECORD  RH7 64

                                A00200 OS Certified?        FAILED  Not certified [Red Hat 7 version]   ---> Why it is showing as not certified OS

                                A01010 ApplTierDirectory    RECORD  /data/appshared122/evkvis

                                A01020 A_T Valid?           PASSED  ATexists

                                A01030 A_T Permissions OK?  PASSED  CorrectPerms

                                A01040 A_T Disk Space       PASSED  OK

                                A01400 Got Software Tools?  FAILED  KshNotFound LdElsewhere Linux32Elsewhere

                                A02030 Limit Processes      SKIPPED Not on certified Linux system

                                A02050 Limit Descriptors    SKIPPED Not on certified Linux system

                                A02100 ENV Variable Unset   SKIPPED Not SuSE Linux Enterprise 10 or SuSE ...

                                A02210 Kernel Params OK?    SKIPPED Not on certified Linux system

                                A02240 NPTL Selected?       SKIPPED Not on certified Linux system

                                A03010 Space in tmp         PASSED  Available

                                A03050 Swap Space (MB)      RECORD  12903.99609375

                                A03060 Swap Space?          FAILED  Need at least 16 GB

                                A03510 IP Address           RECORD  103.231.78.229

                                A03530 Domain Name          RECORD  evkvision.com

                                A03540 /etc/hosts format    PASSED  Adequate IPv4 entry

                                A03550 DNS Lookup           FAILED  nslookup host.domain

                                A03560 Net Service Access?  PASSED  PermOk

                                A03570 Port 6000            PASSED  Free

                                A03580 Port Range OK?       SKIPPED Not on certified Linux system

                                A03590 DNS Settings         FAILED  ATTEMPTSUndef TIMEOUTUndef

                                A03600 SysNetw File         FAILED  Missing host.domain

                                A03610 NoNetwProf File      PASSED  OK

                                A04301 RPM OL5/64 OK?       SKIPPED Not Oracle Linux 5 64-bit

                                A04302 RPM OL6/64 OK?       SKIPPED Not Oracle Linux 6 64-bit

                                A04303 RPM OL7/64 OK?       SKIPPED Not Oracle Linux 7 64-bit

                                A04311 RPM RH5/64 OK?       SKIPPED Not Red Hat Enterprise Linux 5 64-bit

                                A04312 RPM RH6/64 OK?       SKIPPED Not Red Hat Enterprise Linux 6 64-bit

                                A04313 RPM RH7/64 OK?       PASSED  RH7/64rpmsOK

                                A04321 RPM SLES10/64 OK?    SKIPPED Not SuSE Linux Enterprise 10 64-bit

                                A04322 RPM SLES11/64 OK?    SKIPPED Not SuSE Linux Enterprise 11 64-bit

                                 

                                Thanks,

                                Santhosh

                                • 13. Re: R12.2 Install
                                  Narsi M-Oracle

                                  Hi,

                                   

                                  You can ignore the Error for RH7/OL7 not certified as per RDA.

                                  You need to fix "A01400 Got Software Tools?  FAILED  KshNotFound LdElsewhere Linux32Elsewhere".

                                  Looks like some essential tools are missing as per RDA.

                                  Hopefully, fixing it might help.

                                   

                                  Regards,

                                  Narsi

                                  • 14. Re: R12.2 Install
                                    User254377

                                    When I ran RDA, I got some errors that I think are not correct. I'm not sure this RDA is still valid for Linux 7.

                                    For example I got the "A01400 Got Software Tools" message but ar, gcc, g++, ksh, ld, linux32, make, X Display Server were installed already. You can also check RDBMS $ORACLE_HOME/appsutil/log/$CONTEXT_NAME/<MMDDHHMM>.log to see this is causing issues. My 2 cents...

                                    1 2 3 Previous Next