5 Replies Latest reply on Aug 6, 2007 5:40 PM by 581392

    Custom Purchase Order template causes Error while generating PDF

    329795
      The standard XSLFO works, my custom one errors:

      History of the world:
      1) I downloaded the XML Publisher thing for Word, installed it no problems
      2) Downloaded the XML data definition for the Standard Purchase Order from XML Publisher Administrator
      3) Created a blank word document and created the purchase order layout from scratch using the XML Publisher plug-in
      4) Previewed it as a PDF in word - it looked fine (well, it was a start)
      5) Exported the XSLFO
      6) In XML Publisher created a new template and uploaded the XSLFO
      7) Assigned the new template to the document in Purchasing

      All good... the new template is defintately the one being used by the PO Output for Communication program. The problem of course is that it throws a useless error message :) - namely:

      PoPrintingUtil.getBlobPDF(input,input) - After initializing the FOProcessor
      PoPrintingUtil.getBlobPDF(input,input) - After setting the i/o stream and output format
      PoPrintingUtil.getBlobPDF(input,input) - Error while generating the PDForacle.apps.xdo.XDOException
      genDoc() : Exceptionjava.lang.Exception: Error while generating PDF :null
      java.lang.Exception: Error while generating PDF :null
      java.lang.Exception: Error while generating PDF :null
           at oracle.apps.po.communicate.PoGenerateDocument.genDoc(PoGenerateDocument.java:2011)
           at oracle.apps.po.communicate.PoGenerateDocumentCP.runProgram(PoGenerateDocumentCP.java:421)
           at oracle.apps.fnd.cp.request.Run.main(Run.java:148)


      When I run POXPOPDF in Debug I get:

      getArchiveOn(): APPROVE
      After calling genDocThu May 18 12:50:05 EST 2006
      Adding the blob to vector
      java.lang.NullPointerException
      java.lang.NullPointerException
           at java.io.ByteArrayInputStream.<init>(ByteArrayInputStream.java:89)
           at oracle.apps.po.communicate.PoGenerateDocumentCP.runProgram(PoGenerateDocumentCP.java:304)
           at oracle.apps.fnd.cp.request.Run.main(Run.java:148)


      I know no one can magically fix this for me (I wish!) but does anyone have any suggestions on what to do next? I have no conditional formatting or any other more complex functionality, just a really boring PO layout with a logo.

      Any suggestions welcome, in the meantime I will keep trawling through Metalink in search of a clue ;)

      Thanks
      Jo
        • 1. Re: Custom Purchase Order template causes Error while generating PDF
          502042
          Hi Jo:
          Maybe I can magically fix this for you :)

          You did what I would recommend - use the Templat Builder for Word to generate the XSL-FO. I assume the problem you run into is version compatibility.

          The XSL-FO generate from a later version of Template Builder is not backward compatible with XML Publisher. So you will have to upgrade your XML Publisher patch to match the XML Publisher Desktop version you, should be fine.

          Alternatively you can downgrade your Template Builder version (if you haven't deployed 4.5. This is probably the safer approach to begin with - and check if it works.

          Hope that helps,
          Klaus
          • 2. Re: Custom Purchase Order template causes Error while generating PDF
            329795
            Thanks Klaus! See - magic is possible on the internet! :) I wouldn't have thought of that one...

            The apps install is a straight 11.5.10 (No CU1 or CU2) so it looks like 4.5 of XML Publisher and of course my desktop thing is 5.5. I can't find a desktop version of 4.5 available on Metalink to download - was it an Oracle Internal-Only release? So it looks like I'll have to upgrade XDO to 5.5 (or more acurately be really nice to the DBA), unless you know where I can get a copy of the desktop client for version 4.5?

            Thanks so much for your help!
            Jo
            • 3. Re: Custom Purchase Order template causes Error while generating PDF
              502042
              Hi Jo,

              The first version for which the Template Builder was released is 5.0

              Well, I guess I am one of the few who has a backported 4.5 version of the template builder. I did that for testing exactly your case. I just replaced our xdocore.jar file with the 4.5 version and it worked. The core.jar is not easily available. The files are part of the 4.5 patch, but I think it is too much work to get them out.

              However, I would strongly recommend to upgrade to a later version of XML Publisher. We made huge improvements, since 4.5 - performance, translation, RTF template capabilities....

              I just checked the process of converting an RTF template to FO and uploading it to EBS with 5.6.2 and it still worked. So it seems you can go straight to the latest version.

              Hope that helps,
              Klaus
              • 4. Re: Custom Purchase Order template causes Error while generating PDF
                329795
                Hi Klaus

                You were 100% on the money! We applied patch 4206181 to take XML Publisher to 5.5 and the PO is now printing - we're cooking with gas!

                Thanks for your speedy and knowledgable response!

                Jo
                • 5. Re: Custom Purchase Order template causes Error while generating PDF
                  581392
                  Hi Klaus
                  I have a similar scenario and would appreciate your guidance please.
                  We are running XML Pub version 5.6.1 on the server side and I need to export an RTF template to XSL-FO format. I have Template Builder version 5.6. Build 45.
                  I need to locate the 5.6.1 version of the xdocore.jar file in order to replace the one that I currently have in the jlib directory for template Builder 5.6 Build 45.
                  Can you please confirm that the 5.6.1 version of the xdocore.jar file actually exists and where I can find it.
                  This info would help me greatly.
                  Thanks you for your continued service to this forum

                  Regards

                  KH