3 Replies Latest reply on Mar 14, 2016 1:38 PM by Thomas Dodds

    Cannot connect BI to TimesTen

    Ray Kelly

      I am having trouble connecting OBIEE to TimesTen. I am using OBIEE 11.1.1.6 and TimesTen 11.2.2. I created the TimesTen datastore. Configured the odbc.ini and the sys.odbc.ini for the new datastore. I creating all of the objects in the TimesTen database from the Oracle database. I created a new ODBC connection on my local machine (MYSCHEMA_DSN). I create a new repository with a new Database using TimesTen V11 as the Database Type. I created a connect pool using Default ODBC 3.5 as the Call Interface. I tried using TimesTen ODBC 3.5 but when I use that and try to import metadata, it says TimesTen ODBC 3.5 Import is not supported. I changed the Call Interface to ODBC 3.5 and used MYSCHEMA_DSN as the Data Source Name (all other options were left as default). Using ODBC 3.5, I was able to import metadata from the TimesTen database. I created a BMM and Subject Area and deployed the repository. I open analytics and created a new analysis. When I go to the results tab, I get the following error: Odbc driver returned an error (SQLExecDirectW). Error Details Error Codes: OPR4ONWY:U9IM8TAC:OI2DL65P State: HY000. Code 10058. [NQODBC] [SQL_STATE: HY000] [nQSError: 10058] A general error has occurred. [nQSError: 43113] Message returned from OBIS. [nQSError: 14080] One of the unavailable physical database schemas ("ORADB".."SCHEMA1", "ORADB".."SCHEMA2") may have been required to answer this query. [nQSError: 14020] None of the fact tables are compatible with the query request TABLE1.COLUMN1. (HY000) I followed the steps at the following URL: http://www.rittmanmead.com/2012/07/exalytics-timesten-and-obiee-connectivity/ I tried multiple datastores against multiple oracle database schemas. Same problem. Any help would be appreciated.