11 Replies Latest reply on Jul 14, 2016 5:44 AM by trevor

    FDMEE sign flip not working

    KS_227

      We have recently upgraded to FDMEE 11.1.2.4.100. I am loading using a file based data load rule to HFM.

       

      I am having an issue with the Account mapping. It is not flipping the sign even though I have 'Change Sign' selected in the explicit map. Has anyone else seen this behavior before?

       

      I do not have Apply to rule selected by default but I have tried it using that option as well with no success.

        • 1. Re: FDMEE sign flip not working
          USER1211

          What exact version of HFM(including patch level) are you on ?

          Are you stating that if you take a file with one single record for an account which you have sign flip and load to have the sign is not flipping?

           

          Have you ensured that you are looking the precise intersection(all base level) in Smart View?

          • 2. Re: FDMEE sign flip not working
            KS_227

            Even before getting to HFM, I can see in FDMEE that it is not flipping the sign after the validate.

             

            Yes I have tried just the one line in the file and it still is not flipped.

            • 3. Re: FDMEE sign flip not working
              KS_227

              I have also tried recreating all the Account maps for this DLR with no luck.

              • 4. Re: FDMEE sign flip not working
                USER1211

                Tested on 11.2.4.100 and HFM 11.1.4.103 and the sign flip works fine.

                Can you delete the DLR , create a new one and try another file with a single record and ensure that the there are no other account maps which could be affecting the results.

                • 5. Re: FDMEE sign flip not working
                  PetePuskar

                  I've had sign flips work as expected in 11.1.2.4.100.

                   

                  When looking at the record in Workbench, click on the amount > View Mappings. Note the Account map. Then go to your mapping and confirm that the particular Account map is sign flipped.

                  • 6. Re: FDMEE sign flip not working
                    KS_227

                    All of my other DLR/location mappings work. But this particular one did not perform the sign flips. Everything was correct, DLR and mappings.

                     

                    I had to delete all dimension mappings and all DLR associated with this location and recreate from scratch. Any idea on how this kind of corruption could happen that would force it to be recreated?

                    • 7. Re: FDMEE sign flip not working
                      KS_227

                      It worked previously, but stopped flipping signs.

                      • 8. Re: FDMEE sign flip not working
                        USER1211

                        Glad you got it resolved. Remember to close the thread so other members from the community may be able to fine the solution timely in the future.

                        • 9. Re: FDMEE sign flip not working
                          KS_227

                          My question now was if anyone knows about what can cause a corruption of the DLR or mapping that would cause them to stop working correctly in 11.1.2.4.100?

                          • 10. Re: FDMEE sign flip not working
                            USER1211

                            There could be quite a few factors thus folks on the board would be speculating at best (no one on the board was able to replicate the issue you noted), since only you know the details around your environment (e.g. maybe it was how it was upgraded and something just got corrput etc).

                             

                            It might be something you open an Oracle SR and see if they have it as either a known FDMEE undocumented bug or they can start reviewing your environment logs and setup which could be a  long process as not sure you could easily replicate the issue?

                            You could also check maybe it was a DB(your DBA might be able to query if anything) issue in your environment.

                             

                            If you do open an Oracle SR certainly update the thread with the facts from that discovery when it is completed so other community members may know.

                            • 11. Re: FDMEE sign flip not working
                              trevor

                              I think I may have the solution for you. I had the same problem. The solution in my case was:

                               

                              Go into SQL Server and run

                              SELECT * FROM TDATAMAP

                              WHERE DIMNAME<>'ACCOUNT'

                              AND CHANGESIGN=1

                               

                              If you find any rows then

                              UPDATE TDATAMAP SET CHANGESIGN=0

                              WHERE DIMNAME<>'ACCOUNT'

                              AND CHANGESIGN=1

                               

                              So what had happened in our case is that we had imported 'Explicit' mappings for both the 'ACCOUNT' and 'UD2' dimensions ... but because we used the Excel template to import these mappings we managed to set the CHANGESIGN flag=1 on the UD2 mappings as well as the ACCOUNT mappings. If you were manually setting up the mappings in the FDMEE screen that wouldn't be possible. So we had actually created a double negative situation for ourselves. The FDMEE validation process was flipping the sign and then flipping it back again.