9 Replies Latest reply on Apr 14, 2016 12:38 PM by 2963369

    Need Help to apply patch in Oracle EBS Suite (financial)

    2963369

      Hello

       

      I am new to EBS and learning. Our current Oracle EBS suite version is 12.1.3 installed in 2014 . Our patch level is

       

      Installed products:

      Application Object Library R12.FND.B.3

      Application report Generator R12.RG.B3

      Assests R12.FA.B3.

      E-records R12.EDR.B.3

      General-Ledger R12.GL.B.3

      Payables R12.AP.B.3

      Purchasing R12.PO.B.3

      Receviables R12.AR.B.3

       

       

      select * from fnd_product_installations where patch_level like '%AD%';

      R12.AD.B.3

       

      Want to patch to current level of patch level code and would like to use Oracle E-Business Suite Release 12.1.3+ Recommended Patch Collection 3 [RPC3]

       

      To appy RPC i should be in the following level ad per readme doc.

       

      Required Code levels

      [required]

      This patch requires additional code levels to have been successfully applied to your system before it can be applied.  These code levels, as at the time that this patch was built, are listed below.  Please check 'My Oracle Support' to determine if any of these have been superseded
      
      • 12.1.3
      • R12.AD.B.delta.3
      • R12.AD.B.delta.6
      • R12.ADO.B.delta.7

       

      Question is how to get R12.ADO.B.delta before i apply this RPC3 patch(Patch 20203366:12.1.0)


      thanks

      James.

        • 1. Re: Need Help to apply patch in Oracle EBS Suite (financial)
          Bashar.

          Hi,

           

          First of all, why not apply the latest patch for 12.1.3 (RPC4)?

           

          The prerequisite patches are listed in the patch download page.

          You will need both AD.B.delta.6 and ADO.B.delta.7.

          Their patch numbers are 20395533 and 20390398.

           

          Regards,

          Bashar

          • 2. Re: Need Help to apply patch in Oracle EBS Suite (financial)
            2963369

            Thanks for you reply . i don't see it this blog (stephan)..

            https://blogs.oracle.com/stevenChan/entry/rpc3_ebs_12_1_3

             

            if RPC4 is the latest i should apply that. is it out there?

            thanks

            James

            • 3. Re: Need Help to apply patch in Oracle EBS Suite (financial)
              2963369

              Bashar

              since i am new to this.... please advise me which one to apply RPC3 or RPC4... this is going to be first patch since 2014... ..

              Thanks

              • 4. Re: Need Help to apply patch in Oracle EBS Suite (financial)
                Srini Chavali-Oracle

                RPC4 is cumulative and includes RPC3 content - see MOS Doc 2053709.1

                • 5. Re: Need Help to apply patch in Oracle EBS Suite (financial)
                  Bashar.

                  When you go to the patch download page, it will clearly mention that this patch has been superseded.

                  The latest patch to replace it is RPC4.

                  Follow the document referenced by Srini for details.

                   

                  Regards,

                  Bashar

                  • 6. Re: Need Help to apply patch in Oracle EBS Suite (financial)
                    2963369

                    i have downloaded RPC4 patchset. and i applied pre-requst patches.

                    when i apply this patch i stuck here.. any idea??

                     

                    There are now 4304 jobs remaining (current phase=A53):
                        2 running, 2 ready to run and 4300 waiting.

                    Assigned: file peaddasd.sql on worker  1 for product per username HR.
                    Assigned: file POS_SUPPLIER_SEARCH_INDEX.sql on worker  2 for product pos username POS.
                    Completed: file XDOLoader.class on worker  4 for product xdo username XDO.
                    Completed: file XDOLoader.class on worker  3 for product xdo username XDO.
                       FAILED: file peaddasd.sql on worker  1 for product per username HR.
                    Deferred: file peaddasd.sql on worker  1 for product per username HR.               (Deferment number 2 for this job)
                    Assigned: file peaddasd.sql on worker  1 for product per username HR.
                       FAILED: file peaddasd.sql on worker  1 for product per username HR.
                       FAILED: file POS_SUPPLIER_SEARCH_INDEX.sql on worker  2 for product pos username POS.
                    Deferred: file POS_SUPPLIER_SEARCH_INDEX.sql on worker  2 for product pos username POS.               (Deferment number 2 for this job)
                    Assigned: file POS_SUPPLIER_SEARCH_INDEX.sql on worker  2 for product pos username POS.
                       FAILED: file POS_SUPPLIER_SEARCH_INDEX.sql on worker  2 for product pos username POS.

                    ATTENTION: All workers either have failed or are waiting:

                               FAILED: file peaddasd.sql on worker  1.
                               FAILED: file POS_SUPPLIER_SEARCH_INDEX.sql on worker  2.

                    ATTENTION: Please fix the above failed worker(s) so the manager can continue.

                    • 7. Re: Need Help to apply patch in Oracle EBS Suite (financial)
                      Bashar.

                      Please post the errors from the logs of workers 1 & 2.

                       

                      Regards,

                      Bashar

                      • 8. Re: Need Help to apply patch in Oracle EBS Suite (financial)
                        2963369

                        worker1.log


                        234/1  PLS-00201: identifier 'INVALID_SEE_COMMENT_IN_SOURCE' must be declared
                        234/1  PL/SQL: Statement ignored

                        Hook: Before Process
                        --------------------
                        (PER_ZA_USER_HOOK_PKG.VALIDATE_PERSON_ADDRESS) There is a parameter to the call
                        procedure which is not available at this hook. Check your call procedure paramet
                        ers. Code to carry out this hook call has not been created.

                        BEGIN hr_api_user_hooks_utility.clear_hook_report; END;

                        *
                        ERROR at line 1:
                        ORA-06501: PL/SQL: program error
                        ORA-06512: at "APPS.HR_API_USER_HOOKS_UTILITY", line 891
                        ORA-06512: at line 1

                         

                        sqlplus -s APPS/***** @/u01/applmgr/apps/apps_st/appl/pos/12.0.0/patch/115/sql/POS_SUPPLIER_SEARCH_INDEX.sql
                        Connected.
                        DECLARE
                        *
                        ERROR at line 1:
                        ORA-20000: possearchindex.sql(700): ORA-20000: Exception at
                        POS_SUPPLIER_SEARCH_INDEX_PKG.create_index(1800): ORA-20000: Exception at
                        POS_SUPPLIER_SEARCH_INDEX_PKG.create_index(1800): ORA-29855: error occurred in
                        the execution of ODCIINDEXCREATE routine
                        ORA-20000: Oracle Text error:
                        DRG-10502: index POS_SUPPLIER_SEARCH_INDEX does not exist
                        DRG-11135: feature not generally available
                        ORA-06512: at line 57

                         

                        worker2.log

                         

                        DECLARE

                        *

                        ERROR at line 1:

                        ORA-20000: possearchindex.sql(500): ORA-20000: Exception at

                        POS_SUPPLIER_SEARCH_INDEX_PKG.create_index(1800): ORA-20000: Exception at

                        POS_SUPPLIER_SEARCH_INDEX_PKG.create_index(1800): ORA-29855: error occurred in

                        the execution of ODCIINDEXCREATE routine

                        ORA-20000: Oracle Text error:

                        DRG-10502: index POS_SUPPLIER_SEARCH_INDEX does not exist

                        DRG-11135: feature not generally available

                        ORA-06512: at line 57

                        • 9. Re: Need Help to apply patch in Oracle EBS Suite (financial)
                          2963369

                          i opened a TAR. they gave some patches and it' fixed the issue.

                          thanls