11 Replies Latest reply on Apr 9, 2016 12:45 AM by thatJeffSmith-Oracle

    Cannot install  any rpms related to SQL Developer

    Jhil

      Hi all,

       

      Tried to install SQL-Developer on my linux machine but getting error.

       

      Downloaded  JDK from Java SE Development Kit 8 - Downloads

      Linux x86  154.74 MB   jdk-8u77-linux-i586.rpm

       

      >> Installing JDK RPM

       

      # rpm -Uvih jdk-8u77-linux-i586.rpm
      Preparing...                ########################################### [100%]
         1:jdk1.8.0_77            ########################################### [100%]
      Unpacking JAR files...
              tools.jar...
      /usr/java/jdk1.8.0_77/bin/unpack200: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /usr/java/jdk1.8.0_77/bin/unpack200)
      Error: unpack could not create JAR file:
      
              /usr/java/jdk1.8.0_77/lib/tools.jar
      
      Please refer to the Troubleshooting section of the Installation Instructions
      on the download page.
              plugin.jar...
      /usr/java/jdk1.8.0_77/bin/unpack200: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /usr/java/jdk1.8.0_77/bin/unpack200)
      Error: unpack could not create JAR file:
      
              /usr/java/jdk1.8.0_77/jre/lib/plugin.jar
      
      Please refer to the Troubleshooting section of the Installation Instructions
      on the download page.
              javaws.jar...
      /usr/java/jdk1.8.0_77/bin/unpack200: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /usr/java/jdk1.8.0_77/bin/unpack200)
      Error: unpack could not create JAR file:
      
              /usr/java/jdk1.8.0_77/jre/lib/javaws.jar
      
      Please refer to the Troubleshooting section of the Installation Instructions
      on the download page.
              deploy.jar...
      /usr/java/jdk1.8.0_77/bin/unpack200: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /usr/java/jdk1.8.0_77/bin/unpack200)
      Error: unpack could not create JAR file:
      
              /usr/java/jdk1.8.0_77/jre/lib/deploy.jar
      
      Please refer to the Troubleshooting section of the Installation Instructions
      on the download page.
              rt.jar...
      /usr/java/jdk1.8.0_77/bin/unpack200: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /usr/java/jdk1.8.0_77/bin/unpack200)
      Error: unpack could not create JAR file:
      
              /usr/java/jdk1.8.0_77/jre/lib/rt.jar
      
      Please refer to the Troubleshooting section of the Installation Instructions
      on the download page.
              jsse.jar...
      /usr/java/jdk1.8.0_77/bin/unpack200: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /usr/java/jdk1.8.0_77/bin/unpack200)
      Error: unpack could not create JAR file:
      
              /usr/java/jdk1.8.0_77/jre/lib/jsse.jar
      
      Please refer to the Troubleshooting section of the Installation Instructions
      on the download page.
              charsets.jar...
      /usr/java/jdk1.8.0_77/bin/unpack200: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /usr/java/jdk1.8.0_77/bin/unpack200)
      Error: unpack could not create JAR file:
      
      
              /usr/java/jdk1.8.0_77/jre/lib/charsets.jar
      
      Please refer to the Troubleshooting section of the Installation Instructions
      on the download page.
              localedata.jar...
      /usr/java/jdk1.8.0_77/bin/unpack200: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /usr/java/jdk1.8.0_77/bin/unpack200)
      Error: unpack could not create JAR file:
      
              /usr/java/jdk1.8.0_77/jre/lib/ext/localedata.jar
      
      Please refer to the Troubleshooting section of the Installation Instructions
      on the download page.
              jfxrt.jar...
      /usr/java/jdk1.8.0_77/bin/unpack200: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /usr/java/jdk1.8.0_77/bin/unpack200)
      Error: unpack could not create JAR file:
      
              /usr/java/jdk1.8.0_77/jre/lib/ext/jfxrt.jar
      
      Please refer to the Troubleshooting section of the Installation Instructions
      on the download page.
      

       

       

       

      # rpm -Uvih sqldeveloper-4.1.3.20.78-1.noarch.rpm
      error: Failed dependencies:
              rpmlib(FileDigests) <= 4.6.0-1 is needed by sqldeveloper-4.1.3.20.78-1.noarch
              rpmlib(PayloadIsXz) <= 5.2-1 is needed by sqldeveloper-4.1.3.20.78-1.noarch
      

       

       

      Thanks

       

      Can anyone help me to troubleshoot  this issue ?