6 Replies Latest reply on Apr 13, 2016 5:52 AM by 839293

    Installation of 4.1.3 on Windows 10 fails

    839293

      On a fresh corporate Windows 10 Enterprise N (with admin rights).

       

      Download the "Windows 64-bit with JDK 8 included" zip package from OTN (Oracle SQL Developer Downloads)

       

      capture-1.PNG

       

      Unzip with Windows built-in unzip.

       

      Double click C:\Users\janihu\Downloads\sqldeveloper-4.1.3.20.78-x64\sqldeveloper\sqldeveloper.exe

       

      Error dialog: "Unable to launch the Java Virtual Machine Located at path: C:\Users\janihu\Downloads\sqldeveloper-4.1.3.20.78-x64\sqldeveloper\jdk\jre\bin\server\jvm.dll"

       

      capture-2.PNG

       

      The path seems to be correct:

       

      PS C:\> dir C:\Users\janihu\Downloads\sqldeveloper-4.1.3.20.78-x64\sqldeveloper\jdk\jre\bin\server\jvm.dll

       

          Directory: C:\Users\janihu\Downloads\sqldeveloper-4.1.3.20.78-x64\sqldeveloper\jdk\jre\bin\server

       

      Mode                LastWriteTime         Length Name

      ----                -------------         ------ ----

      -a----        11.4.2016     14.52        8755808 jvm.dll

       

      PS C:\>

       

      The same procedure works in my corporate Windows 7 Professional computer.

        • 1. Re: Installation of 4.1.3 on Windows 10 fails
          Gary Graham-Oracle

          Possibly your Windows 7 machine already had a C:\Users\<your-user>\AppData\Roaming\sqldeveloper\4.1.3\product.conf with its SetJavaHome line pointing to a valid JDK in C:\Program Files\Java. Otherwise, the ...x64.zip download either...

          1. Must have gotten changed or corrupted

          2. Must have never been good (surprising if the same version has been out there since Dec 22nd)

          We are looking into it.  As a workaround, update the SetJavaHome line in that product.conf file on Windows 10 to point to a recent Java 8 JDK install.

          1 person found this helpful
          • 2. Re: Installation of 4.1.3 on Windows 10 fails
            Gary Graham-Oracle

            Alternatively, I see that launching directly from the command line works.  That is...SQLDev413x63CmdLine.jpg

            using the sqldeveloper.exe in the top sqldeveloper directory or lower down in the bin directory. 

            Then looking in Help > About > Properties, filtering on jdk in the property name, we can see \

            that the bundled JDK is actually being used.

             

            SQLDev413x63CmdLineJDKProps.jpg

            But when launching directly from Windows Explorer or from a convenient shortcut on my desktop, the error

            appears.  Here is a sample using a shortcut on the sqldeveloper.exe in the bin directory...

            SQLDev413x63Shortcut.jpg

            This needs to be fixed, and apparently has been the behavior for all the 4.1.x releases.  The last release I

            downloaded the x64.zip was 4.0.2, and running from Windows Explorer or a shortcut works properly for that.

            I

            1 person found this helpful
            • 3. Re: Installation of 4.1.3 on Windows 10 fails
              839293

              Thank you for taking my concern seriously. I tried running 4.1.3 from the command line too (powershell but that shouldn't matter ?) but unfortunately I keep getting the same problem.

               

              In my Windows 7 computer I checked file C:\Users\<your-user>\AppData\Roaming\sqldeveloper\4.1.3\product.conf. All lines are commented out (e.g. # SetJavaHome /path/jdk) and checking the properties indeed show the bundled JDK is used.

               

              In my Windows 10 computer I tried all the following SQL Developer versions with bundled JDK that are currently available for download:

               

              • 4.0.2 - works in my Windows 10
              • 4.0.3 - works in my Windows 10
              • 4.1.1 - fails in my Windows 10
              • 4.1.3 - fails in my Windows 10

               

              (4.1.0 requires a separate JDK installation so I didn't try it.)

               

              The error messages of 4.1.1 and 4.1.3 are identical.

               

              I hope you'll find the root cause and will be able to provide a fixed zip file that works in Windows 10 too !

              • 4. Re: Installation of 4.1.3 on Windows 10 fails
                Gary Graham-Oracle

                Update:  I repeated the test on a laptop that was upgraded from WIndows 7 to WIndows 10, but the problem did not reproduce.  And that got me to thinking...

                 

                Actually this seems to be a variation on an old problem.  Over the years there has been a dependency on a Microsoft Visual C++ redistributable, either msvcr71.dll or msvcr100.dll, depending on the which Windows / Java.  Usually when SQL Developer cannot find the necessary flavor of that dll, there are two error messages, i.e.,

                1. msvcr100.dll not found

                2. unable to launch the java virtual machine located at...

                It seems that in this particular case, the first message does not appear, but the missing dll is the underlying reason we are unable to launch.

                 

                Solution:  Even though some hate it (as in Issue running SQL Developer x64 4.1.3 with JDK), get a copy of msvcr100.dll from the JDK and copy it into the sqldeveloper\bin directory.  I did that on my Windows 7 machine and now running from a shortcut or from Explorer works fine.

                1 person found this helpful
                • 5. Re: Installation of 4.1.3 on Windows 10 fails
                  Gary Graham-Oracle

                  No msvcr100.dll not found message appeared in my case originally because one was actually found. Unfortunately it was from an old 32-bit install of an unrelated application, not a 64-bit version that 64-bit Java requires.  It is always a good idea to check the exact DDL being used...

                   

                  On Linux...             which msvcr100.dll   (will list the one being used)

                  On Windows...       where msvcr100.dll   (will list all in the current directory or along PATH)

                   

                  By the way, the one in C:\Windows\system32 is 32-bit, so definitely grab one from the embedded JDK and copy it to sqldeveloper\bin if none of your other C:\Program Files applications using that DLL have their directories included in PATH.

                  1 person found this helpful
                  • 6. Re: Re: Installation of 4.1.3 on Windows 10 fails
                    839293

                    I see ...

                     

                    I copied C:\Program Files\Oracle\VirtualBox\msvrc100.dll to C:\Users\janihu\Downloads\sqldeveloper-4.1.3.20.78-x64\sqldeveloper\sqldeveloper\bin\ (I bet you see the joke)


                    And now SQL Developer 4.1.3 works.


                    You're correct that I'm not a big fan about your (not you as a person, but you as a company) "solution" Issue running SQL Developer x64 4.1.3 with JDK. Anyway thanks for pointing it out !