OPMN is not running and OPMN start attempt  failed

Beauty_and_dBest

    Hi ALL,

     

    EBS R12.1.3

    OL6

    11g

     

     

    Just today we were not able to statup our instance, with the following errors:

     

    Executing service control script:

    /u01/appuat/UAT/inst/apps/UAT_erp/admin/scripts/adoacorectl.sh start

    script returned:

    ****************************************************

    You are running adoacorectl.sh version 120.13

    Starting OPMN managed OACORE OC4J instance  ...

    adoacorectl.sh: exiting with status 2

    =================================

     

    I already check > adoacorectl.sh: check the logfile /u01/appuat/UAT/inst/apps/UAT_erp/logs/appl/admin/log/adoacorectl.txt for more information ...

    Below are the only info given:

     

    05/03/16-10:49:03 :: adoacorectl.sh version 120.13

    05/03/16-10:49:03 :: adoacorectl.sh: starting OPMN if it is not running

    opmnctl: opmn start failed.

    05/03/16-10:49:10 :: adoacorectl.sh: OPMN is not running and OPMN start attempt  failed

    05/03/16-10:49:10 :: adoacorectl.sh: Could not start OPMN managed OACORE OC4J instance

    05/03/16-10:49:10 :: adoacorectl.sh: exiting with status 2

    ==================================

     

    Executing service control script:

    /u01/appuat/UAT/inst/apps/UAT_erp/admin/scripts/adformsctl.sh start

    script returned:

    ****************************************************

    You are running adformsctl.sh  version 120.16.12010000.3

    Starting OPMN managed FORMS OC4J instance  ...

    adformsctl.sh: exiting with status 2

    adformsctl.sh: check the logfile /u01/appuat/UAT/inst/apps/UAT_erp/logs/appl/admin/log/adformsctl.txt for more information ...

    =================================

    05/03/16-11:19:31 :: adformsctl.sh version 120.16.12010000.3

    05/03/16-11:19:31 :: adformsctl.sh: starting OPMN if it is not running

    opmnctl: opmn start failed.

    05/03/16-11:19:38 :: adformsctl.sh: OPMN is not running and OPMN start attempt  failed

    05/03/16-11:19:38 :: adformsctl.sh: Could not start OPMN managed FORMS OC4J instance

    05/03/16-11:19:38 :: adformsctl.sh: exiting with status 2

    ================================================================================

     

     

    Where can I get the details of the error?

     

     

     

     

     

    Please help...

     

    Kind regards,

    jc

      • 1. Re: OPMN is not running and OPMN start attempt  failed
        Ramaraju

        Hi,

        Once check with following Oracle Doc ID:

        R12: OPMN start failed after 11i upgrade or after cloning R12 (Doc ID 836688.1)

         

        Thanks,

        Ramaraju

        1 位用户发现它有用
        • 2. Re: OPMN is not running and OPMN start attempt  failed
          Beauty_and_dBest

          Hi Ramaju,

           

          We have been using this instance for months, and it just got issues today

          What made it  corrupted?

          • 3. Re: OPMN is not running and OPMN start attempt  failed
            Ramaraju

            Is this cloned instance?

            If yes when you did clone?

             

            Thanks,

            Ramaraju

            1 位用户发现它有用
            • 4. Re: OPMN is not running and OPMN start attempt  failed
              Beauty_and_dBest

              Yes this is a clone instance, but we have been using this for sometime. i

              The developers where the last using it, deploying and testing their programs.

              Are they capable of corrupting the OPMN folders?

               

              Kind regards,

              • 5. Re: OPMN is not running and OPMN start attempt  failed
                Beauty_and_dBest

                I already followed the note you gave > (Doc ID 836688.1)

                But still this three module scripts have the same error

                I even clone again from the PROD (appstier only), and still the new clone got error the same error now.

                I also run autoconfig on both db & appstier, but still to no avail

                 

                Please help....

                 

                 

                 

                 

                Executing service control script:

                /u01/appuat/UAT/inst/apps/UAT_erp/admin/scripts/adoacorectl.sh start

                script returned:

                ****************************************************

                You are running adoacorectl.sh version 120.13

                Starting OPMN managed OACORE OC4J instance  ...

                adoacorectl.sh: exiting with status 2

                adoacorectl.sh: check the logfile /u01/appuat/UAT/inst/apps/UAT_erp/logs/appl/admin/log/adoacorectl.txt for more information ...

                .end std out.

                .end err out.

                ****************************************************

                Executing service control script:

                /u01/appuat/UAT/inst/apps/UAT_erp/admin/scripts/adformsctl.sh start

                script returned:

                ****************************************************

                You are running adformsctl.sh  version 120.16.12010000.3

                Starting OPMN managed FORMS OC4J instance  ...

                adformsctl.sh: exiting with status 2

                adformsctl.sh: check the logfile /u01/appuat/UAT/inst/apps/UAT_erp/logs/appl/admin/log/adformsctl.txt for more information ...

                .end std out.

                .end err out.

                ****************************************************

                Executing service control script:

                /u01/appuat/UAT/inst/apps/UAT_erp/admin/scripts/adoafmctl.sh start

                script returned:

                ****************************************************

                You are running adoafmctl.sh version 120.8

                Starting OPMN managed OAFM OC4J instance  ...

                adoafmctl.sh: exiting with status 2

                adoafmctl.sh: check the logfile /u01/appuat/UAT/inst/apps/UAT_erp/logs/appl/admin/log/adoafmctl.txt for more information ...

                • 6. Re: OPMN is not running and OPMN start attempt  failed
                  Ramaraju

                  Hi,

                  Post following log files once.

                  /u01/appuat/UAT/inst/apps/UAT_erp/logs/appl/admin/log/adoacorectl.txt

                  /u01/appuat/UAT/inst/apps/UAT_erp/logs/appl/admin/log/adformsctl.txt

                  /u01/appuat/UAT/inst/apps/UAT_erp/logs/appl/admin/log/adoafmctl.txt

                   

                   

                  Thanks,

                  Ramaraju

                  • 7. Re: OPMN is not running and OPMN start attempt  failed
                    Beauty_and_dBest

                    I already posted it above

                     

                     

                    [root@erp ~]# cat /u01/appuat/UAT/inst/apps/UAT_erp/logs/appl/admin/log/adoacorectl.txt

                    05/03/16-13:10:49 :: adoacorectl.sh version 120.13

                    05/03/16-13:10:49 :: adoacorectl.sh: starting OPMN if it is not running

                     

                    opmnctl: opmn start failed.

                     

                    05/03/16-13:10:56 :: adoacorectl.sh: OPMN is not running and OPMN start attempt  failed

                    05/03/16-13:10:56 :: adoacorectl.sh: Could not start OPMN managed OACORE OC4J instance

                    05/03/16-13:10:56 :: adoacorectl.sh: exiting with status 2

                    ================================================================================

                     

                    [root@erp ~]# cat /u01/appuat/UAT/inst/apps/UAT_erp/logs/appl/admin/log/adformsctl.txt

                    05/03/16-13:10:56 :: adformsctl.sh version 120.16.12010000.3

                    05/03/16-13:10:56 :: adformsctl.sh: starting OPMN if it is not running

                     

                    opmnctl: opmn start failed.

                     

                    05/03/16-13:11:03 :: adformsctl.sh: OPMN is not running and OPMN start attempt  failed

                    05/03/16-13:11:03 :: adformsctl.sh: Could not start OPMN managed FORMS OC4J instance

                    05/03/16-13:11:03 :: adformsctl.sh: exiting with status 2

                    ================================================================================

                     

                    [root@erp ~]# cat /u01/appuat/UAT/inst/apps/UAT_erp/logs/appl/admin/log/adoafmctl.txt

                    05/03/16-13:11:04 :: adoafmctl.sh version 120.8

                    05/03/16-13:11:04 :: adoafmctl.sh: starting OPMN if it is not running

                     

                    opmnctl: opmn start failed.

                     

                    05/03/16-13:11:11 :: adoafmctl.sh: OPMN is not running and OPMN start attempt  failed

                    05/03/16-13:11:11 :: adoafmctl.sh: Could not start OPMN managed OAFM OC4J instance

                    05/03/16-13:11:11 :: adoafmctl.sh: exiting with status 2

                     

                    ================================================================================

                     

                    [root@erp ~]#

                    • 8. Re: OPMN is not running and OPMN start attempt  failed
                      Ramaraju

                      Please post following

                      $LOG_HOME/ ora/ 10.1.3/ opmn/ opmn.log

                      adopmnctl.sh status

                      • 9. Re: OPMN is not running and OPMN start attempt  failed
                        Beauty_and_dBest

                        $ adopmnctl.sh status

                         

                        You are running adopmnctl.sh version 120.6.12010000.5

                        Checking status of OPMN managed processes...

                        Unable to connect to opmn.

                        Opmn may not be up.

                        adopmnctl.sh: exiting with status 0

                        adopmnctl.sh: check the logfile /u01/appuat/UAT/inst/apps/UAT_erp/logs/appl/admin/log/adopmnctl.txt for more information ...

                         

                         

                        $ cat $LOG_HOME/ora/10.1.3/opmn/opmn.log

                         

                        16/05/03 14:03:02 [pm-internal] OPMN server ready.  Request handling enabled.

                        16/05/03 14:03:02 [ons-listener] 172.31.14.118,6210: BIND (Address already in use)

                        16/05/03 14:03:10 [ons-internal] ONS server initiated

                        16/05/03 14:03:10 [pm-internal] PM state directory exists: /u01/appuat/UAT/inst/apps/UAT_erp/ora/10.1.3/opmn/logs/states

                        16/05/03 14:03:10 [pm-internal] PM state file does not exist: /u01/appuat/UAT/inst/apps/UAT_erp/ora/10.1.3/opmn/logs/states/.opmndat

                        16/05/03 14:03:10 [pm-internal] OPMN server ready.  Request handling enabled.

                        16/05/03 14:03:10 [ons-listener] 172.31.14.118,6210: BIND (Address already in use)

                        16/05/03 14:03:17 [ons-internal] ONS server initiated

                        16/05/03 14:03:17 [pm-internal] PM state directory exists: /u01/appuat/UAT/inst/apps/UAT_erp/ora/10.1.3/opmn/logs/states

                        16/05/03 14:03:17 [pm-internal] PM state file does not exist: /u01/appuat/UAT/inst/apps/UAT_erp/ora/10.1.3/opmn/logs/states/.opmndat

                        16/05/03 14:03:17 [pm-internal] OPMN server ready.  Request handling enabled.

                        16/05/03 14:03:17 [ons-listener] 172.31.14.118,6210: BIND (Address already in use)

                        16/05/03 14:03:24 [ons-internal] ONS server initiated

                        16/05/03 14:03:24 [pm-internal] PM state directory exists: /u01/appuat/UAT/inst/apps/UAT_erp/ora/10.1.3/opmn/logs/states

                        16/05/03 14:03:24 [pm-internal] PM state file does not exist: /u01/appuat/UAT/inst/apps/UAT_erp/ora/10.1.3/opmn/logs/states/.opmndat

                        16/05/03 14:03:24 [pm-internal] OPMN server ready.  Request handling enabled.

                        16/05/03 14:03:24 [ons-listener] 172.31.14.118,6210: BIND (Address already in use)

                        16/05/03 14:03:31 [ons-internal] ONS server initiated

                        16/05/03 14:03:31 [pm-internal] PM state directory exists: /u01/appuat/UAT/inst/apps/UAT_erp/ora/10.1.3/opmn/logs/states

                        16/05/03 14:03:31 [pm-internal] PM state file does not exist: /u01/appuat/UAT/inst/apps/UAT_erp/ora/10.1.3/opmn/logs/states/.opmndat

                        16/05/03 14:03:31 [pm-internal] OPMN server ready.  Request handling enabled.

                        16/05/03 14:03:31 [ons-listener] 172.31.14.118,6210: BIND (Address already in use)

                        • 10. Re: OPMN is not running and OPMN start attempt  failed
                          Ramaraju

                          Is this instance single node or multi node?

                          Please post following.

                          ps -ef|grep 6210

                           

                          Thanks,

                          Ramaraju

                          1 位用户发现它有用
                          • 11. Re: OPMN is not running and OPMN start attempt  failed
                            Beauty_and_dBest

                            This is single node. Both apps & db tiers in one server only.

                             

                            $ ps -ef|grep 6210

                            appuat   17603 16867  0 15:13 pts/0    00:00:00 grep 6210

                             

                            No 6210 found, what is this port for? Maybe the command is netstat?

                            • 12. Re: OPMN is not running and OPMN start attempt  failed
                              Ramaraju

                              Please bring down all the application services and bounce the database. Make sure there is no background services running for this instance. If you have any kill them.

                              Then restart the application services.

                               

                              Thanks,

                              Ramaraju

                              • 13. Re: OPMN is not running and OPMN start attempt  failed
                                Beauty_and_dBest

                                Hi Ram,

                                 

                                I have been doing that many times but to no avail

                                 

                                Why is that even my new clone got the same error.

                                 

                                 

                                Kind regards,

                                • 14. Re: OPMN is not running and OPMN start attempt  failed
                                  Ramaraju

                                  Bring down the all application services and do the following and check it once.

                                   

                                  Clear directory under persistence from below directory and restart all three OC4J

                                  $ORA_CONFIG_HOME/ 10.1.3/ j2ee/ oacore/ persistence

                                  $ORA_CONFIG_HOME/ 10.1.3/ j2ee/ oafm/ persistence

                                  $ORA_CONFIG_HOME/ 10.1.3/ j2ee/ forms/ persistence

                                   

                                  Thanks,

                                  Ramaraju

                                  1 2 上一个 下一个