1 Reply Latest reply on Jun 20, 2016 4:36 PM by Lori B.

    EBS 12.2 patch filesystem creation failing

    Lori B.

      I performed a new clone from production.  Everything is working correctly for the run filesystem.  All configs are done.  I want to create the patch filesystem, i need to apply some patches.  I have done this many times with no problem.  Here are the steps I am following:

      my dir structure is:

      /1hub/ebs/appl/fs1/  --run

      /1hub/ebs/appl/fs2/  --patch

      run adpreclone.pl on run filesystem

      copy /1hub/ebs/appl/fs1/EBSapps  to /ehut/ebs/appl/fs2/

       

      the app tier is up for all of this

       

      next i cd to /1hub/ebs/appl/fs2/EBSapps/comn/clone/bin

      I run perl adcfgclone.pl appsTier

      Target System File Edition type [run] : patch

      context file location is /1hub/ebs/appl/fs1/inst/apps/E1HUB02_cnpra01a0113/appl/admin/E1HUB02_cnpra01a0113.xml

      port 98

       

      Everything progresses however in the end it fails.

       

      the first error message i see in the log is:

      Updating s_tnsmode to 'generateTNS'

      UpdateContext exited with status: 0

      AC-50480: Internal error occurred: java.lang.Exception: Error while generating listener.ora.

      Error generating tnsnames.ora from the database, temporary tnsnames.ora will be generated using templates

      Instantiating Tools tnsnames.ora

      Tools tnsnames.ora instantiated

       

      adgentns.pl exiting with status 2

      end std out.

      .end err out.

      Result             : FAILED

       

      all the other error message play off of this.   I have looked up the issue in metalink. I followed some notes, did fnd_clean_setup...reran autoconfig on db tier, then reran autoconfig on apps tier run filesystem.  Everything went ok...no errors.   Again tried to create the patch file system and it is failing.  I have tried probably 20 times at least and can't find anyway to get this patch top created.  Does anyone have any ideas on this? I would appreciate anything you can think of.

       

      Thanks Lori

        • 1. Re: EBS 12.2 patch filesystem creation failing
          Lori B.

          Posting this answer because it is a bit of a strange issue. 

           

          When the patch top is created, it connect to the database via the service ebs_patch.  On the database tier the listener you refer to in you init file as LOCAL_LISTENER  needs to have the service ebs_patch registered to it.  So for example:

          my listener is E1HUB02.  When I did a status on E1HUB02 , the service ebs_patch was not registered. Since this is supposed to happen dynamically, if its not registered you will get the AC-50480: Internal error occurred: java.lang.Exception: Error while generating listener.ora.  Because you are unable to connect to the ebs_patch service.  My problem specifically was that my E1HUB02 listener was down when i configured my database. But a listener named 'LISTENER' was running on port 1521.  Also I had unset LOCAL_LISTENER when i did my clone so, when i brought up the database it automatically registered ebs_patch with the listener on port 1521. I didn't realize this, and brought up my E1HUB02 listener on port 1528.  My database registered with 1528, but the ebs_patch stayed on 1521 listener.  Once i fixed all of this mess, everything worked perfectly.