0 Replies Latest reply on Jun 22, 2016 8:47 AM by Ahmed Hamdy

    RC-50013: Fatal: Instantiate driver did not complete successfully - regclone.drv

    Ahmed Hamdy

      Hello

      we have just upgraded our database from 10.2.0.4 to 11.2.0.4 following oracle note 1058763.1

      and implemented autoconfig on the source instance successfully , adpreclone script runs successfully wihtout any error .

      BUT , on target instance , the following is the log file contents of the ADCFGCLONE script .

      DB : 11.2.0.4

      APPS : 12.1.3

      OS : WINDOWS SERVER 2008 R2 SP2 64Bit .

      ********************************************************************************************************************

      #############################################################

      Started ApplyDBTier at Tue Jun 21 19:58:00 AST 2016

      Version:

          ApplyDBTier.java    :     120.6.12010000.3

      #############################################################

      ApplyDBTier (prog) -1 true true true...

      # Calling ApplyDBTechStack...

      Executing runInstallDriver...

      Started unzipping files...

      Completed runInstallDriver.

       

       

      Executing home registration for s_db_oh...

       

      instantiate file:

         source : D:\ORACLE\database\product\11.2.0\dbhome_1\appsutil\template\adouidb.pl

         dest   : D:\ORACLE\database\product\11.2.0\dbhome_1\appsutil\clone\ouicli.pl

         backup : D:\ORACLE\database\product\11.2.0\dbhome_1\appsutil\clone\ouicli.pl to D:\ORACLE\database\product\11.2.0\dbhome_1\appsutil\out\ouicli.pl

         setting permissions: 700

       

      Executing script in InstantiateFile:

      D:\ORACLE\database\product\11.2.0\dbhome_1\Perl\5.8.3\bin\MSWin32-X64-multi-thread\perl.exe -I D:\ORACLE\database\product\11.2.0\dbhome_1\perl\5.8.3\lib\MSWin32-X64-multi-thread -I D:\ORACLE\database\product\11.2.0\dbhome_1\perl\5.8.3\lib -I D:\ORACLE\database\product\11.2.0\dbhome_1\perl\site\5.8.3\lib\MSWin32-X64-multi-thread -I D:\ORACLE\database\product\11.2.0\dbhome_1\perl\site\5.8.3\lib -I D:\ORACLE\database\product\11.2.0\dbhome_1\appsutil\perl D:\ORACLE\database\product\11.2.0\dbhome_1\appsutil\clone\ouicli.pl

       

      RC-50208: Exception  in method TimedProcessProcess.run

      Raised by oracle.apps.ad.util.TimedProcess$TimedProcessProcess: java.io.IOException: CreateProcess: "D:\ORACLE\database\product\11.2.0\dbhome_1\Perl\5.8.3\bin\MSWin32-X64-multi-thread\perl.exe" -I D:\ORACLE\database\product\11.2.0\dbhome_1\perl\5.8.3\lib\MSWin32-X64-multi-thread -I D:\ORACLE\database\product\11.2.0\dbhome_1\perl\5.8.3\lib -I D:\ORACLE\database\product\11.2.0\dbhome_1\perl\site\5.8.3\lib\MSWin32-X64-multi-thread -I D:\ORACLE\database\product\11.2.0\dbhome_1\perl\site\5.8.3\lib -I D:\ORACLE\database\product\11.2.0\dbhome_1\appsutil\perl D:\ORACLE\database\product\11.2.0\dbhome_1\appsutil\clone\ouicli.pl error=3

      script returned:

      ****************************************************

       

      Exception in TimedProcess...Failed to  execute command = D:\ORACLE\database\product\11.2.0\dbhome_1\Perl\5.8.3\bin\MSWin32-X64-multi-thread\perl.exe -I D:\ORACLE\database\product\11.2.0\dbhome_1\perl\5.8.3\lib\MSWin32-X64-multi-thread -I D:\ORACLE\database\product\11.2.0\dbhome_1\perl\5.8.3\lib -I D:\ORACLE\database\product\11.2.0\dbhome_1\perl\site\5.8.3\lib\MSWin32-X64-multi-thread -I D:\ORACLE\database\product\11.2.0\dbhome_1\perl\site\5.8.3\lib -I D:\ORACLE\database\product\11.2.0\dbhome_1\appsutil\perl D:\ORACLE\database\product\11.2.0\dbhome_1\appsutil\clone\ouicli.pl****************************************************

       

       

      instantiate file:

         source : D:\ORACLE\database\product\11.2.0\dbhome_1\appsutil\template\adouidb.pl

         dest   : D:\ORACLE\database\product\11.2.0\dbhome_1\appsutil\clone\ouicli.pl

         backup : D:\ORACLE\database\product\11.2.0\dbhome_1\appsutil\clone\ouicli.pl to D:\ORACLE\database\product\11.2.0\dbhome_1\appsutil\out\ouicli0.pl

         setting permissions: 700

       

       

       

      [AutoConfig Error Report]

      The following report lists errors AutoConfig encountered during each

      phase of its execution.  Errors are grouped by directory and phase.

      The report format is:

            <filename>  <phase>  <return code where appropriate>

       

        [APPLY PHASE]

        AutoConfig could not successfully execute the following scripts:

          Directory: D:\ORACLE\database\product\11.2.0\dbhome_1\Perl\5.8.3\bin\MSWin32-X64-multi-thread\perl.exe -I D:\ORACLE\database\product\11.2.0\dbhome_1\perl\5.8.3\lib\MSWin32-X64-multi-thread -I D:\ORACLE\database\product\11.2.0\dbhome_1\perl\5.8.3\lib -I D:\ORACLE\database\product\11.2.0\dbhome_1\perl\site\5.8.3\lib\MSWin32-X64-multi-thread -I D:\ORACLE\database\product\11.2.0\dbhome_1\perl\site\5.8.3\lib -I D:\ORACLE\database\product\11.2.0\dbhome_1\appsutil\perl D:\ORACLE\database\product\11.2.0\dbhome_1\appsutil\clone

            ouicli.pl               INSTE8_APPLY       -1

       

       

      AutoConfig is exiting with status 1

       

      RC-50013: Fatal: Instantiate driver did not complete successfully.

      D:\ORACLE\database\product\11.2.0\dbhome_1\appsutil\driver\regclone.drv

      ********************************************************************************************************************

      i see the problem that script is trying to call D:\ORACLE\database\product\11.2.0\dbhome_1\Perl\5.8.3\bin\MSWin32-X64-multi-thread\perl.exe

      which is not a valid location in our 11.2.0.4 instance

      As you know the tmp file used to create the new XML file for the host is adxdbctx.tmp , which contains that path in perl

      Knowing that i set these ENV variables before starting the adcfgclone script .

      set PATH=D:\oracle\DATABASE\product\11.2.0\dbhome_1\perl\bin;%PATH%

       

      set PERL5LIB=D:\ORACLE\database\product\11.2.0\dbhome_1\perl\lib;D:\ORACLE\database\product\11.2.0\dbhome_1\perl\lib\5.10.0;D:\ORACLE\database\product\11.2.0\dbhome_1\perl\lib\site_perl\5.10.0;D:\ORACLE\database\product\11.2.0\dbhome_1\appsutil\perl

       

      set ADPERLPRG=D:\oracle\DATABASE\product\11.2.0\dbhome_1\perl\bin\perl.exe

       

      But still Doesnt work either .

      Kindly help me solving my database clone issue .

       

      Regards