1 Reply Latest reply on Jul 20, 2016 10:28 PM by VishnuVinnakota

    apps in RFS - 12.2

    1811468

      We upgraded from applications with DB 11.2.0.4 from 12..0.6 to 12.2.5 . upgrade is fine. but after upgrade keeping the trigger ebs_logon as enabled , user apps is not able to login

       

      [applprod@erpapp01 patch]$ sqlplus apps/password

       

      SQL*Plus: Release 10.1.0.5.0 - Production on Mon Jul 18 02:00:03 2016

       

      Copyright (c) 1982, 2005, Oracle. All rights reserved.

       

      ERROR:

      ORA-00604: error occurred at recursive SQL level 1

      ORA-20099: E-Business Suite Patch Edition does not exist.

      ORA-06512: at line 29

       

       

      [applprod@erpapp01 patch]$ echo $FILE_EDITION

      run

       

      SQL> select status from dba_triggers where trigger_name='EBS_LOGON';

       

      STATUS

      --------

      ENABLED

       

      After a long troublehsooting, I found the below

       

      pplprod@erpapp01 applprod]$ echo $FILE_EDITION

      run

      [applprod@erpapp01 applprod]$ sqlplus apps/password

       

      SQL*Plus: Release 10.1.0.5.0 - Production on Mon Jul 18 03:01:32 2016

       

      Copyright (c) 1982, 2005, Oracle. All rights reserved.

       

       

      Connected to:

      Oracle Database 11g Enterprise Edition Release 11.2.0.4.0 - 64bit Production

      With the Partitioning, OLAP, Data Mining and Real Application Testing options

       

      SQL> select sys_context('userenv', 'service_name') from dual;

       

      SYS_CONTEXT('USERENV','SERVICE_NAME')

      --------------------------------------------------------------------------------

      ebs_patch

       

       

      it is suppose to be PROD for RFS..

       

      I tried changing in context file, but still it showing as ebs_patch only

        • 1. Re: apps in RFS - 12.2
          VishnuVinnakota

          Once run autoconfig on DB and then APPS.

           

          Check service_names and if it doesn't have both ebs_patch and DB_NAME, then try

           

          alter system set service_names='PROD','ebs_patch' scope=both;

           

          Bounce application services once.

           

          Check if everything is fine..

           

          Then will tell next steps to make permanent changes.

           

          Thanks,

          Vishnu