2 Replies Latest reply on Aug 21, 2016 6:22 AM by Dr.Anty

    EBS R12 URL doesn't worke

    Dr.Anty

      Hello Experts

      I Have installed ebs r12 successfully, and URL was working properly.

       

      but i try to  start and stop the applications service, unfortunately URL doesn't working now...

       

      i GOOGLE IT , I figure out the  owner of server-wsdl file was root, I have changed to be applmgr.

      /data/applmgr/inst/apps/GNDB_of1/ora/10.1.3/j2ee/oacore/application-deployments/oacore/html/server-wsdl

       

      the second issue is the  .lock file exists in one of the following directories: I have changed to be

       

      $INST_TOP/ora/10.1.3/j2ee/oacore/persistence/*

      $INST_TOP/ora/10.1.3/j2ee/oafm/persistence/*

      $INST_TOP/ora/10.1.3/j2ee/forms/persistence/*

      /data/applmgr/inst/apps/GNDB_of1/ora/10.1.3/j2ee/oacore/persistence/oacore_default_group_1/

       

      but  Oracle HTTP Server GNDB_of1          adapcctl.sh      Failed as you can see..

       

      [applmgr@OF1 scripts]$ ./adstrtal.sh apps/apps

       

      [applmgr@OF1 scripts]$ taill -33 /data/applmgr/inst/apps/GNDB_of1/logs/appl/admin/log/adstrtal.log

      -bash: taill: command not found

       

      [applmgr@OF1 scripts]$ taill -33 /data/applmgr/inst/apps/GNDB_of1/logs/appl/admin/log/adstrtal.log

      -bash: taill: command not found

      [applmgr@OF1 scripts]$ tail -33 /data/applmgr/inst/apps/GNDB_of1/logs/appl/admin/log/adstrtal.log

      .end std out.

      .end err out.

      ***************************************************

       

      [Service Control Execution Report]

      The report format is:

        <Service Group>            <Service>                            <Script>         <Status>

       

       

        Root Service                                                                     Enabled

        Root Service               Oracle Process Manager for GNDB_of1  adopmnctl.sh     Started

        Web Entry Point Services                                                         Enabled

        Web Entry Point Services   Oracle HTTP Server GNDB_of1          adapcctl.sh      Failed

        Web Entry Point Services   OracleTNSListenerAPPS_GNDB_of1       adalnctl.sh      Started

        Web Application Services                                                         Enabled

        Web Application Services   OACORE OC4J Instance GNDB_of1        adoacorectl.sh   Started

        Web Application Services   FORMS OC4J Instance GNDB_of1         adformsctl.sh    Started

        Web Application Services   OAFM OC4J Instance GNDB_of1          adoafmctl.sh     Started

        Batch Processing Services                                                        Enabled

        Batch Processing Services  OracleConcMgrGNDB_of1                adcmctl.sh       Started

        Batch Processing Services  Oracle Fulfillment Server GNDB_of1   jtffmctl.sh      Started

        Other Services                                                                   Disabled

        Other Services             OracleFormsServer-Forms GNDB_of1     adformsrvctl.sh  Disabled

        Other Services             Oracle Metrics Client GNDB_of1       adfmcctl.sh      Disabled

        Other Services             Oracle Metrics Server GNDB_of1       adfmsctl.sh      Disabled

        Other Services             Oracle MWA Service GNDB_of1          mwactlwrpr.sh    Disabled

       

      ========================================

      HTTP_Server    is DOWN...

       

      [applmgr@OF1 scripts]$ ./adopmnctl.sh status

      You are running adopmnctl.sh version 120.6

      Checking status of OPMN managed processes...

      Processes in Instance: GNDB_of1.of1.un.com.kw

      ---------------------------------+--------------------+---------+---------

      ias-component                    | process-type       |     pid | status

      ---------------------------------+--------------------+---------+---------

      OC4JGroup:default_group          | OC4J:oafm          |   14720 | Alive 

      OC4JGroup:default_group          | OC4J:forms         |   14651 | Alive 

      OC4JGroup:default_group          | OC4J:oacore        |   14571 | Alive 

      HTTP_Server                      | HTTP_Server        |     N/A | Down  

       

      ServiceControl is exiting with status 1

       

      please advice...

       

      Regards,

        • 1. Re: EBS R12 URL doesn't worke
          Shaik

          Hi

           

          What is the OS?

           

          It seems you have missed the post step as per the document Oracle E-Business Suite Installation and Upgrade Notes Release 12 (12.1.1) for Linux x86-64 (Doc ID 761566.1)

           

          AFTER INSTALLING OR UPGRADING

          =================================

           

          Perform the following steps after installing or upgrading to Release 12.1.1 and before allowing users to access the system.

           

           

          Update AS 10g (10.1.2 and 10.1.3) Oracle Homes (Oracle Linux 6, RHEL 6, Oracle Linux 7 and RHEL 7 only)

           

           

          After installation, users must update the stub libraries in the 10.1.2 and 10.1.3 Oracle Homes using the patch 12415211. In following the instructions below, please note that Opatch should not be used to install this patch.

           

           

          Users must specifically copy the files in the patch to the specified directories as follows for the 10.1.2 Oracle Home:

           

           

          $ cd <12.1_INSTALL_DIR>/apps/tech_st/10.1.2/lib

          $ cp -p -R stubs stubsORIG

          $ cd stubs

          $ cp <PATCH_INSTALL_DIR>/12415211/files/lib/stubs/libgcc_s-2.3.2-stub.so .

          $ ln -s libgcc_s-2.3.2-stub.so libgcc_s.so.1

          $ ln -s libgcc_s.so.1 libgcc_s.so

          After this is done and sourcing the APPS<CONTEXT_NAME>.env file, users should relink all 10.1.2 executables by running the $ORACLE_HOME/appsutil/clone/adlnktools.sh script and ensuring that there are now no errors in the make log file output from the script.

           

           

           

          Regards

          Shaik

          • 2. Re: EBS R12 URL doesn't worke
            Dr.Anty

            Hello Shaik

             

            Thanks for your response, the problem was privileges only, some files was owned by root.

            I have changed to be owned by applmgr.

             

            Thanks,