This discussion is archived
1 2 Previous Next 16 Replies Latest reply: Oct 2, 2009 12:36 PM by 725643 RSS

Platform service is unavailable

ma*437221*sh Newbie
Currently Being Moderated
Hello -

I am running OWB 10.2.0.1 on a Linux x86-64 platform and am unable to start the control center service. After ensuring the ORACLE_HOME is set correctly, as well as the ORACLE_SID, I go to the following directory:
cd $ORACLE_HOME/owb/bin/unix
I then run the local_service_login.sh file via the following command:
./local_service_login.sh -startup $ORACLE_HOME
The correct login screen pops up and I am able to enter in my credentials (the repository owner credentials). After hitting enter, it acts just as I think it should but when I attempt to enter the Control Center Manager from the Design Center, it pops up the error RTC-5301stating the Control Center Service is not currently available.

I have tried all sort of combinations of logging out of the Design Center and logging back in/starting up and stopping the control center service but the same error continues to plague me.

After peforming a little bit of research, I discovered that you could also start up the control center service via the start_service.sql file in the $ORACLE_HOME/owb/rtp/sql directory. So, I logged on as the repository owner, executed the start_service.sql file and received the following message:

Not available
Diagnostics:
service startup failure using command "/owb/bin/unix/run_service.sh -manual 1
OWB_REP_OWNER 192.168.0.7 1521 OWB" reason ORA-29532: Java call terminated by u
ncaught Java exception: java.io.IOException: can't exec: /owb/bin/unix/run_serv
ice.sh doesn't exist

I then ran the show_service.sql file and received the following message:

Not available

I then ran the service_doctor.sql file and received the following message:

All PL/SQL packages and functions are valid
Platform properties have been loaded correctly
Platform location has been seeded correctly
NLS messages have been loaded correctly
The platform service is not available
There is a problem accessing the service startup script from the database server
Here is the detailed error message which contains the name of the start script file:-
Service startup file 'null/owb/bin/unix/run_service.sh' is not accessible from the database server on instance number 1
Please verify that the disk containing the file is visible to the database server
Please verify that the database server account has access rights on the file
Connection information stored within the repository is correct

I found it a little curious that the ORACLE_HOME was null in the above message, seeing as I have double checked millions of times via the 'env' command in Linux and verified that ORACLE_HOME is in fact populated correctly (perhaps this is not how ORACLE retrieves the ORACLE_HOME, however. In which case, how does ORACLE retrieve the ORACLE_HOME?). I have attempted to review the PL/SQL that OWB generates and uses in the start_service.sql file, but could not read it because the code is 'wrapped'.

Is this a bug that anyone else has dealt with, or am I just overlooking something. I have read other posts about this topic for previous releases and did not find a solution that has yet worked. Any help would be awesome,
Mark

P.S. I should also mention that I am running everything OWB related through a VNC client (because my machine is a Windows machine while my client has OWB loaded on a Linux machine). When I start the control center service from my Windows machine for my client's OWB instance, the control center service does become available and everything is hunky-dory. However, this will not be a great solution once I pass the knowledge on to them and they start running everything from that Linux box via a VNC client as well (their repository is not located on the same network that their developers currently develop on, and since OWB is very chatty, this is the solution we have chosen to implement).
  • 1. Re: Platform service is unavailable
    469012 Newbie
    Currently Being Moderated
    Hi

    I am facing the same problem as u faced with Control Center Manager - The service is not currently available.

    As u did I have also tried all possible combinations but nothing worked out..

    have u found a solution for yours ? can u pls share the same..

    Thanks & Regards
    Chandra Sekar A.
  • 2. Re: Platform service is unavailable
    ma*437221*sh Newbie
    Currently Being Moderated
    I have not found a solution yet. I'm still waiting for someone to respond with a solution.

    Sorry.
  • 3. Re: Platform service is unavailable
    519269 Newbie
    Currently Being Moderated
    Hi Mark.

    See if there's any error message in the logfile:
    $OWB_HOME\owb\log

    How is the job_queue_processes in your db?
    SQL> show parameter job_queue_process

    NAME                                 TYPE        VALUE
    ------------------------------------ ----------- ------------------------------
    job_queue_processes                  integer     2
    It must be > 0.


    have you recently changed any repository users' password?

    Regards,
    Marcos
  • 4. Re: Platform service is unavailable
    519269 Newbie
    Currently Being Moderated
    Also found this info:
    HOW TO CHANGE THE PASSWORD OF RUNTIME REPOSITORY 
      Doc ID:  Note:278772.1 Type:  BULLETIN
      Last Revision Date:  19-JUL-2004 Status:  PUBLISHED


    PURPOSE
    -------
    When the password of the Runtime Repository user has been changed in the
    database for OWB 9.2 to 10G, the Runtime Platform Service will fail to start.
    To fix this, The changed password must also be propagated in the Runtime
    Repository tables. This article explains how to do this.

    SCOPE & APPLICATION
    -------------------

    The password in the Runtime Repository must be changed with script:
    - <owb home>/owb/rtp/sql/set_repository_password.sql


    HOW TO CHANGE THE PASSWORD OF RUNTIME REPOSITORY
    ------------------------------------------------
    Warehouse Builder has a specific procedure to do this for the
    runtime repository user. The steps are below:
    .
    1. logon to the runtime repository using the old password.
    2. run script <owb home>/owb/rtp/sql/stop_service.sql
    3. alter user <repository owner> identified by <new password>
    4. run script <owb home>/owb/rtp/sql/set_repository_password.sql
    5. when prompted, specify the new password
    6. run script <owb home>/owb/rtp/sql/start_service.sql
  • 5. Re: Platform service is unavailable
    ma*437221*sh Newbie
    Currently Being Moderated
    Marcos,

    I just looked in the log directory and nothing was there. I also checked on the log_queue_process parameter and the 'value' was greater than 0 (it was 10).

    I then followed the steps above for changing the password of the runtime repository, but failed at step number (6), for the same reason as mentioned above in the original posting (the script does not recognize the oracle home and fails attempting to execute 'null/owb/bin/unix/run_service.sh' because it does not exist.

    Thanks for your help though. Do you have any other suggestions?

    Mark
  • 6. Re: Platform service is unavailable
    519269 Newbie
    Currently Being Moderated
    Hey Mark.
    Could you send the output for (In your linux db server):
    env | grep ORACLE_HOME

    I believe the ORACLE_HOME info should be present before the bold text:

    ORA-29532: Java call terminated by uncaught Java exception: java.io.IOException: can't exec: /owb/bin/unix/run_serv

    The ORACLE_HOME env. should point to the OWB installation home.

    Now lemme ask you:
    Are you using a windows client to access this database via VPN? I don't think the VPN is a problem, don't worry about that. For now...

    Regards,
    Marcos
  • 7. Re: Platform service is unavailable
    ma*437221*sh Newbie
    Currently Being Moderated
    Sure...

    ORACLE_HOME=/usr/app/oracle/product/owb

    And no, I am not using a Windows client to access this database. I am using a VNC client to access the Linux machine over on their system. Once connected, I am running the scripts from that box directly. So, while VPN is used in order to make the connection happen, I am using all internal IP's.

    Mark
  • 8. Re: Platform service is unavailable
    519269 Newbie
    Currently Being Moderated
    Hi Mark.
    It seems like OWB is looking for the scripts in the following directory:
    /usr/app/oracle/product/owb/owb/bin/unix/run_service.sh

    Does this exists? If it doesn't, try seting ORACLE_HOME=/usr/app/oracle/product/.

    Is there any other Oracle Product installed in this directory tree? Such as the database, etc.

    Is OWB and DB installed on the same box? There might be some conflict you have more than one Oracle home.

    Regards,
    Marcos
  • 9. Re: Platform service is unavailable
    ma*437221*sh Newbie
    Currently Being Moderated
    Marcos,

    Not sure this is pertinant, but thought I would mention that I am working on a Linux box that has two database instances (AKFINDW2 and OWB). As far as I can tell, there are two Oracle homes: 1) /usr/app/oracle/product/10.2.0/db_1 & 2) /usr/app/oracle/product/owb. So, to answer your question...yes, the following directory does exist:
    /usr/app/oracle/product/owb/owb/bin/unix/run_service.sh

    Not sure how to answer the question concerning other Oracle Products being installed in that directory tree. As far as I know, Warehouse Builder is the only product installed in /usr/app/oracle/product/owb, but I'm not sure how I would check on that.

    And, even though I answered this above...yes, OWB and DB are installed on the same box.

    Hope this helps in determining my issue,
    Mark
  • 10. Re: Platform service is unavailable
    519269 Newbie
    Currently Being Moderated
    As you stated in your first post, it is really odd having NULL in the error message:
    Service startup file 'null/owb/bin/unix/run_service.sh' is not accessible from the database server on instance number 1
    At this point, I can only give you few suggestions of what I'd look for...
    Check if there's OS restrictions acessing the file. Can you perform a "chmod 777 run_service.sh" and retry? Still, I don't really think this is the reason.
    It seems like the Repository Assistant software, for some reason, does not recognize the ORACLE_HOME variable. I thought that could be due to having more than one Oracle Home, that this could cause conflicts, but i guess i was wrong.
    Plus, check the UTL_FILE_DIR parameter, in the instance you are runing the sql script. Try to include the $OWB_HOME\owb\bin\unix directory in this. Not sure this is going to help.
    Also, try to run run_service_local.sh instead of run_service.sh.
    I know this sounds stupid, but, did you bounced your server? I had this same issue few years ago, but it was a different OWB and DB version. Restarting database used to work, but I can't assure this will help you. And I guess you don't want to restart it every single time the runtime platform service fails...

    You may also look at this and see it helps you in any way:
    Re: OWB execution error : ORA-20213: Unable to create standalone job record


    Good luck.
    Marcos
  • 11. Re: Platform service is unavailable
    487013 Newbie
    Currently Being Moderated
    Mark,

    I am facing the same issue on Linux x86-64 with OWB 10.2.0.1 installed in a RAC instance. I am going to open up a TAR as it is impacting my client's project.

    Please feel free to stay in contact with me directly.

    Regards,
    Tony Orlando
    anthony.orlando@mfgsys.com
  • 12. Re: Platform service is unavailable
    531582 Newbie
    Currently Being Moderated
    Hi mark,
    I am getting exactly the same problem on windows server,already tried every thing u did but still no result......one extra thing i did was i manually write the oracle home path in the local_service_login.bat file......by doing this the file executed successfully and it prompts for the repository owner credentials...and i entered every thing...but again when i tried to start the control center manger from design center it still didnt started........so i am still unable to resolve this issue.....can u plz suggest me any solution if you got one.......
    thanks
    usman
  • 13. Re: Platform service is unavailable
    573192 Newbie
    Currently Being Moderated
    I have the same problem but linux seems does not support the control servcie center. Have any people success to run on Linux 64 but platform. thanks.
  • 14. Re: Platform service is unavailable
    622597 Newbie
    Currently Being Moderated
    Hi all,

    I currently have a Service Request open with Oracle regarding this issue, however, none of the things they have asked me to do work. If they tell me something other than we have no clue what our own product does, I will post it here.

    Thanks,
1 2 Previous Next