1 Reply Latest reply on Sep 14, 2016 7:05 PM by Sdas-Oracle

    Map geometries from relational model


      Dear all,


      I have the exact same problem as the one described in this OTM thread: Create a RDF view model with R2RML on a CLOB column


      I try to map a point in a relational view to RDF (I tried both SDO_GEOMETRY and CLOB as column datatype). I encounter the same error as in the other thread (typecode = 109 or 112 depending on the column datatype being a sdo_geometry or o clob)


       model_name => 'mymodel',
       tables => NULL,
       r2rml_table_owner => 'MYUSER',
       r2rml_table_name => 'STAGE_TABLE');


      DBD::Oracle::st execute failed: ORA-13199: Incompatible types:

      Database Column (COLUMN_LATLONG_POINT) typecode = 112 ((UNSUPPORTED DBMS_TYPES TYPECODE: 112)(0,0))

      R2RML mapping specified type = <http://xmlns.oracle.com/rdf/geo/WKTLiteral>

      ideal RDF datatype: UNKNOWN


      ORA-06512: at "MDSYS.SDO_RDF_INTERNAL", line 13806



      ORA-06512: at "MDSYS.SDO_RDF", line 3776

      ORA-06512: at "MDSYS.SDO_RDF", line 3849

      ORA-06512: at "MDSYS.RDF_APIS", line 1276

      Can someone tell me what I'm doing wrong?


      Thank you