4 Replies Latest reply on Sep 28, 2016 12:05 PM by thatJeffSmith-Oracle

    4.1.5 High CPU-Utilization while editing of large packages

    S-Max

      Hi all,

      dear sql-developer team!

       

      I have following problem. I need to edit huge package bodies with many-many lines (over 20,000).

      Please don't begin the discussion about the rationality of using such large packages and about the refactoring of them. The packages are large and this is so...

       

      While opening of such large package bodies the sql developer is only about to compare the subprograms:

      SQLDeveloper_compare_subprograms.JPG

      English: Subprograms will be compared

       

      Take a look to the CPU-Utilization graph:

      SQLDeveloper_CPU_Auslastung.JPG

       

      Is it possible to disable the "Compare Subprograms" Feature?

      The same problem I have had with all 4.1.x versions of SQL-Developer. Actually only the version 3.2 supports the editing of large package bodies.

       

      Will it be possible to edit the large packages in the next sql developer versions 4.2, 5, 6, 10, 20 ???

       

      Thanks!