3 Replies Latest reply on Sep 28, 2016 5:22 PM by Gary Graham-Oracle

    4.2 EA: sqldeveloper completely hung

    Raj Jamadagni

      I have seen this before in prior version at-least once, but here it goes,

       

      Been working on pl/sql package, things seem slow, so saved code (phew) and started looking around in 'Preferences', changed couple and saved. I also tried to add SqlCL as an external tool and launched it, but didn't see window, so clicked red square to close (not sure what it did).

       

      BAM !

       

      sqldeveloper completely hung, nothing was clickable. And since it was invoked from shortcut, tried to use jstack, jvisualvm etc to attach to pid, but nope, no process could connect. Each failed with a java stack saying 'could not attach'. Finally took a windows dump and killed the process.

       

      Is there anything that can be learned from that dump? How to get usable information (for dev) in such cases?

       

      I have since modified my short cut to cmd /k "c:\path\to\sqldeveloper.exe" so if it happens again, I can go to that command window and hit ctrl+enter to get stack dump.