3 Replies Latest reply on Jun 19, 2006 9:17 AM by 159563

    Oracle Workflow WF_IN Listener doesn't dequeue message

    481950
      <p>
      I'm using Oracle Interconnect 10g (ver. 10.1.2.2) and has been struggle trying to make the workflow WF_IN listener to work and have no luck so far.
      </p>
      <p>
      I have done the following:<br>
      1. Create a Service Components for Workflow Inbound Listener from Oracle Application Server Control 10g.<br>
      2. Create WF_IN Listeners from Oracle Workflow Setup Check All homepage<br>
      3. Create 3 Event Subscriptions from Oracle Workflow homepage:<br>
      a. Event: oracle.apps.wf.event.agent.create<br>
      b. Event: oracle.apps.wf.event.event.create<br>
      c. Event: oracle.apps.wf.event.subscription.create<br>
      4. Create Oracle Workflow Publish and Subscribe Activity Event from iStudio and deploy them to Oracle Workflow
      </p>
      <p>
      Regardless, the message that is in WF_IN Queue is always in ready state (state 0) and never dequeued. I have no idea what steps am I missing here. It just seems that the listener I created doesn't work or maybe not configure properly. So, if anybody can help me out here, I really appreciate. Here is the screenshot of the configuration I mentioned above.
      </p>
      <p>
      <img src="http://www.suryadisoft.com/images/oracle_app_server.JPG"><br><br>
      <img src="http://www.suryadisoft.com/images/event_subscription.JPG"><br><br>
      <img src="http://www.suryadisoft.com/images/workflow_check.JPG"><br><br>
      </p>
      <p>
      Thanks,
      <br><br>
      Edward
      </p>