1 Reply Latest reply on Oct 27, 2016 4:49 PM by Shivashish Roy-Humana

    Unable to use the regex mapping on ORDS 3.0.x URL mapping to connect to multiple DB using tomcat 6.0.x

    Shivashish Roy-Humana

      Hello folks, I am trying to use the regex feature of URL mapping in ORDS 3.0.6.176.08.46  to connect o 2 different Database ( Oracle Database 11g Enterprise Edition Release 11.2.0.4.0 - 64bit Production), Examples I have found in Oracle website or in other places  so far only show the example of "Routing Based on the Request Path Prefix" or "Routing Based on the Request URL Prefix" but the example is same i.e "https://example.com/ords/sales/f?p=1:1 ".

       

      I want the mapping to be based on regex on the host name (i.e. .. https://sales.example.com/ords/f?p=1:1 to go to Sales Database and  https://hr.example.com/ords/f?p=1:1 go to HR Database). I am currently using ORDS 3.0.6.176.08.46 with APEX 4.2.5.00.8 .

      We recently moved to Linux from windows, and i am trying to configure training and test DB instance using one web server via the feature "configuring multiple DB So any help  is greatly appreciated.

       

      things i have tried so far is :

       

      I have configured 2 separate DB connection pool for test and training in the ORDS configuration folder other than the default pointing to Test instance . using the below command on command line of linux and I have also tried using SQL developer via ORDS adminstrator

       

      java -jar ords.war setup --database test

      java -jar ords.war setup --database training

       

      then ...completed the configuration as per the guideline and then ...ran

       

      java -jar ords.war map-url --type regex  http://trn-.*   training

      java -jar ords.war map-url --type regex  http://tst-.*   test

       

      We have also tried escaping the regex as  ^http:\/\/trn-.*

       

      we don't see any logging about the mapping on the tomcat 6 web sever log files when the tomcat is restarted or APEX pages are invoked.

       

      Message was edited by: ac63b7f3-bac3-492c-b288-8df38382f6b5