3 Replies Latest reply on Jan 11, 2010 8:57 PM by 745766

    OCI.dll not found anywhere

    518546
      Hello dear forum participants,

      I understand that with this I will open unfortunately one of the most
      "popular" topics but as I see after some searching none of the
      previous threads have addressed my situation. It looks like this:

      1) I went and installed Oracle Designer 9.* (* means I do not remember
      the version right now but can look it up if necessary)
      I tried to launch it after all in all succesful information and got an
      error that OCI.dll could not be found.
      2) After some googling I found out that OCI.dll should be contained
      in Oracle Client, so I went and installed clinet also from 9 stream
      but slightly different minor version.
      Again, went and attempted to start Oracle Designer and again
      the same error about missing OCI.dll

      3) I read in TOAD FAQ that OCI.DLL is actually OraClient9.DLL
      which is indeed present in the Oracle bin directory. For whatever
      reason the symbolic link (alias) was not created by installation
      routine, so I went and created symbolic link OCI.DLL to OraClient9.DLL
      myself. Now I was able to start TORa (previously it also did not start)
      but still I was not able to start Oracle Designer with the error message
      that function OCICollAppend could not be found in the DLL. I went
      through DLL with Dependency Walker and, indeed, this function
      and several other ones are being missed there. So, dear gurus
      I got following questions:

      a) Where am I really supposed to get correct OCI.dll?
      b) What is behind this painful story, why is it so difficult to get
      OCI.dll properly installed?
      c) How to avoid situations like this in the future?