5 Replies Latest reply on Jan 19, 2017 2:55 PM by user10657778

    OBIEE 12C On virtual server...

    Jacob J

      Hi there

       

      I have been running OBIEE 12.2.1.1 on virtual windows 2012 64bit R2 servers, with a static IP. Everything appears to work except one thing. OVA can't connect to our Exadata or anything other kind of Oracle DB. I can connect and use the subject areas available to answers, but not a direct DB connection. I have a SR with Oracle, and they suspect that it might be because of my virtual servers. Just wondering in anybody have any luck connecting to an Oracle DB not residing on the same server as the OBIEE installation, on a virtual server? If yes, did you do anything to make this work?

       

      /Jacob

        • 1. Re: OBIEE 12C On virtual server...
          rmoff

          What's your virtualisation platform?

          How are you trying to connect from VA to the database? Does it work via the subject areas from VA? What's in the bi-server1 logfile?

          Can you get netcat (or similar) on Windows, and try connecting to the Oracle listener port directly from your windows server? That way you can at least isolate the problem to within OBIEE or within the virtualisation platform

          • 2. Re: OBIEE 12C On virtual server...
            Jacob J

            Hi rmoff

             

            It's an Enterprise version of VMware, dont know the exact version, as this is servers we get from our hosting company. I can find out, if it is of importance.

            What I try do to is to create a new datasource for an Oracle DB. When I hit save, it tells me, it is unable to save it. When I look into the logfiles the following part is the important bit:

            atchData: MESSAGE = [ServletContext@1308271647[app:bidatasetsvc module:datasetsvc path:null spec-version:3.1]] Root cause of ServletException.

            javax.ws.rs.ProcessingException: java.net.UnknownHostException: unknownhost.example.com

             

            Atleast that is what the SR people are telling me. The reason I get the save error, is because it cant find my Oracle DB. When using Answers and the Admin tool, I have no problem connecting to an Oracle DB. Also VA can use a subject area to get data, but it cannot in itself connect to an Oracle DB.

            • 3. Re: OBIEE 12C On virtual server...
              rmoff

              Can you get netcat (or similar) on Windows, and try connecting to the Oracle listener port directly from your windows server? That way you can at least isolate the problem to within OBIEE or within the virtualisation platform

               

              Can you ping unknownhost.example.com from your Windows machine? What about accessing it with SQL Developer from the Windows machine?

               

              Does it work if you use the IP instead of hostname?

              • 4. Re: OBIEE 12C On virtual server...
                Thomas Dodds

                What does TNSPing tell you when you try from the VM across the wire to your Oracle DB?  If it time-out, then it might be a firewall issue ... I've run into similar when using a cloud BI tool against a remote Oracle DB.  

                • 5. Re: OBIEE 12C On virtual server...
                  user10657778

                  Hello,

                   

                  Any update on this? I am facing the same issue.

                   

                  Jonni