0 Replies Latest reply on Nov 15, 2016 11:11 PM by 3035885

    Oralce Workflow Issue

    3035885

      Hi,

       

      I have create a simple workflow , below is the flow

       

      Start --> procedure to fetch the username and set the attribute--> notification to the user --> End

       

      I am trying yo trigger the workflow from a custom form button,

       

      And Below is the code

       

      Code used in Button trigger

       

      TAMS_ITC_WF_PKG.TAMSITC_LAUNCH_WORKFLOW(

          itemtype =>  l_item_type,

                                             itemkey  =>  l_item_key,

                                             process  =>  'TAMS_ITC_PROCESS' -- Main Runnable process name 

                                          );

       

       

      PLSQL Package Used

      CREATE OR REPLACE PACKAGE BODY APPS.TAMS_ITC_WF_PKG

      AS

        

         PROCEDURE TAMSITC_LAUNCH_WORKFLOW  (  itemtype  IN VARCHAR2,

                                       itemkey   IN VARCHAR2,

                                       process   IN VARCHAR2

                                    )

         AS

         BEGIN

            WF_ENGINE.Threshold := -1;

       

            WF_ENGINE.CREATEPROCESS(   itemtype,

                                       itemkey ,

                                       process

                                    );

            WF_ENGINE.STARTPROCESS (   itemtype,

                                       itemkey

                                    );

         EXCEPTION

            WHEN OTHERS

            THEN

               DBMS_OUTPUT.PUT_LINE('Error at LAUNCH_WORKFLOW: '||SQLERRM);

         END   TAMSITC_LAUNCH_WORKFLOW;

      END  TAMS_ITC_WF_PKG;

      /

       

      I used my user name to get the notification, but i haven't received.

       

      I could not find any records in the Status monitor for my WF but i could see the data in

       

      select * from WF_ACTIVITIES where item_type = 'TAMSITC';

      SELECT *     FROM WF_PROCESS_ACTIVITIES where process_item_type = 'TAMSITC';

       

       

      No Idea what's happening, Appreciate your help

       

      Regards,

      Sandeep