This discussion is archived
1 2 Previous Next 15 Replies Latest reply: Dec 16, 2010 1:04 PM by 824663 RSS

can I install Oracle client on Mac os X version 10.4.6?

10626 Newbie
Currently Being Moderated
Hello,

My os version:

ProductName: Mac OS X
ProductVersion: 10.4.6
BuildVersion: 8I127

The processor information is "Dual 800 MHz PowerPC G4 2MB L3 cache per processor"

Memory 1 GB SDRAM

120 gig hard drive

I would like to install the Oracle client software so i can run sql*Plus. I'm looking at the quick install guide and it says that "Only Mac OS X Server is supported." and it also says "The operating system version must be Apple Mac OS X Server 10.3.6"

Why would Oracle only create an Oracle client that runs on a mac server? Is this information correct? or can I go ahead and install the client on my machine?

Thank you,
David
  • 1. Re: can I install Oracle client on Mac os X version 10.4.6?
    10626 Newbie
    Currently Being Moderated
    I need the client so I can run Sql*Plus. I did not get a response to my thread and kept looking and saw in the documentation that sql*plus can be run with the instant client. I did not attempt to install the full client yet, but I was able to install the instant client to get sql*Plus working. Here are the steps:

    1. Download instantclient-basic-macosx-10.1.0.3.zip and
    instantclient-sqlplus-macosx-10.1.0.3.zip

    2. Unzipped them in /usr/ora_instant_client

    3. Set the DYLD_LIBRARY_PATH to /usr/ora_instant_client/instantclient10_1 and later added to my profile

    4. Downloaded a copy of the tnsnames.ora file from one of the local servers and placed it in /usr/ora_instant_client/instantclient10_1

    5. Did "export TNS_ADMIN=/usr/ora_instant_client/instantclient10_1" on the command line and later added to my profile

    I was then able to run sql*Plus.
  • 2. Re: can I install Oracle client on Mac os X version 10.4.6?
    517540 Newbie
    Currently Being Moderated
    Awesome. That worked, although I didn't know the syntax for connecting and I had to talk to our DBA to find the tnsnames.ora file. I think (although I haven't tested this) that you can connect without that file with:

    sqlplus dbusername/dbpassword@//your.domain.com:portnum/dbname

    Plus, since I use tcsh, I didn't perform an explicit export of the TNS_ADMIN variable. I just did a setenv (as I did with the library path too, then updated my .cshrc).

    Also, I should note that you must put the contents of the sqlplus unzip into the directory that results from the basic-macosx unzip.

    Rob

    Message was edited by:
    user514537
  • 3. Re: can I install Oracle client on Mac os X version 10.4.6?
    491831 Newbie
    Currently Being Moderated
    If you're using the connection string <user>/<password>@//host:port/servicename you don't need to set TNS_ADMIN at all, since you're not using it to resolve the connection details (you've already specified everything).

    Oracle also say you can only run the database itself on OSX server, though I've got 10.1 (latest available version for OSX) running on the normal OSX version (10.4.x) without problems. There are plenty of google-able references on how to set this up. NB- you will need to download the Apple XCode developer toolkit (to get the gcc compiler) which weighs in at about 1Gb, and you'll also need to configure the compiler to use version 3.3 (not the latest 4.x) to compile/link Oracle, otherwise it won't work properly. This is just a 1-line command. Again, plenty of web references on how to do this.
  • 4. Re: can I install Oracle client on Mac os X version 10.4.6?
    546062 Newbie
    Currently Being Moderated
    Hello,

    I am trying to install oracle instant client and followed davidxm's instruction. For some reason its still not working on my os. I'm getting following errors while running sqlplus:

    dyld: Library not loaded: /b/729/sqlplus/lib/libsqlplus.dylib
    Referenced from: /usr/ora_instant_client/instantclient10_1/ ./sqlplus group16@orca
    Reason: image not found
    Trace/BPT trap
    -----------------------------------------

    Anyone has got any idea as what am I doing wrong in configuration setting?

    My OS Version 10.4.8 is running on PowerPC G4.

    Thank You,

    Tan
  • 5. Re: can I install Oracle client on Mac os X version 10.4.6?
    386814 Newbie
    Currently Being Moderated
    Hi Tan

    I'm sure it is just an environment set up. See that you have the variables set that I have and the files in the right places. Check with find file that you have libsqlplus.dylib

    If I do this at the terminal prompt:

    cd /
    l000373:/ skiv$ find . -name "libsqlplus.dylib"
    ./Applications/InstantClient/instantclient10_1/libsqlplus.dylib

    Then I have enviromen t variables set up in .bashrc and .profile as follows

    PATH=$PATH:/Volumes/Dot/Applications/InstantClient/instantclient10_1
    DYLD_LIBRARY_PATH=/Volumes/Dot/Applications/InstantClient/instantclient10_1
    TNS_ADMIN=/Volumes/Dot/Applications/InstantClient/instantclient10_1
    export TNS_ADMIN DYLD_LIBRARY_PATH

    and it works:

    l000373:/ skiv$ sqlplus cbm@MISTEST
    SQL*Plus: Release 10.1.0.3.0 - Production on Wed Nov 15 13:20:41 2006

    Copyright (c) 1982, 2004, Oracle. All rights reserved.

    Enter password:

    Connected to:
    Oracle9i Enterprise Edition Release 9.2.0.8.0 - 64bit Production
    With the Partitioning, OLAP and Oracle Data Mining options
    JServer Release 9.2.0.8.0 - Production

    SQL>

    Paul
  • 6. Re: can I install Oracle client on Mac os X version 10.4.6?
    518030 Newbie
    Currently Being Moderated
    Be sure that the user that is trying to run sqlPLus from bash has instant_client's folder rights.
    If not the library couldn't load as the message throws.
  • 7. Re: can I install Oracle client on Mac os X version 10.4.6?
    586905 Newbie
    Currently Being Moderated
    No luck for me. :( Even gave total access to the directory and files. But the location of the lib file is not any directory on my machine.

    Thanks for any help you can provide.
    Eric


    <pre>

    /usr/ora_instant_client $ll
    total 86100
    0 drwxr-xr-x 12 root wheel 408B Jul 7 22:22:46 2007 ../
    0 drwxrwxrwx 14 root wheel 476B Jul 7 22:47:30 2007 ./
    16 -rwxrwxrwx 1 root wheel 15K Jul 7 22:48:25 2007 sqlplus*
    1368 -rw-rw-rw- 1 root wheel 1M Jul 7 22:48:25 2007 ojdbc14.jar
    728 -rwxrwxrwx 1 root wheel 727K Jul 7 22:48:25 2007 libsqlplus.dylib*
    92 -rwxrwxrwx 1 root wheel 90K Jul 7 22:48:25 2007 libocijdbc10.dylib*
    64612 -rwxrwxrwx 1 root wheel 63M Jul 7 22:48:25 2007 libociei.dylib*
    1800 -rw-rw-rw- 1 root wheel 1M Jul 7 22:48:25 2007 libocci.dylib.10.1
    1484 -rw-rw-rw- 1 root wheel 1M Jul 7 22:48:25 2007 libnnz10.dylib
    14544 -rwxrwxrwx 1 root wheel 14M Jul 7 22:48:25 2007 libclntsh.dylib.10.1*
    0 drwxrwxrwx 3 root wheel 102B Jul 7 22:48:25 2007 instantclient10_1/
    4 -rw-rw-rw- 1 root wheel 1K Jul 7 22:48:25 2007 glogin.sql
    1428 -rw-rw-rw- 1 root wheel 1M Jul 7 22:48:25 2007 classes12.jar
    24 -rw-rw-rw- 1 root wheel 20K Jul 7 22:48:25 2007 README_IC.htm

    /usr/ora_instant_client $sqlplus
    dyld: Library not loaded: /b/729/sqlplus/lib/libsqlplus.dylib
    Referenced from: /usr/ora_instant_client/sqlplus
    Reason: image not found
    Trace/BPT trap

    /usr/ora_instant_client $export
    DYLD_LIBRARY_PATH=/usr/ora_instant_client/instantclient10_1
    HOME=/Users/xxx
    LOGNAME=xxx
    PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/ora_instant_client
    PS1='$PWD $'
    PWD=/usr/ora_instant_client
    SHELL=/bin/ksh
    TERM=ansi
    TERM_PROGRAM=iTerm.app
    TNS_ADMIN=/usr/ora_instant_client/instantclient10_1

    </pre>
  • 8. Re: can I install Oracle client on Mac os X version 10.4.6?
    612371 Newbie
    Currently Being Moderated
    Installing SQL plus on a Mac

    Apparently this is not possible - or is exceedingly difficult. Too bad they can't figure out how to create a self-install package. I can't believe it is that difficult to create an installer.

    Oracle does have SQLdeveloper - but I haven't had much luck with it.

    I finally bought Aqua Data Studio (www.aquafold.com) and it so far has worked well with Oracle and every other server we have here.
  • 9. Re: can I install Oracle client on Mac os X version 10.4.6?
    612632 Newbie
    Currently Being Moderated
    It's actually quite easy - I just did it for the first time myself. Make sure to go to terminal and "export DYLD_LIBRARY_PATH=<your_dir_here>". Launch from same terminal - done!

    - Chris
  • 10. Re: can I install Oracle client on Mac os X version 10.4.6?
    643423 Newbie
    Currently Being Moderated
    hi all, first at all thanks for starting this post, it really helped me.

    However, I found a gotcha that didn't allow the client to find the tnsnames.ora. I spent centuries until I found what it was. I moved the tnsnames.ora out of the /usr/ora_instant_client, to some folder where I have full permissions, and then everything started working. Bye bye to the TNS:could not resolve the connect identifier specified.

    I have no clue about why that happened, as I have read permissions for that folder... Anyway, hope that this helps someone else, this one really annoyed me.
  • 11. Re: can I install Oracle client on Mac os X version 10.4.6?
    466751 Oracle ACE
    Currently Being Moderated
    I noticed this tonight and thought pointing to my blog might help some. It has the steps with some screen shots for configuring VM Fusion and connecting to the VM from the Mac OS X directly.

    http://blog.mclaughlinsoftware.com/how-to-configure-mac-os-x-as-an-oracle-client/
  • 12. Re: can I install Oracle client on Mac os X version 10.4.6?
    733768 Newbie
    Currently Being Moderated
    davidxm ,

    In Step 2: How could I access the /usr/ folder with Finder ? Mac OS X Unzip the files directly to the Download folder !
    In Step 3: How and where should I set that ? & How could I add it to my profile ? What profile ??
    In Step 4: what are the "local servers" ? any URL ??


    Yours, Amor.
  • 13. Re: can I install Oracle client on Mac os X version 10.4.6?
    795596 Newbie
    Currently Being Moderated
    I had the same problem, on 10.6.x, in 2010.

    "dyld: Library not loaded: /b/227/sqlplus/lib/libsqlplus.dylib"

    The issue is that Apple quarantines downloaded files from the internet. The unzipped files must carry this quarantine.

    You can tell in an ls -l listing. Each file with have an "@" for extended attributes.

    View extended attributes with ls -l@

    Remove quarantine attributes like this

    sudo xattr -d com.apple.quarantine *

    Now my sql plus works. I imagine that if you unzipped using the finder you would be prompted about the file from the internet, and the quarantine would be removed. If you use 'unzip' from the terminal as I did, the quarantine is kept.
  • 14. Re: can I install Oracle client on Mac os X version 10.4.6?
    811264 Newbie
    Currently Being Moderated
    I tried all the suggestions given above but could not get the sqlplus to work. Then I tried the following:

    Edit /etc/bashrc as root, add the following lines:

    export ORACLE_HOME=/usr/local/oracle/instantclient_10_2
    export DYLD_LIBRARY_PATH=$ORACLE_HOME
    export SQLPATH=$ORACLE_HOME
    export PATH=$PATH:$ORACLE_HOME
    export TNS_ADMIN=$ORACLE_HOME/admin

    ensure that tnsnames.ora file is created in the $ORACLE_HOME/admin folder.

    After making this change, I was able to get the sqlplus to work without throwing the error "dyld: Library not loaded: /b/227/sqlplus/lib/libsqlplus.dylib"

    Thanks,
    Rahul.
1 2 Previous Next