1 2 Previous Next 18 Replies Latest reply on Dec 27, 2016 5:45 AM by Beauty_and_dBest

    Cloning 12.1.3

    Beauty_and_dBest

      Hi ALL,

       

      MERRY CHRISTMAS TO ALL!!!!

       

      EBS R12.1.3

      11gR1

      OL 6

       

       

      I am cloning or EBS R12.1.3 db Tier,  but I got this error message

       

      APPS Password : Log file located at /u01/oravis/VIS/db/tech_st/11.1.0/appsutil/log/VIS_d0c63c/ApplyDBTier_12242120.log

        -     50% completed       RC-50004: Fatal: Error occurred in ApplyDatabase:

      Control file creation failed

       

      ERROR while running Apply...

      Sat Dec 24 21:28:00 2016

       

      ERROR: Failed to execute /u01/oravis/VIS/db/tech_st/11.1.0/appsutil/clone/bin/adclone.pl

       

      Please check logfile.

       

      ---------------------------------------------------------------

                         ADX Database Utility

      ---------------------------------------------------------------

      getConnectionUsingAppsJDBCConnector() -->

          APPS_JDBC_URL='null'

          Trying to get connection using SID based connect descriptor

      getConnection() -->

          sDbHost    : d0c63c

          sDbDomain  : compute-focusitc1.oraclecloud.internal

          sDbPort    : 1521

          sDbSid     : VIS

          sDbUser    : apps

          Trying to connect using SID...

      getConnectionUsingSID() -->

          JDBC URL: jdbc:oracle:thin:@d0c63c.compute-focusitc1.oraclecloud.internal:1521:VIS

          Exception occurred: java.sql.SQLException: ORA-01017: invalid username/password; logon denied

       

       

          Trying to connect using SID as ServiceName

      getConnectionUsingServiceName() -->

          JDBC URL: jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=d0c63c.compute-focusitc1.oraclecloud.internal)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=VIS)))

          Exception occurred: java.sql.SQLException: ORA-01017: invalid username/password; logon denied

       

       

          Trying to connect using SID as ServiceName.DomainName

      getConnectionUsingServiceName() -->

          JDBC URL: jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=d0c63c.compute-focusitc1.oraclecloud.internal)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=VIS.compute-focusitc1.oraclecloud.internal)))

          Exception occurred: java.sql.SQLException: Listener refused the connection with the following error:

      ORA-12514, TNS:listener does not currently know of service requested in connect descriptor

       

          Connection could not be obtained; returning null

       

      -------------------ADX Database Utility Finished---------------

       

      RC-00118: Error occurred during creation of database

      Raised by oracle.apps.ad.clone.ApplyDatabase

       

      StackTrace:

      java.lang.Exception: Control file creation failed

              at oracle.apps.ad.clone.ApplyDatabase.doConf(ApplyDatabase.java:635)

              at oracle.apps.ad.clone.ApplyDatabase.doApply(ApplyDatabase.java:473)

              at oracle.apps.ad.clone.ApplyDatabase.<init>(ApplyDatabase.java:366)

              at oracle.apps.ad.clone.ApplyDBTier.<init>(ApplyDBTier.java:110)

              at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

              at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

              at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)

              at java.lang.reflect.Constructor.newInstance(Unknown Source)

              at oracle.apps.ad.clone.util.CloneProcessor.run(CloneProcessor.java:67)

              at java.lang.Thread.run(Unknown Source)

       

       

      But it seems the database was created?

      Should I just ignore the error?

       

       

       

      Please help...

       

       

      Kind regards,

      jc

        • 1. Re: Cloning 12.1.3
          Beauty_and_dBest

          I remember I changed the apps password, and I forgot what is it

          Can I change it in the new target clone?

           

          Is it okay to connect / as sysdba , and alter user apps identified by apps?

           

           

          Kind regards,

          • 2. Re: Cloning 12.1.3
            mdtaylor

            Ho Ho Ho!  What are you doing working on Christmas Eve?

             

            Depends on if you have a running database in the target if you can change the password.  Can you sqlplus into the target database?

             

            Looks like controlfile creation failed along with listener creation.  Can you use FNDCPASS and change the apps password in the source, run adpreclone.sh then clone it again?

             

            BTW, you must upgrade the database to 11.2.0.3 or higher to run on OEL 6.

             

            Oracle E-Business Suite Installation and Upgrade Notes Release 12 (12.1.1) for Linux x86-64 (Doc ID 761566.1)

            • 3. Re: Cloning 12.1.3
              mdtaylor

              Hi Jenna,

               

              Also, does the compute cloud instance have all of the required OS packages for EBS?  Does it have oracle-ebs-server-R12-preinstall?

               

              Regards,

              Michael

              • 4. Re: Cloning 12.1.3
                Beauty_and_dBest

                Thanks Michael, Merry Christmas to ALL of you here and arround the world.

                 

                I am just taking advantage of this "free day" because I have lots of bakclogs to do

                 

                Well I am sure all pre-reqs have been done on this server, because I was able to clone here a R12.2 instance successfully. (Now I am cloning 12.1.3)

                 

                Anyways,  I just ignore the database error because I believe it is caused by my APPS schema password. I remember it now, I can start/stop the database tier successfully.

                ===============

                Now I proceed to the Apps tier cloning (12.1.3)

                 

                I run it and I encounter error again:

                 

                APPS Password : Log file located at /u01/appvis/VIS/inst/apps/VIS_d0c63c/admin/log/ApplyAppsTier_12242212.log

                  \     89% completed     

                 

                ERROR while running Apply...

                Sat Dec 24 22:20:46 2016

                 

                ERROR: Failed to execute /u01/appvis/VIS/apps/apps_st/comn/clone/bin/adclone.pl

                 

                Please check logfile.

                =================

                 

                New Value : /u01/appvis/VIS/inst/apps/VIS_d0c63c/logs/appl/conc/log/VIS_d0c63c

                Old Value : /sdf/appvis/VIS/inst/apps/VIS_fitc/logs/appl/conc/log/VIS_fitc

                 

                PL/SQL procedure successfully completed.

                 

                Commit complete.

                 

                Disconnected from Oracle Database 11g Enterprise Edition Release 11.1.0.7.0 - 64bit Production

                With the Partitioning, OLAP, Data Mining and Real Application Testing options

                igccmprf.sh exiting with status 0

                ERRORCODE = 0 ERRORCODE_END

                .end std out.

                 

                .end err out.

                ****************************************************

                Product Top Drivers executed : AD_TOP  FND_TOP  ICX_TOP  MSC_TOP  IEO_TOP  BIS_TOP  AMS_TOP  CCT_TOP  WSH_TOP  CLN_TOP  OKE_TOP  OKL_TOP  OKS_TOP  CSF_TOP  IGS_TOP  IBY_TOP  JTF_TOP  MWA_TOP  CN_TOP  CSI_TOP  WIP_TOP  CSE_TOP  EAM_TOP  FTE_TOP  ONT_TOP  AR_TOP  AHL_TOP  OZF_TOP  IES_TOP  CSD_TOP  IGC_TOP

                 

                [AutoConfig Error Report]

                The following report lists errors AutoConfig encountered during each

                phase of its execution.  Errors are grouped by directory and phase.

                The report format is:

                      <filename>  <phase>  <return code where appropriate>

                 

                 

                  [SETUP PHASE]

                  AutoConfig could not successfully execute the following scripts:

                    Directory: /u01/appvis/VIS/inst/apps/VIS_d0c63c/admin/install

                      adgendbc.sh             INSTE8_SETUP       1

                 

                AutoConfig is exiting with status 1

                 

                RC-50014: Fatal: Execution of AutoConfig was failed

                Raised by oracle.apps.ad.clone.ApplyApplTop

                ERROR: AutoConfig completed with errors. Check logfile at /u01/appvis/VIS/inst/apps/VIS_d0c63c/admin/log/ApplyAppsTier_12242212.log for details.

                ApplyApplTop Completed Successfully.

                 

                # Checking the status of AutoConfig run of ApplyApplTop

                Warning : AutoConfig has completed with  errors .

                Please review the AutoConfig section in the logfile. If required, you can re-run AutoConfig from command line  after fixing the problem.

                 

                =================

                 

                Maybe I need some little tweaking here?

                 

                Please help...

                 

                Kind regards,

                • 5. Re: Cloning 12.1.3
                  mdtaylor

                  When adgendbc.sh fails, it is a good time to run fnd_conc_clone.setup_clean and run autoconfig again on the database and the appTier again.

                   

                  Can you paste the first error when adgendbc.sh ran, not just the conclusion error?

                  • 6. Re: Cloning 12.1.3
                    Beauty_and_dBest

                    Thanks Michael,

                     

                    I only got the log posted above ,  I can not  get which is the first run of adgendbc.sh?

                     

                     

                    I also find this in google > Oracle apps: Autoconfig Fails with error adgendbc.sh INSTE8_SETUP 1

                    alter system set JAVA_JIT_ENABLED= FALSE scope = both

                     

                     

                    Should I try it?

                     

                     

                    Kind regards,

                    • 7. Re: Cloning 12.1.3
                      mdtaylor

                      Yes.  I use that parameter in many of my 12.1.3 instances.

                       

                      Adgendbc Fails With Database Connection Failure (Doc ID 1302708.1)

                      • 8. Re: Cloning 12.1.3
                        mdtaylor

                        Hi Jenna,

                         

                        If you search the rapid clone log /u01/appvis/VIS/inst/apps/VIS_d0c63c/admin/log/ApplyAppsTier_12242212.log, you should find the autoconfig section which will have it's log. If you open that log file and search for adgendbc.sh, you should see the exact error.

                         

                        That parameter you found should correct this issue.

                         

                        Regards,

                        Michael

                        • 9. Re: Cloning 12.1.3
                          dba-india

                          Directly changing APPS password from backend is not supported by Oracle and more over you might face problems while cloning.

                          APPS password should be same as that of APPLSYS user.

                           

                          The right way to change APPS is using FNDCPASS utility

                          FNDCPASS apps/apps 0 Y system/manager SYSTEM APPLSYS newPassword

                           

                          After changing the APPS password using FNDCPASS, you should run autoconfig on DB & Apps tiers.

                          • 10. Re: Cloning 12.1.3
                            Beauty_and_dBest

                            Thanks Micheal,  dba-india and ALL,

                             

                             

                            it worked!

                             

                            I also run >  fnd_conc_clone.setup_clean

                             

                            Do I need to set jit to true again?

                             

                             

                            Note also that my database is 11.1.0.7 and my OS is OL6.

                            [appvis@d0c63c ~]$ sqlplus system/manager

                             

                            SQL*Plus: Release 10.1.0.5.0 - Production on Sat Dec 24 23:41:09 2016

                             

                            Copyright (c) 1982, 2005, Oracle.  All rights reserved.

                             

                            Connected to:

                            Oracle Database 11g Enterprise Edition Release 11.1.0.7.0 - 64bit Production

                            With the Partitioning, OLAP, Data Mining and Real Application Testing options

                             

                             

                            Kind regards,

                            • 11. Re: Cloning 12.1.3
                              mdtaylor

                              Hi Jenna,

                               

                              Awesome.  Please leave it set.  You can put it in the ifile in case you need to run autoconfig again.

                               

                              Regards,

                              Michael

                              • 12. Re: Cloning 12.1.3
                                Beauty_and_dBest

                                Thanks,

                                 

                                Set it to false or true?

                                 

                                So I do not need to upgrade my database to 11.2?

                                 

                                 

                                Kind regards,

                                • 13. Re: Cloning 12.1.3
                                  mdtaylor

                                  Hi Jenna,

                                   

                                  Please set it to false.

                                   

                                  The official answer is you need to upgrade the database to 11.2 if you are running on OL/RH 6 according to the installation guide.  If it is just a Vision demo install and things appears to be working, you may be able to squeak by on 11.1.0.7.  Personally, I do not leave any R12 databases on 11.1 and upgrade them to 11.2.0.3.15 or 11.2.0.4.

                                   

                                  I hope Santa brings you something nice.

                                   

                                  Cheers,

                                  Michael

                                  • 14. Re: Cloning 12.1.3
                                    Beauty_and_dBest

                                    Thanks Michael,

                                     

                                    Actually we have cloned a PROD instance to (11.1 and RHEL 6)  running for a year now,  it is still okay

                                    Anyways can you share me the steps to upgrade 11.1 to 11.2 for EBS database?

                                    I understand you need to apply patches both on the apps and dbtier?

                                     

                                     

                                    Kind regards,

                                    1 2 Previous Next