1 Reply Latest reply on Jan 19, 2017 4:43 PM by mseberg

    Problem on RMAN Duplication

    1311064

      Hello

           I am trying to do a duplication of a database using RMAN. The source database is 11g (11.2.0.10) on a window 2003 Server and target database is a 12c (12.1.0.2.0  ) on a window 2012 Server.

      The directory structure on both are not similar but I resolved it converting filename and log files.  First of all  I made a full backup with

      RMAN> run{

      2> backup database;

      3> backup archivelog all;

      4> }

           I copied the files needed and  I tried to do duplication on RMAN on the target database

      DUPLICATE DATABASE TO MADDW BACKUP LOCATION 'D:\BACKUP'

           It seems to work fine until  it tried to made a ALTER CLONE DATABASE OPEN RESETLOGS;

       

      contents of Memory Script:

      {

         Alter clone database open resetlogs;

      }

      executing Memory Script

       

       

      RMAN-00571: ===========================================================

      RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============

      RMAN-00571: ===========================================================

      RMAN-00601: fatal error in recovery manager

      RMAN-03004: fatal error during execution of command

      RMAN-10041: Could not re-create polling channel context following failure.

      RMAN-10024: error setting up for rpc polling

      RMAN-10005: error opening cursor

      RMAN-10002: ORACLE error: ORA-03114: not connected to ORACLE

      RMAN-03002: failure of Duplicate Db command at 01/19/2017 15:57:36

      RMAN-05501: aborting duplication of target database

      RMAN-03015: error occurred in stored script Memory Script

      RMAN-06136: ORACLE error from auxiliary database: ORA-01092: ORACLE instance ter

      minated. Disconnection forced

      ORA-00704: bootstrap process failure

      ORA-00604: error occurred at recursive SQL level 2

      ORA-00904: "I"."UNUSABLEBEGINNING#": invalid identifier

      Process ID: 3740

      Session ID: 62 Serial number: 45210

       

      Could anyone give any clue to resolve this issue?

      Regards and thank you in advance

        • 1. Re: Problem on RMAN Duplication
          mseberg

          The ORA-00704: bootstrap process failure generally means version mismatch between datafile headers and oracle binaries, which are being used to start the database.

           

           

          For example if I tried starting a database using Oracle 12.1.0.2 binaries, but the datafiles are from 11.2.0.4

           

          The source database is 11g (11.2.0.10) on a window 2003 Server and target database is a 12c (12.1.0.2.0  ) on a window 2012 Server

           

          You best bet would be to duplicate with the same version, upgrade either before or after.

           

          See

           

          RMAN DUPLICATE / RESTORE a database to a higher patchset (Doc ID 558408.1)

           

          Also

           

          Frequently Asked Questions about Restoring Or Duplicating Between Different Versions And Platforms (Doc ID 369644.1)

           

          What you are doing is not recommended by Oracle.

           

          Best Regards

           

          mseberg