6 Replies Latest reply on Feb 20, 2017 10:16 AM by Anjum Ara

    Opatch problem

    3363076

      hi guys ,,

       

      I recently upgraded my OBIEE 12.2.1.0.0 jdk1.8.0_92 to jdk1.8.0_121

      and its working fine but now I was trying to apply the patch to the OBIEE and It was giving me the error which is "

      The installation jdk /apps/app/oracle/product/fmw12c/jdk1.8.0_92 is not accessible.

      Please set approppriate JAVA_HOME and run again."

       

      even though my java _home is set to the new java which is jdk1.8.0_121 but it stills asking for the same old java

      when I use command java -version it gives the new java version which is fine but in patching it showing the above message

      So please how can I fix so that it doesn't show the above error

       

      Thanks

        • 1. Re: Opatch problem
          S R Battula

          OPatch uses the jar utility that comes with JDK for its jar, war, and ear operations. Opatch searches for JDK inside the specified Oracle home. If the Oracle home does not have JDK, you have to use the -jdk option in OPatch to provide an alternate location. OPatch displays an error if there is a jar/war/ear operation and cannot locate the Java SDK location.

           

          are you applying Optach  using  Command Prompt , if yes  set  JAVA_HOME in command prompt  before applying Optach.

          • 2. Re: Opatch problem
            3363076

            I am applying Optach in Linux and I have set JAVA_HOME too

            initially I set java during installation for obiee 12c to /apps/app/oracle/product/fmw12c/jdk1.8.0_92

             

            Then I upgrade it to jdk1.8.0_121 and I  created a directory jdk and mv jdk1.8.0_121 to jdk so now it looks like this

            apps/app/oracle/product/fmw12c/jdk

             

            I set JAVA_HOME in the environment variable to /apps/app/oracle/product/fmw12c/CDF_DEV/jdk and it works fine but giving the error as I mention before during patching

             

            I have attached the screen shot of the problem

             

            Also can you please just tell me how to give the -jdk option in Opatch if you can just give me some hints

             

            Thanks

            • 3. Re: Opatch problem
              Anjum Ara

              Hi

               

              Here is the syntax:

              opatch apply <PATCHpath> -oh <ORACLE_HOME_PATH> -jre <Java path>

              example

                                               ./opatch apply 21672441 –oh /obiee/app/oracle/product/Middleware/oracle_common -jre /obiee/app/oracle/product/Middleware/jdk1.6.0_121

              • 4. Re: Opatch problem
                S R Battula

                based on you screenshot ,i hope the Java installation is not accessible for the user which you are using  for patch apply.

                • 5. Re: Opatch problem
                  Madasamy-Oracle

                  This is almost right, but we just need to set the oracle_home as an environment variable and ignore the -oh on the opatch command.

                   

                  Correct me if i am wrong

                   

                  -Madasamy

                  • 6. Re: Opatch problem
                    Anjum Ara

                    You need not, we can do it either by setting it as an environment variable or use -oh command. I always use -oh and it works fine.