0 Replies Latest reply on Jun 30, 2006 7:56 AM by 501074

    Error Parsing wwjps.xml file

    501074
      Hi All,

      I am trying to integrate my JSP pages into Oracle Portal and use the Oracle Portal login mechanism for my JSP application.

      I followed the instructions of the document Integrating JavaServer Pages with OracleAS Portal and created the wwjps.xml file:

      <?xml version="1.0"?>
      <jps version="1.0">
      <portal name="portal_instance" default="true">
      <database data-source="jdbc/OracleDS"/>
      <url host="portsrv" port="80" path="/pls/portal"/>
      <cookie name="portal" maxAge="-1" path="/" />
      <pageGroups>
      <pageGroup name="FragysPageGroup" key="fragypgkey" default="false"/>
      </pageGroups>
      </portal>
      </jps>

      And here the probems start:

      When I run my jsp page I receive a 500 Internal Server Error with the following stacktrace

      oracle.webdb.utils.PortalExceptionImpl: &#931;&#966;&#940;&#955;&#956;&#945;: UsePortalTag: at oracle.webdb.service.tagext.JspPortalException.<init>(Unknown Source) at oracle.webdb.service.tagext.JspPortalException.<init>(Unknown Source) at oracle.webdb.service.tagext.UsePortalTag.doEndTag(Unknown Source) at simple.jspService(_simple.java:54) [SRC:/simple.jsp:2] at com.orionserver[Oracle Application Server Containers for J2EE 10g (10.1.2.0.2)].http.OrionHttpJspPage.service(OrionHttpJspPage.java:56) at oracle.jsp.runtimev2.JspPageTable.service(JspPageTable.java:350) at oracle.jsp.runtimev2.JspServlet.internalService(JspServlet.java:509) at oracle.jsp.runtimev2.JspServlet.service(JspServlet.java:413) at javax.servlet.http.HttpServlet.service(HttpServlet.java:853) at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.0.2)].server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:824) at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.0.2)].server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:330) at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.0.2)].server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:830) at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.0.2)].server.http.AJPRequestHandler.run(AJPRequestHandler.java:224) at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.0.2)].server.http.AJPRequestHandler.run(AJPRequestHandler.java:133) at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.0.2)].util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:192) at java.lang.Thread.run(Thread.java:534)Caused by: oracle.webdb.service.config.ConfigLoaderException: &#931;&#966;&#940;&#955;&#956;&#945; &#945;&#957;&#940;&#955;&#965;&#963;&#951;&#962; XML: Start of root element expected. &#963;&#964;&#959; bootstrap at oracle.webdb.service.config.ConfigLoader.performBootstrap(Unknown Source) at oracle.webdb.service.config.ConfigLoader.getConfiguration(Unknown Source) at oracle.webdb.service.PortalFactoryImpl.usePortal(Unknown Source) at oracle.portal.service.PortalFactory.usePortal(Unknown Source) at oracle.portal.service.PortalFactory.usePortal(Unknown Source) ... 14 moreCaused by: oracle.xml.parser.v2.XMLParseException: Start of root element expected. at oracle.xml.parser.v2.XMLError.flushErrors1(XMLError.java:337) at oracle.xml.parser.v2.NonValidatingParser.parseRootElement(NonValidatingParser.java:319) at oracle.xml.parser.v2.NonValidatingParser.parseDocument(NonValidatingParser.java:281) at oracle.xml.parser.v2.XMLParser.parse(XMLParser.java:307)

      Something is going wrong when the configurator parses my XML file.
      But I don't know what.

      Have you go any clue of what am I doing wrong???


      Thanks


      p.s sorry for the greek in the stack trace just ignore it...