7 Replies Latest reply on Mar 22, 2017 5:59 PM by Aldrich

    Add and clone to Multi node system

    953987

      Hi All,

       

        We ahve EBS R12 system with single nodes. DB in one node and apps in another nodes.

       

        EBS - R12.2.5

        DB - 12.1.0.2

       

        DB - DEVDB

        Apps - DEVAPP

       

      Now I want to things to perform.

       

      1)  I want to add another apps node to existing system. DB will be one node

           Please provide the steps for this 

       

      2)  We want to clone system and the Apps tier want in Multi node system for PROD. DB will be one node

           Please provide the steps for this as well.

       

       

      Thanks,

      ASM

        • 1. Re: Add and clone to Multi node system
          Shaik

          Hi

           

          Please refere "Adding a New Application Tier Node to an Existing System" in below note

          Cloning Oracle E-Business Suite Release 12.2 with Rapid Clone (Doc ID 1383621.1)

          also refere previously raised thread

          12.2.5 Adding a new node fails

           

           

          Regards

          Shaik

          • 2. Re: Add and clone to Multi node system
            953987

            Thanks Shaik,

             

            Another doubt:

            -----------------

            To add node / to clone to TEST / to create standby instance,

              a) we need to run preclone only in Run system ?

                  or in patch also?

                       if in patch file system, need to start admin server ?

             

              b) after preclone, we need to copy both file system to target server respectively ( fs1->fs1 , fs2->fs2) ? or only need to copy run file system ?

            • 3. Re: Add and clone to Multi node system
              Aldrich

              1)  To an existing system, you would run the following to add a node:

              adclonectx.pl addnode contextfile=<context file of existing/primary node>

               

              2)  To clone a multi node, you would do the following:

              a)  run preclone in the PROD env.

              b)  Run adcfgclone on the first/primary node

              c)  as mentioned in the first question, run the following to add nodes:

              adclonectx.pl addnode contextfile=<context file of existing/primary node>

              • 4. Re: Add and clone to Multi node system
                953987

                I am adding node ( non-shared file system) using below command.

                 

                My primary server  :APP1

                Secondary : APP2

                 

                while running, am getting below error

                 

                perl adclonectx.pl addnode contextfile=/u02/DEV/fs_ne/run/DEV_APP1.xml pairsfile=/u02/DEV/fs_ne/run/pairsfile_NODE2.txt dualfs=yes

                 

                ERROR: Unable to get the connection to the MBean Server

                Creating the managed server oacore_server2

                ERROR: Unable to get the connection to the MBean Server

                Validating the value of the managed server context variables...

                 

                ERROR: Unable to get the connection to the MBean Server

                Connecting to t3://APP2.local:7001 with userid weblogic ...

                 

                ERROR: Unable to connect to the Admin Server..

                You will need to be connected to a running server to execute this command

                You will need to be connected to a running server to execute this command

                Connecting to t3://APP2.local:7001 with userid weblogic ...

                 

                Below pairsfile:

                --------------------

                 

                [Base]

                s_base=/u02/DEV

                s_current_base=/u02/DEV/fs1

                s_other_base=/u02/DEV/fs2

                s_ne_base=/u02/DEV/fs_ne

                 

                [General]

                s_applptmp=/usr/tmp

                s_appsgroup=oinstall

                s_appsuser=appldev

                s_dbuser=oradev

                s_dbgroup=oinstall

                s_dbdomain=APP1.local

                s_at=/u02/DEV/fs1/EBSapps/appl

                s_com=/u02/DEV/fs1/EBSapps/comn

                s_tools_oh=/u02/DEV/fs1/EBSapps/10.1.2

                s_weboh_oh=/u02/DEV/fs1/FMW_Home/webtier

                s_fmw_home=/u02/DEV/fs1/FMW_Home

                s_dbGlnam=DEV

                s_dbSid=DEV

                s_dbhost=APP1

                s_clonestage=/u02/DEV/fs1/EBSapps/comn/clone

                s_dbport=1521

                s_options_symlinks=Options -FollowSymLinks

                s_proxyhost=

                s_proxybypassdomain=local

                s_proxyport=

                s_nonproxyhosts=

                s_javamailer_imapdomainname=NoImapDomain

                s_javamailer_imaphost=NoImapHost

                s_javamailer_reply_to=NoReplyTo

                s_javamailer_outbound_user=changeOnJavaMailerInstall

                s_smtphost=

                s_smtpdomainname=test.local

                s_file_edition_type=run

                s_port_pool=0

                patch_s_port_pool=1

                s_admhost=APP2

                s_atName=AT_APP2

                s_shared_file_system=false

                 

                [Web Entry Point Configuration]

                s_webentryurlprotocol=http

                s_webentryhost=APP2

                s_webentrydomain=local

                s_active_webport=8000

                s_endUserMonitoringURL=http://APP2.local:8000/oracle_smp_chronos/oracle_smp_chronos_sdk.gif

                s_external_url=http://APP2.local:8000

                s_login_page=http://APP2.local:8000/OA_HTML/AppsLogin

                 

                [Instance Specific]

                s_temp=/u02/DEV/fs1/inst/apps/DEV_APP2/temp

                s_contextname=DEV_APP2

                s_hostname=APP2

                s_domainname=local

                s_cphost=APP2

                s_webhost=APP2

                s_config_home=/u02/DEV/fs1/inst/apps/DEV_APP2

                s_inst_base=/u02/DEV

                s_display=APP2:0.0

                s_forms-c4ws_display=APP2:0.0

                s_ohs_instance=EBS_web_DEV_OHS2

                s_webport=8000

                s_http_listen_parameter=8000

                s_https_listen_parameter=4443

                 

                [Services To be Enabled on the Secondary Application Tier Node]

                s_web_applications_status=enabled

                s_web_entry_status=enabled

                s_apcstatus=enabled

                s_root_status=enabled

                s_batch_status=disabled

                s_other_service_group_status=enabled

                s_adminserverstatus=disabled

                s_web_admin_status=disabled

                • 5. Re: Add and clone to Multi node system
                  953987

                  Admin server is running on both run and patch edition in primary server

                  • 6. Re: Add and clone to Multi node system
                    953987

                    actually my admin server is APP1, don;t know why it is trying to connect to APP2

                    • 7. Re: Add and clone to Multi node system
                      Aldrich

                      I would try running it this way and populate the questions manually...

                       

                      perl adclonectx.pl addnode contextfile=/u02/DEV/fs_ne/run/DEV_APP1.xml