2 Replies Latest reply on Mar 21, 2017 10:53 AM by joehoub

    Row Type Filter not working

    joehoub

      If I define a row type filter in IG like shown below the resulting entry contains escape characters and does not work

       

       

        • 1. Re: Row Type Filter not working
          Anthony Rayner-Oracle

          Hi,

           

          Many thanks for reporting this. I was easily able to reproduce the over escaping behaviour, and have filed bug #25755555 for this issue which we currently plan to fix in the 5.1.2 patch. I was not able to reproduce the filter not working though, in that it still worked correctly in filtering the data as it should. I tried the following test case:

           

          1) In the Interactive Grid sample app, go to the 'Editing > Basic Editing' example. Change some data to include an apostrophe, so say one of the row's notes columns to include '10'.

          2) Go to Actions > Filter, change type to 'Row', and enter a search of '10'.

          3) Hit Save

          4) Observe the IG filters correctly to show the row changed to include '10', however in the report settings area, the row filter appears as follows: Search for ''10''.

           

          Please let me know if you are able to reproduce the filter also not working properly, and if so provide similar steps.

           

          Kind regards,

          Anthony.

          • 2. Re: Row Type Filter not working
            joehoub

            Hi Anthony,

             

            I followed your instructions and had the same result. The filter works as described.

             

            But my intention was to identify the column 'vg' in the condition (vg='10').

            I know that this could be better achieved by using a column filter but in case of joining columns with an 'OR'-Operator the only way seems to be the row filter.

             

            For example: I need to filter the records like in the following where-clause:  "where vg='10' OR projekt='A0906%'"

            "vg" and "projekt" are columns in the IG.

             

            Thanks for your guidance