1 2 Previous Next 22 Replies Latest reply on Mar 26, 2017 7:59 AM by 979524

    Upgrade R12.2.0 to R12.2.5

    979524

      Hi,

       

        I have installed R12.2.0 with startcd version 51. Now I want to upgrade the instance to R12.2.5.

       

        Please suggest me the document / steps / links to achieve the same.

       

       

      Thanks,

      ASM

        • 1. Re: Upgrade R12.2.0 to R12.2.5
          mdtaylor

          Please follow these notes.  Shutdown 12.2.0 applications and run ETCC checker, then apply all listed patches to each Oracle Home.  Then proceed with consolidated Seed patches, AD/TXK patches then 12.2.5 upgrade patch.

           

          Oracle E-Business Suite Release Notes, Release 12.2 (Doc ID 1320300.1)

          Oracle E-Business Suite Installation and Upgrade Notes Release 12 (12.2) for Linux x86-64 (Doc ID 1330701.1)

          Applying the Latest AD and TXK Release Update Packs to Oracle E-Business Suite Release 12.2 (Doc ID 1617461.1)

          Oracle E-Business Suite Release 12.2: Consolidated List of Patches and Technology Bug Fixes (Doc ID 1594274.1)

          Oracle E-Business Suite Release 12.2.5 Readme (Doc ID 1983050.1)

          Useful 12.2 Documents (Doc ID 1585889.1)

           

          Regards,

          Michael

          • 2. Re: Upgrade R12.2.0 to R12.2.5
            979524

            Thanks for the update.

             

            First time I am installing R12.2.0 and Installed with version DB - 12.1.0.2 and Apps - R12.2.0

             

            1 - By default adop enabled in R12.2.0?

             

            2- What all steps do I need to do before planning upgrade ?

             

            3- Do I need to run fs_clone before performing any action ?

             

            4 - can't find EBSapps.env file ?

             

             

            Thanks,

            ASM

            • 3. Re: Upgrade R12.2.0 to R12.2.5
              mdtaylor

              There are several blogs which show step by step 12.2.0 to 12.2.5 patching.

               

              http://alexanderpavlik.blogspot.com/2016/04/upgrade-oracle-ebs-1220-to-1225.html

              https://tobeimpact.blogspot.com/2015/11/step-by-step-upgrade-from-r1220-to-r1225.html

               

              1 - By default adop enabled in R12.2.0? - Yes

               

              2- What all steps do I need to do before planning upgrade ? - Download ETCC patch and run checker script against database and applications then download all required patches

               

              3- Do I need to run fs_clone before performing any action ? - No

               

              4 - can't find EBSapps.env file ? - Make a softlink to fs1/EBSapps/appl/APPS{sid}_{host}.env

               

              ln -s /lv01/oracle/prd122/fs1/EBSapps/appl/APPSprd122_server.env prd122_fresh.env

               

              After you upgrade to latest AD/TXK patches, the EBSApps.env file will be there.

               

              Regards,

              Michael

              • 4. Re: Upgrade R12.2.0 to R12.2.5
                979524

                Thanks for the update.

                 

                I am planning to upgrade after running the ETCC. But before that I just want to know the how the R12.2.0 version works.

                 

                I ran adop phase=fs_clone and failed with below error.

                 

                [ERROR]     Error occurred while executing <perl /u02/EBSTST/fs1/EBSapps/appl/ad/12.0.0/patch/115/bin/txkADOPPreparePhaseSynchronize.pl -contextfile=/u02/EBSTST/fs1/inst/apps/EBSTST_server1/appl/admin/EBSTST_server1.xml -patchcontextfile=/u02/EBSTST/fs2/inst/apps/EBSTST_server1/appl/admin/EBSTST_server1.xml -promptmsg=hide -console=off -mode=create -sessionid=3 -timestamp=20170321_155608 -outdir=/u02/EBSTST/fs_ne/EBSapps/log/adop/3/fs_clone_20170321_155608/EBSTST_server1>

                        [ERROR]     Error occurred while CLONE PATCH FS with RUN FS using command: <perl /u02/EBSTST/fs1/EBSapps/appl/ad/12.0.0/patch/115/bin/txkADOPPreparePhaseSynchronize.pl -contextfile=/u02/EBSTST/fs1/inst/apps/EBSTST_server1/appl/admin/EBSTST_server1.xml -patchcontextfile=/u02/EBSTST/fs2/inst/apps/EBSTST_server1/appl/admin/EBSTST_server1.xml -promptmsg=hide -console=off -mode=create -sessionid=3 -timestamp=20170321_155608 -outdir=/u02/EBSTST/fs_ne/EBSapps/log/adop/3/fs_clone_20170321_155608/EBSTST_server1>.

                        [ERROR]     fs_clone phase completed with errors/warnings. Please check logfiles

                • 5. Re: Upgrade R12.2.0 to R12.2.5
                  mdtaylor

                  You may need to abort this adop session you started if fs_clone was the first step you executed.  There is no need to run fs_clone until you complete the 12.2.5 upgrade.

                   

                  adop phase=abort

                   

                  adop --help

                  Applications DBA Online Patching Tool (adop)

                   

                  Usage: adop [phase=<phase,phase,...>] [patches=<patch#,patch#,...>]

                              [<parameter>=<value> ...] [input_file=<filename>]

                         adop -help

                         adop -examples

                         adop -status [<session_id>]

                         adop -validate

                   

                  See Oracle E-Business Suite Maintenance Guide for a full description of

                  adop features, operation, and usage.

                   

                  The phase parameter specifies the parts (phases) of the online

                  patching cycle to be executed. The five standard phases are executed

                  in the order shown below.

                   

                  Standard phases:

                    prepare       - Prepare the instance for patch application.

                    apply         - Apply patches (to the patch edition).

                    finalize      - Ready the instance for cutover.

                    cutover       - Make the patch edition the new run edition.

                    cleanup       - Drop obsolete objects and data from old editions.

                   

                  There are also three special phases, for use when needed.

                   

                  Special phases:

                    abort         - Abort the current online patching cycle.

                    actualize_all - Create actual copies of all code objects in the patch

                                    edition.

                    fs_clone      - Copy the run file system to the patch file system.

                  • 6. Re: Upgrade R12.2.0 to R12.2.5
                    979524

                    Thanks...I have restore complete system from backup.

                    Now I have clean system and will start upgrade plan

                    • 7. Re: Upgrade R12.2.0 to R12.2.5
                      Shaik

                      Hi

                       

                      Once you restore your R12.2.0, you just follow the steps mentioned R12.2.5 readme

                      Oracle E-Business Suite Release 12.2.5 Readme (Doc ID 1983050.1)

                       

                       

                      Regards

                      Shaik

                       

                       

                      • 8. Re: Upgrade R12.2.0 to R12.2.5
                        979524

                        I have applied Patch and Bug fixes on DB,forms,FMW webtier, FMW common,WLS.

                        Now I am applying  Seed Table Upgrade Patch 17204589 using below command

                        adop phase=apply patches=17204589,21900871 merge=yes hotpatch=yes

                         

                        After this, it is mandatory to run phase=cleanup and phase=fs_clone  before proceeding to next step (Applying the Latest AD and TXK Release Update Packs)?

                         

                        Or Can I continue directly with Applying the Latest AD and TXK Release Update Packs to Oracle E-Business Suite Release 12.2 ?

                        • 9. Re: Upgrade R12.2.0 to R12.2.5
                          mdtaylor

                          You do not cleanup or fs_clone after the seed data patches but proceed directly to applying the AD/PXK patches in hotpatch mode per the document for new installations.

                          • 10. Re: Upgrade R12.2.0 to R12.2.5
                            979524

                            Thanks for the update.

                             

                            While applying R12.2.5 patch, in log file I can see below warnings ( lot of warning for this xdo), patch activity is going on.

                             

                            Is this expected ?

                             

                            Warning: oracle/apps/xdo/template/fo/datatype/Border - Invalid entry. No resource unit matching this pattern found.

                            Warning: oracle/apps/xdo/template/fo/datatype/BorderContainer - Invalid entry. No resource unit matching this pattern found.

                            Warning: oracle/apps/xdo/template/fo/datatype/CarryForwardContainer - Invalid entry. No resource unit matching this pattern found.

                            Warning: oracle/apps/xdo/template/fo/datatype/Color - Invalid entry. No resource unit matching this pattern found.

                            Warning: oracle/apps/xdo/template/fo/datatype/ColorPool - Invalid entry. No resource unit matching this pattern found.

                            Warning: oracle/apps/xdo/template/fo/datatype/ColumnInfo - Invalid entry. No resource unit matching this pattern found.

                            Warning: oracle/apps/xdo/template/fo/datatype/CombinedRectangle - Invalid entry. No resource unit matching this pattern found.

                            Warning: oracle/apps/xdo/template/fo/datatype/Direction - Invalid entry. No resource unit matching this pattern found.

                            Warning: oracle/apps/xdo/template/fo/datatype/DirectionPool - Invalid entry. No resource unit matching this pattern found.

                            Warning: oracle/apps/xdo/template/fo/datatype/Edge - Invalid entry. No resource unit matching this pattern found.

                            Warning: oracle/apps/xdo/template/fo/datatype/EdgePool - Invalid entry. No resource unit matching this pattern found.

                            Warning: oracle/apps/xdo/template/fo/datatype/FOProperties - Invalid entry. No resource unit matching this pattern found.

                            • 11. Re: Upgrade R12.2.0 to R12.2.5
                              mdtaylor

                              It appears from earlier versions that the message could be ignored.

                               

                              R11i : About Oracle Applications DBA Minipack 11i.AD.I (Doc ID 233044.1)

                              • 12. Re: Upgrade R12.2.0 to R12.2.5
                                979524

                                Thanks...Upgrade over and all is working fine. Upgraded to 12.2.5.

                                 

                                My Java version is 1.6u27, Please provide link/steps to upgrade java version

                                • 13. Re: Upgrade R12.2.0 to R12.2.5
                                  mdtaylor

                                  Please see the following document:

                                   

                                  Deploying JRE (Native Plug-in) for Windows Clients in Oracle E-Business Suite Release 12 (Doc ID 393931.1)

                                   

                                  For java higher than 1.7.0_21, you will need a code signing certificate from a signing authority to open forms.

                                   

                                  Enhanced Jar Signing for Oracle E-Business Suite (Doc ID 1591073.1)

                                   

                                  Regards,

                                  Michael

                                  • 14. Re: Upgrade R12.2.0 to R12.2.5
                                    979524

                                    Thanks for the update. Upgraded the java version to 1.8 u92. But the problem is when I use java 64 bit in server, it is not launching forms in desktop even client java version is 64 bit. Then I replaced the version to 32 bit and is working fine. How I can use 64 bit java in server

                                     

                                    OS - Oracle Linux 6.4  64bit

                                    1 2 Previous Next