3 Replies Latest reply on Apr 4, 2017 7:15 AM by Gary Graham-Oracle

    error when starting sql developer

    L_i_F_e

      I downloaded sql developer version 4.2 for windows, i recently reset my laptop to factory setting, after that i am not able to open sql developer. i am getting the attached error message please help

       

      the error message is Unable to launch the Java Virtual Machine located at path C:\users\protected\Downloads\sqldeveloper\jdk\bin\msvcr100.dll

       

      to fix this i installed latest java but still the problem exists.

       

       

      sqld.PNG

        • 1. Re: error when starting sql developer
          Gary Graham-Oracle

          Unable to launch the Java Virtual Machine located at path C:\users\protected\Downloads\sqldeveloper\jdk\bin\msvcr100.dll

          Copy the mentioned file to the mentioned location (jdk\bin), after creating the bin folder.  You can get mscvcr100.dll from (jdk\jre\bin) in your SQL Developer install.  This has been fixed for the SQL Developer 4.2 production release.

           

          Alternatively, if you wish to avoid using the bundled server JRE in SQL Developer and use the separately installed JDK instead, just edit the SetJavaHome line in product.conf under your user settings Roaming\sqldeveloper\4.2.0 folder to point to that installed JDK.

          1 person found this helpful
          • 2. Re: error when starting sql developer
            L_i_F_e

            what is this file msvcr100.dll  ? why is this file important ? every application uses this file even Nmap uses this file !

            • 3. Re: error when starting sql developer
              Gary Graham-Oracle

              Indeed, in general this issue has a very long history, as discussed in Issue running SQL Developer x64 4.1.3 with JDK.

               

              Actually our team always considered this a configuration issue, but never a bug until 4.2.  Prior to 4.2 it had never been a problem for anyone with a copy of msvcr100.dll in a folder included in their PATH environment variable.  For some reason this changed in 4.2 but, as stated in my prior post, it is fixed for 4.2 production.