9 Replies Latest reply on Apr 11, 2017 9:04 AM by Joel Acha

    ORA-12154: TNS:could not resolve the connect identifier specified at OCI call OCIServerAttach

    Maahjoor

      Dear all,

       

      i am following the below tutorial

      http://www.oracle.com/webfolder/technetwork/tutorials/obe/fmw/bi/bi1221/rpd/rpd.html#section4s4

      i am using OBIEE 12c.

       

      under the section, Creating and Running Analysis, under step 8, i receive the following error message

       

        

      Odbc driver returned an error (SQLExecDirectW).

      http://localhost:9502/analytics/res/v-vQCQg5v6K1w/sk_blafp/common/errorminus.gif  Error Details

      Error Codes: OPR4ONWY:U9IM8TAC:U9IM8TAC:U9IM8TAC:U9IM8TAC:OI2DL65P

       

      State: HY000. Code: 10058. [NQODBC] [SQL_STATE: HY000] [nQSError: 10058] A general error has occurred. (HY000)

       

      State: HY000. Code: 43113. [nQSError: 43113] Message returned from OBIS. (HY000)

       

      State: HY000. Code: 17001. [nQSError: 17001] Oracle Error code: 12154, message: ORA-12154: TNS:could not resolve the connect identifier specified at OCI call OCIServerAttach. (HY000)

       

      State: HY000. Code: 17014. [nQSError: 17014] Could not connect to Oracle database. (HY000)

       

      SQL Issued: SELECT 0 s_0, "Students"."D Colleges"."College Name Ara" s_1, "Students"."D Degrees"."Degree Desc Arb" s_2, "Students"."D Departments"."Department Name Ara" s_3, "Students"."D Fascal Years"."Year Description" s_4, "Students"."D Students"."Count Female" s_5, "Students"."D Students"."Count Male" s_6, "Students"."F Student Graduation"."Avg GPA" s_7, "Students"."F Student Graduation"."Max GPA" s_8, "Students"."F Student Graduation"."Min GPA" s_9 FROM "Students" FETCH FIRST 65001 ROWS ONLY

      i have load the repositary using the following command.

       

       

      Cd C:\Oracle\Middleware\Oracle_Home\user_projects\domains\bi\bitools\bin

      datamodel.cmd uploadrpd -I C:\Oracle\Middleware\Oracle_Home2\bi\bifoundation\server\Student_Repository.rpd -W Oracle_123 -U weblogic -P Oracle_123 -SI pdborcl

       

       

      how could i fix it?

       

      Thank you.