2 Replies Latest reply on Apr 27, 2017 7:21 AM by 3419909

    Schema Objects not visible with  SQL developer 4.2.0.17.089 (JDK included)

    3419909

      Hi all,

      I am facing issue with the SQL developer 4.2.0.17.089. I have downloaded "sqldeveloper-4.2.0.17.089.1709-x64.zip" from oracle product site.

      It connects to the database with success but schema browser is not visible.None of the objects are visible when I expand the icon.

      Even basic queries are not running.

      The connectivity is just through "basic" with hostname:port and service_name with userId and pwd.

       

       

      The JRE version of my system  is below :

       

      java version "1.8.0_131"

      Java(TM) SE Runtime Environment (build 1.8.0_131-b11)

      Java HotSpot(TM) 64-Bit Server VM (build 25.131-b11, mixed mode).

       

      Kindly let me know if anybody has faced such issue or having any idea on this.

        • 1. Re: Schema Objects not visible with  SQL developer 4.2.0.17.089 (JDK included)
          Gary Graham-Oracle

          If the problem was just a lack of object nodes (Tables, Views, Packages, etc) under the TC connection node, then I would suspect the Tools > Preferences > Database > Navigation Filter being set to exclude all object types from the navigator tree.

           

          You say, however, that basic queries are not working from the Worksheet either.  What basic queries?  Queries against objects you know / think the user owns?  Some data dictionary queries?  You need to describe more about the TC connection user's privileges and the objects owned by it.  Also, whether or not you migrated from a prior version of SQL Developer, and if all worked in that prior version.

          • 2. Re: Schema Objects not visible with  SQL developer 4.2.0.17.089 (JDK included)
            3419909

            Hi Gary,

            I have double checked Navigation Filter. There is no issue with that. All types of objects are default included.

             

            After I connected to the DB, I fired a simple query like "select sysdate from dual", even that query is not fetching the date, forget about any existing objects..!!!

             

             

             

            Now regarding permissions or read/write access, my team mates are also using same user credentials and connection details and they are not facing any issues.

            I have used 4.2.0 and also 4.1.3 and 4.1.5 versions and for all of them are having problem.

            During launching everytime, I have not imported any preferences from previous versions.

             

             

            Is this a potential Java/JRE problem of my system?

            I have even tried with JRE1.7 also but no luck.

            Also below is the screen shot of the query I ran.

             

             

             

             

            Please suggest.