12 Replies Latest reply on May 2, 2017 11:44 AM by saketsrv

    UnsupportedClassVersionError - major.minor version 52.0

    saketsrv

      Hi All,

       

      After successfully installing FMW Infrastructure and OBIEE 12c Software I am getting below error while running configuration.

       

       

      --------

      Launcher log file is /var/tmp/OraInstall2017-04-28_04-57-59PM/launcher2017-04-28_04-57-59PM.log.

      Checking monitor: must be configured to display at least 256 colors.   Actual 16777216    Passed

      Checking swap space: must be greater than 500 MB.   Actual 31794 MB    Passed

      Checking if this platform requires a 64-bit JVM.   Actual 64    Passed

       

      Log: /oracle/product/oraInventory/logs/install2017-04-28_04-57-59PM.log

      [ERROR]: Installer has encountered an internal Error. Contact Oracle support with details

      [EXCEPTION]:java.lang.reflect.InvocationTargetException

      Logs successfully copied to /oracle/product/oraInventory/logs.

       

       

      Install Log:

       

      Setting ORACLE_HOME to /home/oraclebi/Obiee12c/Middleware/Oracle_Home

      java.lang.reflect.InvocationTargetException

        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)

        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

        at java.lang.reflect.Method.invoke(Method.java:606)

        at oracle.as.install.engine.InstallEngine.launchModule(InstallEngine.java:580)

        at oracle.as.install.engine.InstallEngine.processAndLaunchModules(InstallEngine.java:522)

        at oracle.as.install.engine.InstallEngine.startOperation(InstallEngine.java:471)

        at oracle.sysman.oio.oioc.OiocOneClickInstaller.main(OiocOneClickInstaller.java:717)

      Caused by: java.lang.UnsupportedClassVersionError: oracle/bi/configassistant/ui/pages/welcomeconfig/validation/WelcomeConfigPageHandler : Unsupported major.minor version 52.0

        at java.lang.ClassLoader.defineClass1(Native Method)

        at java.lang.ClassLoader.defineClass(ClassLoader.java:792)

        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)

        at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)

        at java.net.URLClassLoader.access$100(URLClassLoader.java:71)

        at java.net.URLClassLoader$1.run(URLClassLoader.java:361)

        at java.net.URLClassLoader$1.run(URLClassLoader.java:355)

        at java.security.AccessController.doPrivileged(Native Method)

        at java.net.URLClassLoader.findClass(URLClassLoader.java:354)

        at oracle.as.install.engine.modules.handler.util.URLHandlerClassLoader.loadClass(URLHandlerClassLoader.java:165)

        at oracle.as.install.engine.modules.handler.util.URLHandlerClassLoader.loadClass(URLHandlerClassLoader.java:144)

        at java.lang.ClassLoader.loadClass(ClassLoader.java:357)

        at oracle.as.install.engine.modules.handler.util.HandlerClassLoader.loadLib(HandlerClassLoader.java:100)

        at oracle.as.install.engine.modules.handler.HandlerModule.processHandlers(HandlerModule.java:290)

        at oracle.as.install.engine.modules.handler.HandlerModule.preProcess(HandlerModule.java:193)

        at oracle.as.install.engine.modules.handler.HandlerModule.launchModule(HandlerModule.java:144)

        ... 8 more

      [ERROR]: Installer has encountered an internal Error. Contact Oracle support with details

      [EXCEPTION]:java.lang.reflect.InvocationTargetException

       

       

       

      Please suggest this if this can be fixed from my side or do i need to raise an SR in internal forum.