1 2 Previous Next 19 Replies Latest reply on Jun 14, 2017 3:53 PM by Miguel Ferrufino

    OBI 11g - Initializing obis1

    Miguel Ferrufino

      Hi everyone.

       

      We have a server with OBIEE 11g and we restarted the server the last weekend, but now we can't start the coreapplication_obis1 (obi server component). It just keeps in init state.

       

      any idea why?

      We really appreciate your help.

        • 1. Re: OBI 11g - Initializing obis1
          Sherry George

          I assume that it was working fine before, so what changed? As to ideas, check the logs (nqserver.log is a good place to start)

          • 2. Re: OBI 11g - Initializing obis1
            Miguel Ferrufino

            Yes, it was working fine.

             

            I have this error:

            MessageError in starting component: oracle instance: instance1, component: coreapplication_obis1
            Supplemental Detailoracle.bi.management.adminservices.opmn.ProcessControlException: Operation Failed: start; OracleInstance: instance1; Component: coreapplication_obis1; msg: Failed to create secure socket for OPMN at orabi:9501. The remote OPMN server is probably not running or the OPMN mbean is not properly configured. See the adminserver log for more details.

            at oracle.bi.management.adminservices.opmn.OpmnProcessController.start(OpmnProcessController.java:145)

            at oracle.bi.management.adminservices.model.impl.ProcessManagerProxyImpl.start(ProcessManagerProxyImpl.java:70)

            at oracle.bi.management.adminservices.mbeans.impl.BIComponentMBeanImpl.start(BIComponentMBeanImpl.java:171)

            at oracle.bi.management.adminservices.mbeans.impl.BIComponentMBeanImpl.start(BIComponentMBeanImpl.java:159)

            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

            at java.lang.reflect.Method.invoke(Method.java:597)

            at oracle.as.jmx.framework.standardmbeans.spi.OracleStandardEmitterMBean.doInvoke(OracleStandardEmitterMBean.java:1012)

            at oracle.adf.mbean.share.AdfMBeanInterceptor.internalInvoke(AdfMBeanInterceptor.java:104)

            at oracle.as.jmx.framework.generic.spi.interceptors.AbstractMBeanInterceptor.doInvoke(AbstractMBeanInterceptor.java:252)

            at oracle.as.jmx.framework.generic.spi.security.AbstractMBeanSecurityInterceptor.internalInvoke(AbstractMBeanSecurityInterceptor.java:190)

            at oracle.as.jmx.framework.generic.spi.interceptors.AbstractMBeanInterceptor.doInvoke(AbstractMBeanInterceptor.java:252)

            at oracle.security.jps.ee.jmx.JpsJmxInterceptor$2.run(JpsJmxInterceptor.java:358)

            • 3. Re: OBI 11g - Initializing obis1
              Sherry George

              Miguel Ferrufino wrote:

               

              Yes, it was working fine.

              So did something change? Perform an opmnctl stopall make sure the processes are down and then do a opmnctl startall or try a complete restart of the system (including weblogic).

              https://docs.oracle.com/cd/E23943_01/bi.1111/e10541/components.htm#BIESG486

              • 4. Re: OBI 11g - Initializing obis1
                Christian Berg

                Most valid question has already been asked: "Ok but so WHAT changed?!"

                 

                Also: have you already bounced the whole env again? Admin Server, Managed Server + all OPMN? Maybe it just fell on its face during startup.

                • 5. Re: OBI 11g - Initializing obis1
                  Miguel Ferrufino

                  Sherry. We don't know if something was changed, but when we checked the env, the variable JAVA_HOME had not been setted.

                  We have already tried to stopall and startall from opmnctl.

                  • 6. Re: OBI 11g - Initializing obis1
                    Miguel Ferrufino

                    Christian, we don't know if something has changed, may be a variable, but we don't know which one.

                    I have already bounced the whole env again, but it didn't work.

                    • 7. Re: OBI 11g - Initializing obis1
                      Christian Berg

                      Do you have backups of the environment? Randomly hunting for variables may be a fun activity for some hours but it will soon become tedious

                      • 8. Re: OBI 11g - Initializing obis1
                        Miguel Ferrufino

                        That's a good option. I will see if there are backups of the environment.

                         

                        I got this error <Error> <oracle.as.management.mbeans.opmn>, it looks like a java error.

                        • 9. Re: OBI 11g - Initializing obis1
                          Christian Berg

                          "orabi:9501. The remote OPMN server is probably not running or the OPMN mbean is not properly configured"

                           

                          ^--- Question being why the heck that only breaks for OBIS and the other components work.

                          • 10. Re: OBI 11g - Initializing obis1
                            Miguel Ferrufino

                            Yes, that's the question. Why are the other components working well??

                             

                            In my opmn.log got this when I try to do ./opmnctl startproc ias-component coreapplication_obis1:

                             

                            -04:00] [opmn] [ERROR:1] [] [libopmncustom] Process Ping Failed: coreapplication_obis1~OracleBIServerComponent~coreapplication_obis1~1 (257231713:9041)

                            [2017-06-13T10:26:58-04:00] [opmn] [ERROR:1] [] [libopmncustom] Ping failed in Ready callback for proc:257231713

                            [2017-06-13T10:27:00-04:00] [opmn] [ERROR:1] [] [libopmncustom] Process Ping Failed: coreapplication_obis1~OracleBIServerComponent~coreapplication_obis1~1 (257231713:9041) [No addresses for the request]

                            [2017-06-13T10:27:00-04:00] [opmn] [ERROR:1] [] [libopmncustom] Process Ping Failed: coreapplication_obis1~OracleBIServerComponent~coreapplication_obis1~1 (257231713:9041)

                            [2017-06-13T10:27:00-04:00] [opmn] [ERROR:1] [] [libopmncustom] Ping failed in Ready callback for proc:257231713

                            [2017-06-13T10:27:02-04:00] [opmn] [ERROR:1] [] [libopmncustom] Process Ping Failed: coreapplication_obis1~OracleBIServerComponent~coreapplication_obis1~1 (257231713:9041) [No addresses for the request]

                            [2017-06-13T10:27:02-04:00] [opmn] [ERROR:1] [] [libopmncustom] Process Ping Failed: coreapplication_obis1~OracleBIServerComponent~coreapplication_obis1~1 (257231713:9041)

                            [2017-06-13T10:27:02-04:00] [opmn] [ERROR:1] [] [libopmncustom] Ping failed in Ready callback for proc:257231713

                            [2017-06-13T10:27:04-04:00] [opmn] [ERROR:1] [] [libopmncustom] Process Ping Failed: coreapplication_obis1~OracleBIServerComponent~coreapplication_obis1~1 (257231713:9041) [No addresses for the request]

                            [2017-06-13T10:27:04-04:00] [opmn] [ERROR:1] [] [libopmncustom] Process Ping Failed: coreapplication_obis1~OracleBIServerComponent~coreapplication_obis1~1 (257231713:9041)

                            [2017-06-13T10:27:04-04:00] [opmn] [ERROR:1] [] [libopmncustom] Ping failed in Ready callback for proc:257231713

                            [2017-06-13T10:27:06-04:00] [opmn] [ERROR:1] [] [libopmncustom] Process Ping Failed: coreapplication_obis1~OracleBIServerComponent~coreapplication_obis1~1 (257231713:9041) [No addresses for the request]

                            [2017-06-13T10:27:06-04:00] [opmn] [ERROR:1] [] [libopmncustom] Process Ping Failed: coreapplication_obis1~OracleBIServerComponent~coreapplication_obis1~1 (257231713:9041)

                            [2017-06-13T10:27:06-04:00] [opmn] [ERROR:1] [] [libopmncustom] Ping failed in Ready callback for proc:257231713

                            [2017-06-13T10:27:08-04:00] [opmn] [ERROR:1] [] [libopmncustom] Process Ping Failed: coreapplication_obis1~OracleBIServerComponent~coreapplication_obis1~1 (257231713:9041) [No addresses for the request]

                            [2017-06-13T10:27:08-04:00] [opmn] [ERROR:1] [] [libopmncustom] Process Ping Failed: coreapplication_obis1~OracleBIServerComponent~coreapplication_obis1~1 (257231713:9041)

                            [2017-06-13T10:27:08-04:00] [opmn] [ERROR:1] [] [libopmncustom] Ping failed in Ready callback for proc:257231713

                            [2017-06-13T10:27:10-04:00] [opmn] [ERROR:1] [] [libopmncustom] Process Ping Failed: coreapplication_obis1~OracleBIServerComponent~coreapplication_obis1~1 (257231713:9041) [No addresses for the request]

                            [2017-06-13T10:27:10-04:00] [opmn] [ERROR:1] [] [libopmncustom] Process Ping Failed: coreapplication_obis1~OracleBIServerComponent~coreapplication_obis1~1 (257231713:9041)

                            [2017-06-13T10:27:10-04:00] [opmn] [ERROR:1] [] [libopmncustom] Ping failed in Ready callback for proc:257231713

                            • 11. Re: OBI 11g - Initializing obis1
                              Christian Berg

                              Is the component registration for OBIS in OPMN messed up? I.e. have you tried deregistering and reregistering it?

                              • 12. Re: OBI 11g - Initializing obis1
                                Miguel Ferrufino

                                How can I do that ? reregistering and deregistering it?

                                • 13. Re: OBI 11g - Initializing obis1
                                  Christian Berg

                                  https://docs.oracle.com/cd/E23943_01/doc.1111/e14007/opmnctl.htm#ASPMN135

                                   

                                  But do some checks and especially BACKUPS first before going off to "deletecomponent"

                                  1 person found this helpful
                                  • 14. Re: OBI 11g - Initializing obis1
                                    Miguel Ferrufino

                                    So, you advice that delete the component that does not initiate and then register it again?

                                    1 2 Previous Next