0 Replies Latest reply on Jun 21, 2017 1:54 AM by 954736

    R12.1.3 [ons-secure] Connection 19c0a,hostname02.domain,6200 SSL handshake failed (29024)

    954736

      Customer setups the oc4j_cluster,then start the oc4j cluster,the above ssl handshake failed was showed on the opmn.log.

       

      only one node services of cluster are up.

       

      the another node services of cluster are not up.

       

       

      Background:

      1.Multiply Application Tier Nodes (customer add two nodes to oc4j cluster)

      2.Customer uses DMZ,SSL and SSO … SSL offloading is done at load balancer.

      3.refer the Note:380489.1 to setup oc4j_cluster

      4.run $INST_TOP/admin/scripts/adopmnctl.sh @cluster status

       

       

      adopmnctl.sh status @cluster ( shows only one node from where adopmnctl.sh run)

       

      You are running adopmnctl.sh version 120.6.12010000.5

       

      Checking status of OPMN managed processes…

       

      Processes in Instance: ENVK_hostname02.hostname02.domain

      ———————————+——————–+———+———

      ias-component | process-type | pid | status

      ———————————+——————–+———+———

      OC4JGroup:default_group | OC4J:forms-c4ws | 30038 | Alive

      OC4JGroup:default_group | OC4J:oafm | 29757 | Alive

      OC4JGroup:default_group | OC4J:forms | 29674 | Alive

      OC4JGroup:default_group | OC4J:oacore | 11981 | Alive

      HTTP_Server | HTTP_Server | 11562 | Alive

       

       

      adopmnctl.sh: exiting with status 0

       

      adopmnctl.sh: check the logfile /u01/ENVK/inst/apps/ENVK_hostname02/logs/appl/admin/log/adopmnctl.txt for more information …

       

       

      $CONTEXT_FILE

      ————————————-

       

      Application server 1:

      egrep 's_oacorestatus|s_formsstatus|s_oafmstatus|s_oc4j_cluster_nodes|s_ons_remoteport'  $CONTEXT_FILE

               <oc4j_cluster_nodes oa_var="s_oc4j_cluster_nodes">hostname01.domain:6200,hostname02.domain:6200</oc4j_cluster_nodes>

            <ons_remoteport oa_var="s_ons_remoteport" oa_type="PORT" base="6200" step="1" range="-1" label="ONS Remote Port">6200</ons_remoteport>

                  <oa_service_status oa_var="s_oacorestatus">enabled</oa_service_status>

                  <oa_service_status oa_var="s_formsstatus">enabled</oa_service_status>

                  <oa_service_status oa_var="s_oafmstatus">enabled</oa_service_status>

       

       

      Application server 2:

      egrep 's_oacorestatus|s_formsstatus|s_oafmstatus|s_oc4j_cluster_nodes|s_ons_remoteport'  $CONTEXT_FILE

               <oc4j_cluster_nodes oa_var="s_oc4j_cluster_nodes">hostname01.domain:6200,hostname02.domain:6200</oc4j_cluster_nodes>

            <ons_remoteport oa_var="s_ons_remoteport" oa_type="PORT" base="6200" step="1" range="-1" label="ONS Remote Port">6200</ons_remoteport>

                  <oa_service_status oa_var="s_oacorestatus">enabled</oa_service_status>

                  <oa_service_status oa_var="s_formsstatus">enabled</oa_service_status>

                  <oa_service_status oa_var="s_oafmstatus">enabled</oa_service_status>

       

       

      opmn.log

      ==========

      17/06/14 13:32:10 [ons-secure] Connection 19c0a,hostname02.domain,6200 SSL handshake failed (29024)

      17/06/14 13:33:05 [ons-secure] Connection 19c14,192.168.5.6,6200 SSL handshake failed (28860)

      17/06/14 13:34:10 [ons-secure] Connection 19c21,hostname02.domain,6200 SSL handshake failed (29024)

      17/06/14 13:35:05 [ons-secure] Connection 19c29,192.168.5.6,6200 SSL handshake failed (28860)

       

       

      Expect any feedback.

       

      Regards

      Gavin.