4 Replies Latest reply on Jul 17, 2017 6:51 AM by Carola

    WWV_DBMS_SQL still in use in APEX 5.1?

    Carola

      Is the package WWV_DBMS_SQL still in use in APEX 5.1?

      After I upgraded to APEX 5.1 and deleted the old user APEX_050000 the package got invalid and it is not possible to recompile it.

       

      OWNER                OBJECT_TYPE             STATUS

      -------------------- ----------------------- -------

      SYS                  PACKAGE BODY            INVALID

      SYS                  PACKAGE                 VALID

       

       

      select GRANTEE, OWNER,PRIVILEGE from dba_tab_privs where TABLE_NAME ='WWV_DBMS_SQL';

      no rows selected

       

       

      Thanks for your answers,

      Carola

        • 1. Re: WWV_DBMS_SQL still in use in APEX 5.1?
          fac586

          Carola wrote:

           

          Is the package WWV_DBMS_SQL still in use in APEX 5.1?

          After I upgraded to APEX 5.1 and deleted the old user APEX_050000 the package got invalid and it is not possible to recompile it.

           

          OWNER OBJECT_TYPE STATUS

          -------------------- ----------------------- -------

          SYS PACKAGE BODY INVALID

          SYS PACKAGE VALID

           

           

          select GRANTEE, OWNER,PRIVILEGE from dba_tab_privs where TABLE_NAME ='WWV_DBMS_SQL';

          no rows selected

          Check for compilation errors in DBA_ERRORS:

           

          select * from dba_errors where name = 'WWV_DBMS_SQL'
          
          • 2. Re: WWV_DBMS_SQL still in use in APEX 5.1?
            Carola

            Hello,

             

            thanks for your reply.

             

            The errors are all related with APEX_050000 and the grants only went to APEX_050000 and APEX_040200 and NOT to APEX_050100 after I installed APEX 5.1 and BEFORE I dropped User APEX_050000 and APEX_040200.

            Therefore my question is it still necessary in APEX 5.1?

             

            I executed @wwv_dbms_sql.sql and @wwv_dbms_sql.plb of the directory where the APEX 5.1 software is, but still the package won’t comile.

             

             

            TEXT

            ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

            PLS-00201: identifier 'APEX_050000.WWV_FLOW_DYNAMIC_EXEC' must be declared

            PL/SQL: Item ignored

            PL/SQL: ORA-00942: table or view does not exist

            PL/SQL: SQL Statement ignored

            PL/SQL: ORA-00942: table or view does not exist

            PL/SQL: SQL Statement ignored

            PL/SQL: ORA-00942: table or view does not exist

            PL/SQL: SQL Statement ignored

            PLS-00201: identifier 'APEX_050000.WWV_FLOW_SESSION_RAS' must be declared

            PL/SQL: Statement ignored

            PLS-00201: identifier 'APEX_050000.WWV_FLOW_ERROR' must be declared

            PL/SQL: Statement ignored

            PLS-00201: identifier 'APEX_050000.WWV_FLOW_ERROR' must be declared

            PL/SQL: Statement ignored

            PLS-00201: identifier 'APEX_050000.WWV_FLOW_SECURITY' must be declared

            PL/SQL: Statement ignored

            PLS-00201: identifier 'APEX_050000.WWV_FLOW' must be declared

            PL/SQL: Statement ignored

            PLS-00201: identifier 'APEX_050000.WWV_FLOW' must be declared

            PL/SQL: Statement ignored

             

            20 rows selected.

             

            select GRANTEE, OWNER,PRIVILEGE from dba_tab_privs where TABLE_NAME ='WWV_DBMS_SQL';

             

            GRANTEE

             

            --------------------------------------------------------------------------------------------------------------------------------

             

            OWNER                                                                                                                   PRIVILEGE

             

            -------------------------------------------------------------------------------------------------------------------------------- ----------------------------------------

             

            APEX_050000

             

            SYS                                                                                                                     EXECUTE

             

            APEX_040200

             

            SYS                                                                                                                     EXECUTE

             

            2 rows selected.

            • 3. Re: WWV_DBMS_SQL still in use in APEX 5.1?
              Christian Neumueller-Oracle

              Hi Carola,

               

              you can drop sys.wwv_dbms_sql after dropping the old APEX schemas. Starting with 5.1, we are tagging that package with the APEX schema name (e.g. wwv_dbms_sql_apex_050100) to reduce downtime during upgrades.

               

              Regards,

              Christian

              1 person found this helpful
              • 4. Re: WWV_DBMS_SQL still in use in APEX 5.1?
                Carola

                Thanks a lot Christian !

                 

                regards,

                Carola