3 Replies Latest reply on Jul 17, 2017 12:06 AM by swesley_perth

    ORA-01403: no data found

    Eslam_Elbyaly

      Application Express 5.1.1.00.08

      Hi,

      I have a form on a table created with the wizard, and I have a "Fetch row from my table" process. I ran the page successfully many times while I was trying to adjust the items on the layout.

      but the first time I tried to insert a new record, I faced an error(normal error), I had a select list and it was returning character when the Item was a number field, So I closed the run time and changed the return value of the select list to a number. Then when I tried to run the page again I faced

       

      What is the reason for that error?

       

      - Here is the full error statement

      begin begin select "ORDER_ID","SUPPLIER_ID",to_char("PURCHASE_DATE", :p$_format_mask1),"PAYMENT_METHOD","STATUS","DISCOUNT","INSTALLMENTS_NUMBER","DISCOUNT_UNIT","CREATED_BY","MODIFIED_BY",to_char("MODIFY_DATE", :p$_format_mask2) into wwv_flow.g_column_values(1),wwv_flow.g_column_values(2),wwv_flow.g_column_values(3),wwv_flow.g_column_values(4),wwv_flow.g_column_values(5),wwv_flow.g_column_values(6),wwv_flow.g_column_values(7),wwv_flow.g_column_values(8),wwv_flow.g_column_values(9),wwv_flow.g_column_values(10),wwv_flow.g_column_values(11) from "HR"."PURCHASE_ORDER" where "ORDER_ID" = :p_rowid; end;

      end;

       

      I do not know if this is normal or not " where "ORDER_ID" = :P_rowid; "?

       

      Should not it be " Where "order_id" = :p4_order_id; " ?