4 Replies Latest reply on Jul 25, 2017 9:04 PM by Client_321

    Apex 5.1  ords problem

    Client_321

      Anyone know issue with oracle apex ords

      When i type  127.0.0.1:8080/ords/ i got 404 error

        • 1. Re: Apex 5.1  ords problem
          BluShadow

          *** Moderator Note:

           

          As Mike indicates, this is a professional community for people seeking help in a professional manner.

           

          The community is supported by volunteers who are just users of Oracle products like yourself, so using bad language and mouthing off in that manner will not help you to get assistance from those people, who are more than willing to help if you act professionally and provide good details of what your issue actually is.

           

          Abusive language and inappropriate behaviour will not be tolerated.  Please bear this in mind for future posts you make.

           

          ***

          • 2. Re: Apex 5.1  ords problem
            Client_321

            Sure, i apologize, i l post solution here ,its is very common frustrating problem .

            1.After installing apex and later ords if you type 127.0.0.1:8080/ords/   error 404 pop up

            In my case it was issue with  @apex_rest_config.sql script.After executing this script users in database are created but still locked ,i had to unlocked them then login screen showed

            2.Also if images directory is not configured error will show up ,then you have to check path to your images folder and write command

            java -jar ords.war --apex-images /apex/images

            without this directory,page cant load becouse apex relevant files are there

            3.If xdb prompt issue is shown then visit ths blog and follow these steps

            APEX stuff in one place

            • 3. Re: Apex 5.1  ords problem
              Mike Kutz

              The URL you posted is for EPG.

              If XDB Prompt is showing, then you are not using ORDS.  (you are using EPG)

               

              In order to use ORDS, you have to install and configure one of the supported J2EE servers:  TomCat, GlassFish, or Oralce WebLogic Server [WLS] ($$$).  ("standalone mode" should not be counted.)

               

              If the XDB Prompt is still showing, that means that Oracle Database is listening in on Port 8080 and TomCat is not. (ie you are still using EPG and not ORDS).  You'll need to turn off the database's "internal HTTP Server" by ??????.setHTTPPort(0)  (i forgot the name of the package)

               

              If you want $0 PDF creation, you need to install ORDS.

               

              Why complex?

              All open-source Report Generators (that I know) are Java based.  Per mandate, APEX must be able to run on XE.  Oracle XE does not support Java.  Therefore, Report Generators are not part of "APEX Proper".

               

              This is also how SOA designed software works.  (PDF Generation is a "Service")

               

              Lucky for us, ORDS actually includes the Java classes for the open-source Report Generator "Apache FOP".  This allows it to be a PDF Generator Service Provider.  (Your other option is to use BI Publisher $$$$$$$$$ ).

               

              The easiest way to use Apache FOP is to install and use ORDS, then configure your APEX session Print Server for "APEX Listener (ORDS)".

              note:  This implies that you need to install either TomCat or GlassFish (or WLS) prior to "installing ORDS"

               

              With that method, ORDS acts as an Interpreter by doing the following:

              • ORDS will intercepts your "make a PDF Request"
              • creates the PDF within ORDS (using Apache FOP)
              • return a PDF instead of HTML code
              • *** THIS DOES NOT WORK IF YOU ARE USING EPG ***

               

              In short:  Once you have ORDS working, then you can easily create PDFs.

               

              The other "easy $0 PDF Generator" is to configure your APEX Print Server to be "External (Apache FOP)".  With this setup, yours ORDS setup acts like a "Service Provider".

               

              The trick to this one:

              • You will need to go this route (or BI Publisher) if you are going to use the GET_PRINT_DOCUMENT() calls.
              • You still need to use the Apache FOP classes that came with ORDS.  (ie even with EPG, you'll need to install ORDS)
              • You need to modify the database's ACL to allow the database to talk to your ORDS instance on your J2EE server.
                • Think of the ACL as a firewall built into the database with the default of DENY ALL

               

              Reading everything that you have done, I doubt you are able to create a PDF at this point.

               

              NEXT STEPS

              If you are still having problems, please provide the following information:

              • 4 digit database version and edition (first line from SELECT * FROM V$VERSION)
              • APEX version  (3-digits... eg APEX v5.1.2 )
              • How you are accessing APEX ( EPG or ORDS)
              • If ORDS, J2EE Sever and version (eg TomCat 7.0)
              • Sometimes, the Java version being used by TomCat

               

              MK

              • 4. Re: Apex 5.1  ords problem
                Client_321

                Thank you for your reply Mike my version of apex is 5.1.1

                Database version 11g Express edition 11.2.0.2

                i wanted to migrate one part of my forms 11 g aplication on apex so i did fresh install on virtual machine and did basic setup .

                Everything worked fine but for pdf reports in admin instance settings i choose ORacle REST data service just like in this video https://www.youtube.com/watch?v=mHGpOxWNmxk&t=8s

                I know its not reccomended  but it was only for testing purposes

                After that i installed ords 3.0.11 following oracle documentation

                Then i disabled http port with exec dmbs_xdb.sethttpport(0)

                After configuring all those steps i  used 127.0.0.1:8090 /ords/ to login and my first issue was error 404 ,i resolve it by unlocking users made by script @apex_rest_config.sql

                Second issue was wrong image/apex folder and i fixed it

                Third issue was oracle xdb prompt ,i read carefully what you wrote,maybe i configured ords, and apex httpport was still 8080 ,so when i executed dmbs_xdb procedure problem was solved

                My pdf reports are now working fine .Il try to switch on apache tomcat tommorow Thank you