13 Replies Latest reply on Aug 4, 2017 2:18 PM by Mark.Thompson

    OBIEE 12c - Unable to connect to repository in online mode - no ODBC Driver found

    Mark.Thompson

      When I attempt to open my 12c repository in online mode, I get this error message immediately after clicking the blue folder:

       

      pic4.jpg

      So let's check the ODBC System Data Sources.

      pic0.jpgpic1.jpg

      pic2.jpgpic3.jpg

       

      So it appears that I do indeed have an ODBC System Data Source for BI Server that can connect to my OBIEE repository.  It behaves just like it did in 11g.

       

      So, what else might be wrong?  I found this blog, which mentions that obis1 is probably listening on port 9514, but that NQSConfig.ini might still have a bad RPC_SERVICE_OR_PORT pointing to 9703.

      https://myobieespace.wordpress.com/tag/create-obiee-12c-system-dsn/

       

      In my system, I do indeed see that obis1 is using port 9514:

      pic5.jpg

       

      ...and I also see in nqsconfig.ini that the RPC_SERVICE_OR_PORT parameter is still set to the old default 11g value of 9703:

      RPC_SERVICE_OR_PORT = "9703";  # default is 0.0.0.0:9703 - This Configuration setting is managed by Oracle Enterprise Manager Fusion Middleware Control

      LISTEN_ADDRESS = "0.0.0.0";  # default is 0.0.0.0

      LISTEN_PORT = 9703;  # default is 9703

       

      However, that blog is not clear as to whether that parameter and/or the LISTEN_PORT parameter actually need to be changed, nor does it specify where in FMC to make the change.

       

      So, I just took a guess.  I manually changed nqsconfig.ini to refer to the 9514 port, both for the RPC_SERVICE_OR_PORT and the LISTEN_PORT parameters, replacing the original 9703 for each.  After doing that, I restarted the BI Server service.  The system seems to be working fine, thank goodness.

       

      But I still cannot connect to the repository in online mode.  The NQSConfig.ini file is good - it still refers to port 9514.  But I get exactly the same result as shown in the first screenshot above.

       

      BTW, "Disallow RPD Updates" is not ticked on the Configuration...Performance screen in FMC.  Also, I know that online mode is not the preferred method of changing a repository.  I'm not attaching in online mode to change anything.  I just need to be able to 'Manage...Cache' to see what is happening in the data cache.

       

      Thoughts?  What am I missing?