1 Reply Latest reply on Aug 11, 2017 4:22 AM by Parks-Oracle

    Web start application not loading in Internet Explorer with Java 8 x64 JRE Why?

    SteveH57

      When I connect to a server to get and deploy my web start application in Internet Explorer 11, I see a flash of the browser's Download popup that says 8.8KB of webstart.jnlp was downloaded and it has buttons to Cancel or Show Downloads. (It took many tries to catch the text since it disappears quickly.) The application never loads and the jnlp file does not show up in the View Downloads of IE. It never gets to the point of launching Java as I have the Java Console set to Show with all of the Debugging options on. I have installed the latest 64 bit JRE from Java 1.8.0_144.  I am running on Windows 10 with the last Creator update with IE 11 Version 11.483.15063.0.

      I found online a workaround by uninstalling the 64 bit JRE and installing the 32 bit one. The problem is I need the 64 bit version to operate properly. Also our software is deployed at various sites and to have them remove their Java 8 x64 JREs will be a problem.

      Things I've tried:

      1. Installed 64 bit only and doesn't work.
      2. Installed 32 bit only and it works.
      3. Installed both the 64 bit and 32 bit at the same time and from the Java Control Panel I disabled the 64 bit JRE but that didn't work.
      4. Installed only Java 7 64 bit (1.7.0_80), and it works.
      5. Downloaded the jnlp file locally and when I double click on it the application loads fine. So Windows knows to launch the jnlp file using the Java Web Start Launcher.
      6. Installed Java 9+181 x64 JRE. Do not do this. Nothing worked related to Java Applets or Web Start in IE. Had to uninstall all JREs and reinstall to get things to run.

       

      The place online where I found the workaround said this occurred for them after doing the Creators update for Windows 10.

      Is there anything else I can try?