7 Replies Latest reply on Aug 23, 2017 1:14 PM by rthampi

    R12 (12.0.6) | Opening general preferences page error

    rthampi

      Hello guys

      pre_error.png

      We've upgraded the database from 10.2.0.3 64Bit to 11.2.0.4 for our EBS R12 12.0.6 a month back & once the users started complaining about not receiving notifications by email, tried to access the preferences page to evaluate whether they have right email options selected. To our utter dismay, realized that as soon as the Preferences link from HTML page is clicked, an error message  "You have encountered an unexpected error. Please contact the System

      Administrator for assistance." started being shown

      While rest of the system is intact with no other visible issues, pry your help to resolve this error.

       

      Thank you

        • 1. Re: R12 (12.0.6) | Opening general preferences page error
          mdtaylor

          There are two things you can do:

           

          - Check the alert log for errors on the database

          - Set FND: Diagnostics and Utilities: Diagnostics to yes for a user and click on Preferences. You will now see a click here for details link. Click on the link and post the error details.

          • 2. Re: R12 (12.0.6) | Opening general preferences page error
            rthampi

            Thank you mdtylor for you reply

            Please find the error below, it looks like NLS related

             

            Exception Details.
            oracle.apps.fnd.framework.OAException: oracle.jbo.SQLStmtException: JBO-27122: SQL error during statement preparation. Statement: SELECT * FROM (select t.territory_short_name territory_name, t.nls_territory from fnd_territories_vl t, v$nls_valid_values v where t.nls_territory = v.value and v.parameter = 'TERRITORY') QRSLT ORDER BY territory_name at oracle.apps.fnd.framework.OAException.wrapperException(OAException.java:896) at oracle.apps.fnd.framework.webui.OAPageErrorHandler.prepareException(OAPageErrorHandler.java:1169) at oracle.apps.fnd.framework.webui.OAPageBean.renderDocument(OAPageBean.java:3117) at oracle.apps.fnd.framework.webui.OAPageBean.renderDocument(OAPageBean.java:2914) at _OA._jspService(_OA.java:228) at com.orionserver.http.OrionHttpJspPage.service(OrionHttpJspPage.java:59) at oracle.jsp.runtimev2.JspPageTable.service(JspPageTable.java:335) at oracle.jsp.runtimev2.JspServlet.internalService(JspServlet.java:478) at oracle.jsp.runtimev2.JspServlet.service(JspServlet.java:401) at javax.servlet.http.HttpServlet.service(HttpServlet.java:856) at com.evermind.server.http.ResourceFilterChain.doFilter(ResourceFilterChain.java:64) at oracle.apps.jtf.base.session.ReleaseResFilter.doFilter(ReleaseResFilter.java:26) at com.evermind.server.http.EvermindFilterChain.doFilter(EvermindFilterChain.java:15) at oracle.apps.fnd.security.AppsServletFilter.doFilter(AppsServletFilter.java:318) at com.evermind.server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:610) at com.evermind.server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:359) at com.evermind.server.http.HttpRequestHandler.doProcessRequest(HttpRequestHandler.java:870) at com.evermind.server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:451) at com.evermind.server.http.AJPRequestHandler.run(AJPRequestHandler.java:299) at com.evermind.server.http.AJPRequestHandler.run(AJPRequestHandler.java:187) at oracle.oc4j.network.ServerSocketReadHandler$SafeRunnable.run(ServerSocketReadHandler.java:260) at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:303) at java.lang.Thread.run(Thread.java:595) ## Detail 0 ## java.sql.SQLException: ORA-00600: internal error code, arguments: [1350], [1], [23], [], [], [], [], [], [], [], [], []

             

            Our DBA has tried to setup the NLS parameters once after the error was reported, however it ended up with cost manager failing to create tmp files under /usr/tmp, forcing us to rollback. Please let me know whether it needs to be patched, or an easy alternative if available.

             

            regards,

            • 3. Re: R12 (12.0.6) | Opening general preferences page error
              stejac

              put your ora-600 in the magic tool sometime it give good result

              ORA-600/ORA-7445/ORA-700 Error Look-up Tool (Doc ID 153788.1)

              • 4. Re: R12 (12.0.6) | Opening general preferences page error
                rthampi

                Thanks for stopping by stejac , Actually the problem is specific to application instance as I have mentioned & related to NLS settings in the environment settings. We already tried few changes and the TEST instance is working fine till the moment without producing more errors or issues accessing preferences page.

                We changed ORA_NLS10 (11.2.0.4 database) parameter to $ORACLE_HOME/nls/data from $ORACLE_HOME/nls/data/9idata (Which was as instructed by Oracle while migrating from 10g to 11g for R12.0.x (DBA's claim)

                Anyway I will get back to this post after monitoring the test instance for 5 days and confirmed whether switching the NLS settings resolved.

                 

                Regards,

                • 5. Re: R12 (12.0.6) | Opening general preferences page error
                  mdtaylor

                  I am not sure that is the correct solution.  Please see the following notes for 11gR2.

                   

                  ORA-600 [1350] Error Raised When E-Business Suite Is In Use (Doc ID 1117757.1)

                  ADSTATS.SQL FAILS On 12.1.3 With ORA-20011 ORA-00600: internal error code, arguments: [1350] On V$NLS_VALID_VALUES (Doc ID 2044698.1)

                   

                  Just try to select from v$nls_valid_values after restarting the database and running perl $ORACLE_HOME/nls/data/old/cr9idata.pl.

                  1 person found this helpful
                  • 6. Re: R12 (12.0.6) | Opening general preferences page error
                    rthampi

                    Hello mdtaylor

                    Thank you very much for the continued interest in the subject. I have gone thoroughly through the documents you have provided and as our DBA insists, the documents are referring to 9idata for ORA_NLS10 (11.2.0.4) database.

                    Now I am totally at a loss as I have rolled back the TEST instance NLS environment to 9idata and restarted the server & could access the preferences page & even the costing & certain HR/Payroll related Oracle forms which were popping up error related to NLS settings have been confirmed as functioning properly. As we have a part time DBA, I am waiting for him to bounce the production instance once again, followed by a complete restart to insure that he has replicated same environment parameters for both Production and TEST instances.

                    Thank you very much for the leads, it saved me few days long stress.

                    I will post the progress as they happen.

                     

                    Thanks once again.

                    • 7. Re: R12 (12.0.6) | Opening general preferences page error
                      rthampi

                      Dear mdtaylor

                      I think we have pinpointed the situation as the one explained in this thread

                       

                      Changes are applied to TEST instance and will post the results once after verifying.