7 Replies Latest reply on Jul 20, 2018 11:14 AM by op123

    OVM Server installation error: losetup

    3481293

        Hi,

       

        While installing ORacle VM Server for x86_64 (v 3.4.2 or 3.4.3) I'm getting and error from Anaconda:

        RuntimeError: Error running losetup:

        Usage: losetup [-d] <loopdev> [file]

        losetup: error: no such option: -f

        After the message installation is aborted.

      screen02.PNG

        I downloaded again the iso image in case it was the wrong version but got same results

       

        Any suggestion?

       

        Thanks,

        • 1. Re: OVM Server installation error: losetup
          SantiagoB

          Same happened to me

          This happens when you boot OVM from a usb stick media , try booting ovm server installer from a dvd or nfs installation image.

           

          Regards

          • 2. Re: OVM Server installation error: losetup
            3481293

              Thanks! you're right, boot from a DVD did the trick.

            • 3. Re: OVM Server installation error: losetup
              3466004

              It is possible to burn a usb stick correctly.

               

              Its annoying they don't just produce a dd'able image like every other distro does.

               

              This is how I did it in Linux, its odd I needed to use both Unetbootin and the Oracle usb script (twice) (Install_OL_fromUSBStick_Script) in order to make it correctly boot and run through the installer.

               

              In this example my USB drive is using /dev/sdc, feel free to use this, I can 100% say it works all the time.

               

              1 First dd usb stick to wipe

              # sudo dd if=/dev/zero of=/dev/sdc bs=1M count=128

              2 parted - create msdos table

               

              # parted /dev/sdc mktable msdos

               

              3  fdisk -> new partition, type : b 'W95 FAT32" - 4GB MAX !

              # sudo mkfs -t vfat /dev/sdc1
              # sudo parted /dev/sdc 'toggle 1 boot'
              # sudo sync

               

              4 Download OracleLinux to USB script from : http://download.oracle.com/technetwork/systems/Install_OL_fromUSBStick_Script

              # sudo ./Install_OL_fromUSBStick_Script /storage/backups/Downloads/iso/OVS-3.4.2-1384.iso /dev/sdc1

               

              5 when finished , take out - reinsert USB - then use unetbootin to write OVS-3.4.2-1384.iso image -> usb (you need to mount partition first)

               

              6. after unetbootin has completed, unmount usb partiton - then re-run

              # sudo ./Install_OL_fromUSBStick_Script /storage/backups/Downloads/iso/OVS-3.4.2-1384.iso /dev/sdc1

              After disk should both boot and complete install.

              • 4. Re: OVM Server installation error: losetup
                4aa8c43e-7020-4b22-b15f-ae2be4aeed84

                This wingardium leviosa didn't work for me, same error...

                Installing from .ISO using IDE-R doesn't work either.

                Just in case, I've also tried to install to VM, backup and restore to bare metal and boot from ISO with grub, no luck.

                Seems I'll have to blow the dust from my old USB DVD drive. Thank you Oracle for not forcing an installation from floppy drives

                • 5. Re: OVM Server installation error: losetup
                  ElonDBA

                  I'm attempting to install OVM onto an Intel NUC which has no CD/DVD drive. 

                   

                  Come on Oracle, let's get modern, we need a bullet proof install method utilizing a USB stick.

                  • 6. Re: OVM Server installation error: losetup
                    1151268

                    I cannot agree to using NFS on this method.  I get the same error.

                    • 7. Re: OVM Server installation error: losetup
                      op123

                      Dear 3481293,

                       

                      We experienced the same problem with the USB installer (losetup -f parameter missing) but found a solution.

                       

                      With which tool or option did you create your USB media from the ISO file?

                       

                      On our first approach we created the USB media using "Universal USB Installer" and there selected the distribution "Try unlisted Linux ISO" which produced the error above.

                      Reason is that this option will install a syslinux containing an incompatible iosetup version (without the -f option) on the stick which will than be used during anaconda installation.

                       

                      After we changed the distribution to "CentOS installer" for installing the ISO file onto the stick, the installer went throught as it uses the isos own losetup program (with the -f option) in its chrooted installer environment.

                       

                      So it most likely is the "unlisted Linux ISO" option in your USB installer tool (have not tried any alternative such as RUFUS) which will intall an old or incompatible syslinux folder on your USB stick. Try some distribution/option which installs an "installer" on your stick and which directly load the iso from the stick or try something RHEL or CentOS related.