7 Replies Latest reply on Nov 8, 2017 7:55 AM by JohnGoodwin

    ADD DATA Method

    ISHAV

      Hi, Im trying to execute a data rule in Data Management to export data to a PBCS Application, how ever ADD DATA export method does not add data to existing target data.

      It is a multiperiod source file and i have configured the period and the year in the import format

       

      In EPMAutomate:

      call epmautomate rundatarule RULE_REAL Mar-17 Mar-17 REPLACE ADD_DATA inbox/Datos_reales/REAL_2017_03.txt

       

      For example, in the target application I have in March $400 for an Account, and in the file I have $100, so after executing the rule I want to see $500.

       

      Any clue why the ADD DATA export method is not working?

      Thanks in advanced.

        • 1. Re: ADD DATA Method
          JohnGoodwin

          Are you saying the data is being overwritten in the target application? If you load the data from the workbench or load rule do you still get the same issue? what is the load method type in the load rule

           

          Cheers

           

          John

          • 2. Re: ADD DATA Method
            ISHAV

            Yes John, the data is OVERWRITTEN in the target application. If I execute it from workbench or from the Data Load Rule I get the same behavior.

            Load Method is "All data types with security".

             

            Thanks in advanced.

            • 3. Re: ADD DATA Method
              JohnGoodwin

              Change the load method to "Numeric Data Only" and try the full process again.

               

              It does work using Numeric Data Only

              Data is added correctly.

              • 4. Re: ADD DATA Method
                ISHAV

                Sorry John I do not have that choice in the Target Application Load Method, maybe am I in the wrong place?

                The options that I have are:

                Capture.PNG

                The file type set is "Delimited - Numeric Data"

                • 5. Re: ADD DATA Method
                  JohnGoodwin

                  It is a bug if you create a new rule you should see the "Numeric" option in the load method, if you select one of the all data types then the numeric option seems to disappear.

                   

                  • 6. Re: ADD DATA Method
                    ISHAV

                    Thanks John it worked! I have changed it to Numeric Only like you said!

                     

                    However I couldn't set it in a new Data Rule either, I went to the Setup - Target Application - Application Options and I changed it there, and all my Data Rules where automatically updated to Numeric Data Only.

                     

                     

                    Thank you very much once again!!!

                    • 7. Re: ADD DATA Method
                      JohnGoodwin

                      Yes it is a bit strange how it operates if you select any "all data" types in the target application options it doesn't seem to allow you to set numeric in the load rule, if you select numeric in the target app options you can select any of the types in the load rule, though if you change in the load rule to "all data" then you can't change it back "numeric", I consider it a bug.