0 Replies Latest reply on Nov 8, 2017 12:47 PM by ripleymj

    SQLDev 17.3.1 with IPv6 SSH port forward

    ripleymj

      Has anyone been able to create an SSH port forward to an IPv6 host in SQL Developer? I'm trying in 17.3.1, and it fails with "Status : Failure -Test failed: com.jcraft.jsch.JSchException: parseForwarding: java.lang.NumberFormatException: For input string: "febc"" when hitting the test connection button for the database. The error happens after prompting for SSH credentials, so I believe the connection is successfully established to the IPv4 jump host. I get the error with either the v6 address plain or surrounded by [ ], which are the two common syntaxes I've encountered, though oddly, the "febc" in the error is the 2nd to last block of the address.

       

      I'm able to create the same tunnel in PuTTY running outside SQLDev, and then connect to its port forward, so I don't suspect the database (both 12.1 and 12.2) listener is having trouble receiving the v6 connection. I believe I've tried this off and on with previous versions, never had much luck, and went the PuTTY route instead. I don't have specific versions of SQLDev handy, but I don't believe this is a recent break.

       

      I ran across some guy called "Jeff Smith" yesterday who said I should just plug directly into the database server to avoid this problem, but it's several hundred miles away and I figured I'd throw this out here for a 2nd opinion.

       

      --Mike