11 Replies Latest reply on Dec 5, 2017 10:33 PM by USER1211

    Error while Importing Artifacts

    3494752

      Hello,

      I am migrating the application on 11.1.2.4 version, Hyperion planning EPMA apllication & while importing EPMA,EPMA imported successful, Deploy the application & refreshed the database.

      After that I am trying to import the substitutional variable but I am getting error like "EPMLCM-24000: Artifact not available at source.  /Configuration/Application Definition"

      IMG_3049.jpg

       

      But I am importing the substitutional variable.

      IMG_3050.jpg

       

      If I try to import Data forms, then also I am getting the same error.

       

      I have also try to import other application but also getting the same error.

       

      Please advice.

        • 1. Re: Error while Importing Artifacts
          JohnGoodwin

          What happens if you use LCM to extract substitution variables from the target environment (assuming there is sub vars) and then use the same file to import, does it work?

          if it does this work indicate there is an issue with your LCM  from your source environment

           

          Cheers

           

          John

          • 2. Re: Error while Importing Artifacts
            3494752

            Hello John,

            Thanks for response. I have export sub vars from target & imported for the other application, its done successfully.

            But for this application I have imported the EPMA & Deployed the application & refreshed the Database, which completed successfully.

            But I am not able to import Data forms & sub variable & other artifacts, getting error "EPMLCM-24000: Artifact not available at source.  /Configuration/Application Definition".

            Shared services_Lcm log

            IMG_3072.jpg

             

            In this log showing that Invalid application name RLPLAN in MDF.

            Please advice.

            • 3. Re: Error while Importing Artifacts
              JohnGoodwin

              I am not saying to export then and import then to another app, I am saying export them from the target app and then import them into the same app, so it is the same LCM file, this then narrows down the issue to the LCM export from the source.

              Also is this a different target application name than the source? because the error indicates that it might be and it doesn't exist so it is trying to create the application, if the target application is a different name than the source then do a find and replace on the LCM files to update the application name.

              • 4. Re: Error while Importing Artifacts
                3494752

                Hi John,

                I try to export from target but the target export also failed.

                No, source application name & target application name are same & I created the target application from EPMA import & deployment & refresh database done successfully.

                But while I am going for importing the sub var & data forms, I am getting error which I previously hatched.

                • 5. Re: Error while Importing Artifacts
                  JohnGoodwin

                  If you can't even export and if other applications are fine then I suspect there is something wrong with the application, might be worth considering recreating

                  If there are no other apps then try creating the sample app and see if you can export/import to rule out an environmental issue.

                  • 6. Re: Error while Importing Artifacts
                    3494752

                    Hello John,

                     

                    Thanks for your response.

                    Other applications are fine, Can import & export.Also i can create new application & can perform import,export successfully on Oracle hyperion 11.1.2.4 version & Planning applications.

                    But the application for which I am facing issue was firstly deployed on hyperion 11.1.2.2 version & was working fine & then I have taken the export from LCM successfully, Now I am trying to import on oracle hyperion 11.1.2.4 version,for that EPMA imported successfully but facing issue for other artifacts.

                     

                    Please advice if any possible solution.

                    • 7. Re: Error while Importing Artifacts
                      USER1211

                      Firstly LCM between on premise version is not officially supported by Oracle .

                      The supported upgrade paths are below:

                      https://docs.oracle.com/cd/E57185_01/EPMIS/ch09s01.html

                       

                      If you choose to go that path you are going then you could have to compare the XML for the latest version versus the old version and see if you can manually update the files but as always the risk(and detailed testing) with such approach is solely on you.

                      • 8. Re: Error while Importing Artifacts
                        JohnGoodwin

                        So now you add the important fact that the source and target are different versions, there can be differences between the two versions in terms of format of the LCM files, so you need to put some effort into getting it working.

                        You did say you couldn't export from the 11.1.2.4 application so there is something wrong with it and needs to be resolved first by possibly recreating.

                        1 person found this helpful
                        • 9. Re: Error while Importing Artifacts
                          Srini+K

                          Looks like Import_Export folder not configured using UNC path.  Can you check in shared services console..

                           

                          Foundation->Deployment Metadata->

                              Shared Services Registry

                                 Foundation Services

                                    Shared Services

                                        Properties.****

                           

                          try to export and edit and find...

                          filesystem.artifact.path=C:\Oracle\Middleware\user_projects\epmsystem1\Import_Export

                           

                          this should show up like.. (UNC Path)

                          filesystem.artifact.path=\\servername\import_export

                           

                          all the epm related servers should run services on single directory id which should have write access to this UNC path.

                          • 10. Re: Error while Importing Artifacts
                            3494752

                            Thanks all for your responses.

                             

                             

                            The issue has been resolved.

                            Our source application was deployed in Planning folder but our target application were deployed in the Default Application Group.

                             

                             

                            So we changed the import.xml file from backup folder as shown:

                            Source import:

                            <Source type="Application" product="HP" project="Planning" application="XX"/>

                             

                             

                            Target Import:

                            <Source type="Application" product="HP" project="Default Applicatio Group" application="XX"/>

                            • 11. Re: Error while Importing Artifacts
                              USER1211

                              Once you got the clarity you needed remember to mark the thread as answered so members can focus on unanswered questions.

                              Did Your Question Get Answered in My Oracle Support Community (Doc ID 1180503.1)