1 Reply Latest reply on Nov 29, 2017 1:59 PM by APEX RnD Roeland

    UI Defaults and Blueprint

    APEX RnD Roeland

      Hey

       

      I'm on apex.oracle.com, so APEX v5.1.3.00.05.

       

      I've just spent quite some time in setting up UI Defaults via SQL Workshop > Utilities > User Interface Defaults

       

      I was surprised that the effort didn't pay off. None of my UI Defaults were taken into account when using the Blueprint creating a new app.

      So next I tried a normal wizard and also nothing ... There I randomly picked Interactive Grid. Only to find out later that apparently the IG is not (yet?) setup to use the UI Defaults.

      Next tried another wizard: Form on a report and YES! UI Defaults were used.

       

      So back to the Blueprint.

      One of the settings there is "User Interface Defaults". When I click on that button, I can see some settings, but it looks like the default ones, so not taking into account my changes in the UI Defaults. So I make a change there and generate the app. My UI Defaults again ... not reflected on the pages.

      Also: the changes I make in the UI Defaults page from BP are not represented in the UI Defaults screens from SQL Workshop.

       

      So I'm wondering. Am I doing it all wrong? Or am I trying something that can't be done.

       

      The Table Dictionary shows that all my tables have defaults. It's completely synchronized (0 objects withoud defaults).

      But I do notice that the Attribute Dictionary only shows 9 columns, I would expect a lot more.

      So, on the Table Dictionary tab, there is a link called "Attribute Dictionary Migration". When I go there, I see most of my objects showing up. And I click one specific table I've been using to test with, and I get the message "All the columns in this table already exist in the Attribute Dictionary. There is nothing to migrate."

       

       

      I have now 3 questions:

      1. Can UI Defaults be used with Interactive grid?

      2. Can UI Defaults (from SQL Workshops Utilities) be used in Blueprint? Are the UI Defaults from BP something else then the ones defined in SQL Workshop?

      3. Am I simply missing something?

       

      Thakns for your help!