5 Replies Latest reply on Mar 3, 2018 10:45 AM by 713c7849-fee4-4d0c-9ad7-4c5d7c4efa51

    Failed dependencies error with Datamodeler RPM package

    niksajur

      Hello,

       

      when I try to install the actual Datamodeler rpm package on Oracle Linux 7.4, the installation fails with following error messages:


      # rpm -ivh datamodeler-17.4.0.355.2121-1.noarch.rpm

      error: Failed dependencies:

      osgi(org.netbeans.api.progress) is needed by datamodeler-17.4.0.355.2121-1.noarch

      osgi(org.netbeans.api.progress.nb) is needed by datamodeler-17.4.0.355.2121-1.noarch

      osgi(org.netbeans.modules.editor.guards) is needed by datamodeler-17.4.0.355.2121-1.noarch

      osgi(org.netbeans.modules.sampler) is needed by datamodeler-17.4.0.355.2121-1.noarch

      osgi(org.openide.filesystems) is needed by datamodeler-17.4.0.355.2121-1.noarch

      osgi(org.openide.modules) is needed by datamodeler-17.4.0.355.2121-1.noarch

      osgi(org.openide.text) is needed by datamodeler-17.4.0.355.2121-1.noarch

      osgi(org.openide.util) is needed by datamodeler-17.4.0.355.2121-1.noarch

      osgi(org.openide.util.lookup) is needed by datamodeler-17.4.0.355.2121-1.noarch

      osgi(org.openide.util.ui) is needed by datamodeler-17.4.0.355.2121-1.noarch

       

      It is obvious that Datamodeler rpm package depends on osgi rpm package(s). What rpm package(s) is/are required to satisfy these dependencies?

       

      Thanks a lot in advance.