2 Replies Latest reply on Jan 9, 2018 2:54 PM by Magnanimous

    adcfgclone fails Undefined subroutine NamedCapture.pm line 9

    Mariami Kupatadze

      I am trying to add new app node according to the following doc: Doc ID 1383621.1

       

      But my clone fails at stage 4. Running the following on target node:

       

      [oracle@app2 bin]$ pwd

      /ebs/oracle/PROD/fs1/EBSapps/comn/clone/bin

      [oracle@app2 bin]$ perl adcfgclone.pl appsTier

      ......

       

      Beginning application tier Apply - Fri Dec 29 10:51:43 2017

      /ebs/oracle/PROD/fs1/EBSapps/comn/clone/bin/../jre/bin/java -Xmx600M -DCONTEXT_VALIDATED=true  -Doracle.installer.oui_loc=/oui -classpath /ebs/oracle/PROD/fs1/EBSapps/comn/clone/jlib/xmlparserv2.jar:/ebs/oracle/PROD/fs1/EBSapps/comn/clone/jlib/ojdbc6.jar:/ebs/oracle/PROD/fs1/EBSapps/comn/clone/jlib/java:/ebs/oracle/PROD/fs1/EBSapps/comn/clone/jlib/oui/OraInstaller.jar:/ebs/oracle/PROD/fs1/EBSapps/comn/clone/jlib/oui/ewt3.jar:/ebs/oracle/PROD/fs1/EBSapps/comn/clone/jlib/oui/share.jar:/ebs/oracle/PROD/fs1/EBSapps/comn/clone/jlib/oui/srvm.jar:/ebs/oracle/PROD/fs1/EBSapps/comn/clone/jlib/ojmisc.jar:/ebs/oracle/PROD/fs1/FMW_Home/wlserver_10.3/server/lib/weblogic.jar:/ebs/oracle/PROD/fs1/EBSapps/comn/clone/jlib/obfuscatepassword.jar  oracle.apps.ad.clone.ApplyAppsTier -e /ebs/oracle/PROD/fs1/inst/apps/PROD_app2/appl/admin/PROD_app2.xml -stage /ebs/oracle/PROD/fs1/EBSapps/comn/clone    -showProgress -nopromptmsg

      Log file located at /ebs/oracle/PROD/fs1/inst/apps/PROD_app2/admin/log/ApplyAppsTier_12291051.log

        -     70% completed      

      ERROR while running Apply...

      Fri Dec 29 10:57:31 2017

      ERROR: Failed to execute /ebs/oracle/PROD/fs1/EBSapps/comn/clone/bin/adclone.pl

       

      ###############Log file contains

       

      [oracle@app2 ~]$ less /ebs/oracle/PROD/fs1/inst/apps/PROD_app2/admin/log/ApplyAppsTier_12291051.log

       

      Running.....perl  -I/ebs/oracle/PROD/fs1/FMW_Home/webtier/perl/lib/5.10.0 -I/ebs/oracle/PROD/fs1/FMW_Home/webtier/perl/lib/site_perl/5.10.0 -I/ebs/oracle/PROD/fs1/EBSapps/appl/au/12.0.0/perl -I/ebs/oracle/PROD/fs1/FMW_Home/webtier/ohs/mod_perl/lib/site_perl/5.10.0/x86_64-linux-thread-multi /ebs/oracle/PROD/fs1/EBSapps/appl/ad/12.0.0/patch/115/bin/adProvisionEBS.pl ebs-create-node -contextfile=/ebs/oracle/PROD/fs1/inst/apps/PROD_app2/appl/admin/PROD_app2.xml -machinelistenaddress=app2.example.com -logfile=/ebs/oracle/PROD/fs1/inst/apps/PROD_app2/admin/log/ApplyAppsTier_12291051.log -promptmsg=hide

       

       

      .end std out.

      Undefined subroutine &Tie::Hash::NamedCapture::flags called at /ebs/oracle/PROD/fs1/FMW_Home/webtier/perl/lib/5.10.0/Tie/Hash/NamedCapture.pm line 9.

      Compilation failed in require at /ebs/oracle/PROD/fs1/FMW_Home/webtier/perl/lib/5.10.0/English.pm line 148.

      BEGIN failed--compilation aborted at /ebs/oracle/PROD/fs1/FMW_Home/webtier/perl/lib/5.10.0/English.pm line 148.

      Compilation failed in require at /ebs/oracle/PROD/fs1/EBSapps/appl/ad/12.0.0/patch/115/bin/adProvisionEBS.pl line 28.

      BEGIN failed--compilation aborted at /ebs/oracle/PROD/fs1/EBSapps/appl/ad/12.0.0/patch/115/bin/adProvisionEBS.pl line 28.

       

      .end err out.

       

      Script Executed in 401 milliseconds, returning status 255

      Failed to add a node app2.example.com

       

      Can you help me to identify the problem?