4 Replies Latest reply on Jan 12, 2018 7:29 AM by Puneet Singh-Oracle

    500 Internal server error after 17.4 install

    Puneet Singh-Oracle

      Hi,

       

      I recently tried ords.17.4.1.353.06.48 version. However after setting up everything, it returns following error on any URL request :-

       

      Could not invoke: oracle.dbtools.url.mapping.node.NodeMapper(oracle.dbtools.plugin.api.logging.Log,oracle.dbtools.common.di.ServiceLocator,oracle.dbtools.http.dispatch.MetaDataFactory,oracle.dbtools.http.routes.RoutePatterns,oracle.dbtools.http.servlet.DispatchableServletDependencies), due to the following error: oracle.dbtools.common.di.DependencyInjectionException: Could not invoke: oracle.dbtools.rest.resource.modules.xml.StaticModules(oracle.dbtools.plugin.api.logging.Log,oracle.dbtools.rest.resource.modules.xml.StaticManifests,oracle.dbtools.common.reflect.ClassLoaderResources,oracle.dbtools.rest.resource.modules.xml.XMLResourceModules,oracle.dbtools.plugin.api.routes.PathTemplates,oracle.dbtools.rest.resource.modules.ResourceModulePatterns,oracle.dbtools.rest.resource.jdbc.hooks.JDBCDispatchHooks,oracle.dbtools.rest.resource.modules.xml.StaticPrivileges,oracle.dbtools.rest.resource.generator.ResourceGenerators), due to the following error: oracle.dbtools.common.UnrecoverableException: Exception Description: The class oracle.dbtools.rest.resource.modules.xml.Content requires a zero argument constructor or a specified factory method. Note that non-static inner classes do not have zero argument constructors and are not supported.

       

      ORDS validate (command output)

       

      Oracle REST Data Services will be validated.

      Validating Oracle REST Data Services schema version 17.4.1.353.06.48

      ... Log file written to /scratch/ords/logs/ords_validate_core_2018-01-09_032616_00462.log

      Completed validating Oracle REST Data Services version 17.4.1.353.06.48.  Elapsed time: 00:00:03.406

       

       

      The setup was a complete uninstall followed by fresh install of 17.4 version. Advanced setup mode was not used.

       

      Platform details:-

       

      Oracle Database 12c Enterprise Edition Release 12.2.0.1.0 - 64bit Production

      Apex 5.0.3.00.03

      Weblogic 12.2.1.2.0 Production mode

       

      Reverting to ords.3.0.12.263.15.32 worked fine for us. Any insights on what's wrong with our 17.4 setup would be helpful.

       

      Thanks,

      Puneet