1 2 3 Previous Next 62 Replies Latest reply on Apr 30, 2018 1:37 PM by NLee123

    Forms and new jre 1.8.0_161

    Matthew D.

      Since yesterday with new jre 1.8.0_161 i have a problem with my forms application.

       

      java version "1.8.0_161"

      Java(TM) SE Runtime Environment (build 1.8.0_161-b12)

      Java HotSpot(TM) Client VM (build 25.161-b12, mixed mode)

       

      In menu we are using trees and at some point we get this:

       

      tree1.png

       

      but it should be like this:

      tree2.png

       

      With previous jre version 1.8.0_152 with did't have any problems.

      We are on forms 12.2.1.2 on Linux 6.9 x64. I'm using fsal to start application.

      Is there anyone who can test new jre with trees in forms?

       

      Regards

        • 1. Re: Forms and new jre 1.8.0_161
          Frank Hoffmann

          I have no problems with 8.161 so far...

           

          Windows (we have a tree demo on forms12c.com) seems to work fine with 161

          start /min "Oracle Forms 12c Console" java.exe -jar frmsal_windows_12213.jar -url "https://forms12c.com/forms/frmservlet?config=demo0014"

           

          and I checked FSAL via JRE 161 (32 Bit) against Solaris (12213) - no problems

           

          Only a Linux issue?

          • 2. Re: Forms and new jre 1.8.0_161
            Matthew D.

            Hi Frank,

             

            txn for reply.

            I tried to test with Internet explorer. Same thing, i need to click several times on tree to get tree without branches.

            Also, i have checked access log on ohs, all requests are getting http 200.

             

            Noticed this: progress bar is stuck in the middle.

             

            tree3.png

             

            Good news is that i can reproduce problem at will.

            If a click on desktop or start another application then return to forms application and click on tree, i don't get full tree.

             

            With jre 1.6.0_152 everything is ok (no problems).

             

            Demonstration:

             

            tree.gif

             

            Regards

            • 3. Re: Forms and new jre 1.8.0_161
              Michael Ferrante-Oracle

              It looks like you are using custom images in your tree.  This suggests that there may be an issue with your jar file that contains the images.  I would recommend checking the certificate you are using.  Ensure that the certificate uses SHA256 and that it is valid.  Also, enable tracing in the Java Control Panel (Advanced tab).  Run the form to the point of failure then look very closely at the java console.  Specifically look for exceptions, "File not found" errors, or anything that might cause the images or branches to not populate. 

               

              It is unlikely that changing the JRE version is causing the problem unless the issue is related to the digital signature in your jar.  Therefore, it might be worth rolling back to 152 to prove this theory.  If rolling back results in the form doing the right thing, uninstall that version then install u162.  Before running anything, open the Java Control panel and on the General tab. click on Settings > Delete Files... > check "Installed Applications and Applets" > OK.  Then retest.

               

              If this still fails, I recommend contacting Oracle Support and be prepared to provide a reproducible test case that Support can run.  In other words, do not attempt to send them your form because obviously they won't be able to run it because they don't have your db.  Provide a very simple test cases that uses the same jar that contains your images.

              • 4. Re: Forms and new jre 1.8.0_161
                Matthew D.

                There is no problem with certificate, it is a new certificate which uses SHA256.

                 

                There is no errors in Java Console.

                 

                 

                Nothing is changed on server. On my machine only new is java 1.8.0_161, because of Oracle CPU for January 2018.

                Also, tried with 1.8.0_162, same problem.

                 

                 

                I have java 1.8.0_152 (without installation) which i'm using for testing fsal.

                With this java version there is no problem.

                 

                Regards

                • 5. Re: Forms and new jre 1.8.0_161
                  Michael Ferrante-Oracle

                  Please contact Support so that we can investigate the behavior and get it fixed if there is truly a defect.

                   

                  I tested Forms 12.2.1.3 with Java 8u162 using a custom jar (with icons) and cannot reproduce the problem.  My tree nodes display correctly and also show the node image.

                  • 6. Re: Forms and new jre 1.8.0_161
                    Matthew D.

                    Tried with forms 12.2.1.3.

                     

                    Same thing: 1.8.0_152 ok, 1.8.0_162 not ok.

                     

                    I will open SR with Oracle support.

                     

                    Regards

                    • 7. Re: Forms and new jre 1.8.0_161
                      Matthew D.

                      Hi Frank, can you check this:

                       

                      1) I'm starting demo from https://forms12c.com/

                       

                      Look at logon screen:

                      s1.png

                       

                      Now, click somewhere on desktop, and logon screen will be like this:

                       

                      s2.png

                       

                      Notice, that window title is now in diff color.

                       

                      Now try to back to logon screen click on window title or user or password.

                       

                      You will notice that logon window is not getting focus, but if you click on image in logon screen window will get focus.

                       

                      Something is changed with new jre.

                       

                      Can you check this?

                      I'm working with IE and jre 1.8.0_161.

                       

                      Regards

                      • 8. Re: Forms and new jre 1.8.0_161
                        Frank Hoffmann

                        Matthew,

                         

                        yes, now I can reproduce this on the demo server with 1.8.0_161. But it seems to come up sporadic. First time click I saw it .. than after a couple of seconds it went away. Second try it was a different behavior but also a focus problem. After some click everything was fine. Third try not reproducable. We will do our FSAL rollout on 5.000 Clients with 1.8.0_152 to be sure that we do not run into this.

                         

                        Maybe it has to do with the new security feature in 161 and 162. The Java Applet connection is now trying to use the highest security protocol available. You will probably see this in wireshark. This might be the reason why the synchronization is slower or hangs from time to time (depending on the Network).

                         

                        Can you try to reproduce this with a http connection to the demo Server - I could not reproduce this with http

                         

                        http call

                        Forms12c.com | demo0001

                         

                        Frank

                        • 9. Re: Forms and new jre 1.8.0_161
                          Matthew D.

                          Hi Frank,

                           

                          txn for reply and help.

                           

                          I can confirm that same problem exists with http:

                           

                          http.png

                           

                          Look at the progress bar, it stuck in the middle.

                           

                          Still waiting response from Oracle support.

                           

                          Regards

                          • 10. Re: Forms and new jre 1.8.0_161
                            Frank Hoffmann

                            Matthew,

                             

                            I have rolled back my Installation to JRE 1.8.152 and the problem is not reproducable on the demo site (http/https).

                            The bad thing is that with _152 a warning pops up to update the JRE Version to a newer version.

                             

                            I gave an warning adive for 1.8.161/2 to my customers so they don't search for this bug in the software.

                             

                            Thank you for this this post. FSAL seems the best choice because you are no longer dependend on problematic Client JRE versions.

                             

                            Frank

                            • 11. Re: Forms and new jre 1.8.0_161
                              Michael Ferrante-Oracle

                              Matthew,

                               

                              If you share your SR number with me, I would be happy to follow up with Support.  Feel free to share it here or email or Twitter message me directly if you are not comfortable sharing it here.

                               

                              Also, keep in mind that Oracle is investigating at least one focus bug (20308814).  This may or may not be related to the issue here, but it does seem similar.

                               

                              That said, what would be helpful in this case is to know if the issue is reproducing in a form that does not have a Java Bean or PJC.

                              • 12. Re: Forms and new jre 1.8.0_161
                                Matthew D.

                                Hi Michael,

                                 

                                service number is SR 3-16682307101.

                                 

                                So far i have this observations:

                                 

                                1) problem is with focus, form window is not getting focused when returning to forms application

                                Frank Hoffman also confirmed this on his demo application.

                                2) with jre 1.8.0_161 and 162 i can reproduce the problem at will

                                3) with jre 1.8.0_152 i can't reproduce the problem (same as Frank Hoffman)

                                 

                                I'm using webutil with my applications (don't know about Franks login form on forms demo).

                                 

                                Regards

                                • 13. Re: Forms and new jre 1.8.0_161
                                  Michael Ferrante-Oracle

                                  As I mentioned, it will be a very helpful piece of information for Oracle developers to know if the issue reproduces in a form that does not have Beans or PJCs.  WebUtil is a set of Java Beans.

                                   

                                  Frank's logon form uses WebUtil, therefore Beans.

                                  • 14. Re: Forms and new jre 1.8.0_161
                                    Michael Ferrante-Oracle

                                    Matthew,

                                     

                                    I just looked at the SR and it was routed to the wrong team.  It has now been routed to the Forms team.  In order to save you some time and move this faster, you need to provide the following (in the SR):

                                     

                                    1.  The client platform info (OS/version, browser and version, etc)

                                    2.  A simple test case that Support can run. Ideally it would be based on the demo tables in the SCOTT schema.

                                    3.  They are also going to want to know if you've tried this in 12.2.1.3.  If you have not, that's ok, but let them know either way.

                                     

                                    Providing this information before they ask could save some time.  Also, if you upload a test case soon, I can personally do some investigating as time permits.

                                    1 2 3 Previous Next